1 10 11 12 13 14 Previous Next 199 Replies Latest reply: Apr 8, 2010 8:35 PM by Robert Bosch Go to original post
  • 180. Re: Copying to Network Drive Error code -36
    Tony Kambourakis1 Level 1 Level 1 (25 points)
    Has anyone had any success in resolving this error when copying to a firewire attached Drobo via the network from a Mac to a Mac?

    I tried the steps outlined in KB article but no success.
  • 181. Re: Copying to Network Drive Error code -36
    coldrick Level 1 Level 1 (0 points)
    Many thanks for that, herveyw. That fixed my problem as well. The share I could no longer copy files to was a CIFS share on opensolaris. Followed the instructions and all works fine now. Outstanding!

    Regards,
    David
  • 182. SMB Error code -36 SOLUTION
    Redfish123 Level 1 Level 1 (5 points)
    THIS IS MY SOLUTION FOR ERROR CODE 36 CONNECTING TO SMB SHARES ON WINDOWS SYSTEMS

    I had the same problem and kept beating my head. After reading numerous posts with fix issues using dot_clean and many others this is what I found that works for me. I have multiple Network Drive Shares on 2 Windows 7 computers and connect via smb. I was able to transfer files via the Terminal using the cp command, but the solution below allowed me to transfer via Finder again without having to use the terminal anymore.

    I was sharing the entire drive (ex: E:\) and was going over permissions and everything looked fine. The user I was connecting as had Full Control permissions. Then I realized maybe I should look at who the Owner of drive was under Properties > Security > Advanced > Owner: System was the Owner. I then clicked the Change Permissions Tab and changed the Owner to my user name on the system. Poof every thing was worked again.

    So my steps were:

    1. Right Click the Drive Share
    2. Select Properties
    3. Select Security Tab
    4. Choose Advanced
    5. Select Owner Tab
    6. Change the Current Owner from System to Your "User Account" (ex: John Doe)
    7. Check Replace Owner on Subcontainers and Objects
    8. Click Apply then Ok on each of the boxes till all are closed.
    9. Try to reconnect to the share and transfer files
  • 183. Re: Copying to Network Drive Error code -36
    oddshoes Level 1 Level 1 (0 points)
    I was having this problem between my mac pro and iDisc and appear to have solved the problem at least in my case.
    Analysis: The problem is intermittent - tried from more than one drive no change thus not drive problem. Copies between drives thus not os problem here. Assume no hardware prob at .me. Thus problem in-between. On net there are reams of stuff about this problem. error code -36 seems to = sorry there is a problem. Noticed there were a few streams about going through windows samba servers and not coping with unusual characters in file names so removed the _ from the file name = worked first time or I got lucky, but I'm not clever enough to know which!
    Hope this helps someone. I find the help on the net very valuable and was starting to be a bit embarrassed that I only took but never gave back!
    cheers
  • 184. Re: Copying to Network Drive Error code -36
    jamesbelbin Level 1 Level 1 (0 points)
    any further updates. i am still struggling to use itunes (it wont burn any songs if i use my sharedrive as the location folder for songs) or watch any videos/files kept on the share either.....

    just to add, it all worked fine in the previous version, it appears to be purely snow leopard related.

    Tried dot clean and the stream fix.
    Using snow leopard and a landrive using SMB.

    james
  • 185. Re: Copying to Network Drive Error code -36
    thunderbolt Level 1 Level 1 (0 points)
    This works, when trying to connect from a PowerBook G4 running Mac OS 10.4.11 to a Windows 7 Pro 64-bit (BOOTCAMP on a Mac Pro) ...

    Connect to Server:

    smb://ipaddress_ofserver/SHARE

    Note the capital letters "SHARE" for the network share on the "PC."

    Now, about the copying problem ...

    Experimenting with the Mac command line, I found that the cp command would copy items where the Finder would not, but still, I get errors on occasion --- on the command line, they show as "Cannot allocate memory."

    I have no idea, if that is a true error report or just a guess by the Mac OS command line bash shell whatever.

    Whether copying with the Finder (all too familiar Error code -36 or Error code -41) or copying at the command line using cp, the result is cosmic, but certainly there is more success when copying by using cp at the command line, than using the Finder.

    Also, there seems to be an improvement by removing the .DS_Store file of the Mac directory to which I am trying to copy a file or a folder from the "PC."

    I suspect that basically, there is a wobbly SMB "handshake" instead of a good, "firm" SMB "handshake" going on, and both Apple and Microsoft are interested in a fix, but a Samba + Apple + Microsoft project team that is determined to solve the problem, has not fixed it, yet.

    I suspect that a lot of the "Hey! This works!" reports, are mostly improvement on the odds --- increasing the occurences of success over failure --- but no solid THIS WORKS, yet.

    Our solution for copying, therefore, has been to --- at the "PC" --- copy the files of interest, to an office network SMB share (we use an Intel Mac Mini running Mac OS 10.5.8 and the smb.conf file set up to share a directory) ... and that has been working OK, and then any Mac users pick up the files, from that "Windows server" ... instead of directly from the Windows 7 Pro 64-bit "PC."
  • 186. Re: Copying to Network Drive Error code -36
    thunderbolt Level 1 Level 1 (0 points)
    Given that I suspect the SMB problem - I meant to add, that applies to making the connection, not the copying.

    I just did some more testing, and easily, the cp command at the command line, trumps the Finder.

    Also, removing the .DS_Store file of the destination directory, again improves the odds ... and this relates to my previous post, about the "Cannot allocate memory" error. If the .DS_Store file is removed from the destination directory on the Mac, then a follow up cp command, copying a file from the "PC" to the destination directory, succeeds.

    So, there's a lot to be said for those who have observed that the Finder, whether Mac OS 10.4.11, 10.5.8, 10.6.2, fails when trying to do its dotdirectorystorage chores.
  • 187. Re: Copying to Network Drive Error code -36
    thunderbolt Level 1 Level 1 (0 points)
    Repeating (from my reply above) what worked for us, trying and succeeding at a connection, from a Mac to a Windows 7 machine:

    This works, when trying to connect from a PowerBook G4 running Mac OS 10.4.11 to a Windows 7 Pro 64-bit (BOOTCAMP on a Mac Pro) ...

    Connect to Server:

    smb://ipaddress_ofserver/SHARE

    Note the capital letters "SHARE" for the network share on the "PC."

    Also works from a Mac running Mac OS 10.5.8 "Leopard."

    - - - - - - -

    Now came the other difficult part - copying.

    It seemed to fail 7 times out of 10, with a "Error code -41" if using the Finder, or 3 times out of 10 at the command line, using the "cp" command, with an error, "cannot allocate memory".

    We tried the fix recommendation found online, which was to disable SMB2 on the Windows 7 machine. Some Windows 7 users tried this:

    http://blogs.technet.com/srd/archive/2009/09/18/update-on-the-smb-vulnerability. aspx

    Other Windows 7 users tried that manually - editing the Registry - to disable SMB2.

    Disabling SMB2 on the Windows 7 machine, did NOT work for us.

    So, we searched more online, using keywords "cannot allocate memory" with "windows 7" and finally found what works:

    http://alan.lamielle.net/2009/09/03/windows-7-nonpaged-pool-srv-error-2017

    That guy is a genius. Somebody give him a medal. Make him a "Hero of the Soviet Union! Dah!"

    He states: "Apparently you need to tell Windows that you want to use the machine as a file server and that it should allocate resources accordingly."

    His Registry fixes, at his webpage:

    - - - FIRST - - -

    Set the following registry key to 1 (Decimal):

    HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management\LargeSystemCache

    - - - SECOND - - -

    [S]et the following registry key to 3 (Decimal):

    HKLM\SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters\Size

    "After making these changes and restarting, I haven’t seen this issue arise again. Fixed!"

    Yes, that did fix the copying problem.

    I can hardly believe it.
  • 188. Re: Copying to Network Drive Error code -36
    BROOKLYNTREEZ Level 1 Level 1 (120 points)
    looks like Apple are about to fix this problem:

    http://www.appleinsider.com/articles/10/03/18/releaseof_apples_mac_os_x_10_6_3_update_appearsimminent.html

    Highlight: Other fixes baked into the release target issues with mail messages displaying the incorrect background color and problems copying files to a shared Windows volume.

    About friggin time!
  • 189. Re: Copying to Network Drive Error code -36
    Han van Vilsteren Level 1 Level 1 (0 points)
    See here whats happening with wireshark:

    10.0.0.200 is the Windows 7 machine. 10.0.0.253 is the iMac.

    No. Time Source Destination Protocol Info
    23 6.200303 10.0.0.200 10.0.0.253 SMB Negotiate Protocol Response, Error: Out of memory

    Frame 23 (105 bytes on wire, 105 bytes captured)
    Ethernet II, Src: 02:23:54:80:b4:22 (02:23:54:80:b4:22), Dst: Apple_f2:be:60 (d4:9a:20:f2:be:60)
    Internet Protocol, Src: 10.0.0.200 (10.0.0.200), Dst: 10.0.0.253 (10.0.0.253)
    Transmission Control Protocol, Src Port: microsoft-ds (445), Dst Port: 49177 (49177), Seq: 1, Ack: 52, Len: 39
    NetBIOS Session Service
    SMB (Server Message Block Protocol)
    SMB Header
    Negotiate Protocol Response (0×72)
  • 190. Re: Copying to Network Drive Error code -36
    BROOKLYNTREEZ Level 1 Level 1 (120 points)
    Not sure if all your issues have been resolved now that Apple has released an update, but Im still haveing the same issue. this time its a (error code-50)

    same issues as the Error code -36. My macs are in a huge corporate enviroment, so poking around the windows servers is a big no no.

    Any insight as to what this error is?

    just to clear up, dragging a folder on the SMB server results in a Error -50, creating a folder and dragging the files individually seems to be ok.

    I guess I will have to get in touch with Apple directly. Any help will be appreciated.
  • 191. Re: Copying to Network Drive Error code -36
    BROOKLYNTREEZ Level 1 Level 1 (120 points)
    Seemed top have found an low tech non-terminal solution for error-50.

    Label the folder a color, then drag on top the server. Should be good to go, and certainly weird!
  • 192. Re: Copying to Network Drive Error code -36
    maxsquared Level 1 Level 1 (0 points)
    OK 10.6.3 is out, but the problem (error 36) with NAS drive is still not solved for me.
  • 193. Re: Copying to Network Drive Error code -36
    bluetooth Level 1 Level 1 (45 points)
    I've updated to 10.6.3 and it's not resolved either! It's kind of odd... I can transfer .dmg files, but not folders containing files in them.
  • 194. Re: Copying to Network Drive Error code -36
    BROOKLYNTREEZ Level 1 Level 1 (120 points)
    Try changing the color label of the folder.