Previous 1 6 7 8 9 10 Next 199 Replies Latest reply: Apr 8, 2010 8:35 PM by Robert Bosch Go to original post
  • Stuart Marden Level 1 Level 1 (5 points)
    Also not working after 10.6.2 update

    I also tried re-programming from the Terminal to use non encrypted passwords but still no good.
    http://support.apple.com/kb/TS1564?viewlocale=en_US

    I think we should all write a letter to their offices - requesting information on this subject

    For me in Europe that address is:

    Apple Ltd
    Holyfield Industrial Park
    Cork, Republic of Ireland

    If you live in the United States, try this address:

    Apple Computer, 1 Infinite Loop, MS60-DR, Cupertino, California, USA, 95014

    Here's hoping.....
  • Oliver Kess Level 1 Level 1 (45 points)
    Dear Daniel Palmer,
    would you please share your wisdom with us instead of yelling around that it is working for you?....

    What kind of server are you using?
    What software version?
    What are your ACL settings?
    With what kind of test did you verify it is working for you?
    What kind of document did you copy?
    Did you use an application to save your document to your server?
    If yes, what version, please name to doc type?
    Seems like a lot of work to you?
    Now you might get the idea how much work it is for the professional user to check out this problem...
    In my case:
    I use Netapp Ontap 7.3.1 (which is said not to be compatible with Snow Leopard....)
    and Win 2003 Server SP2 (which should mean no problem) as server.

    For you netapp users out there, here is a doc that shows mac os compatibility: http://now.netapp.com/NOW/knowledge/docs/olio/guides/ntsp_mac.shtml

    I use the actual Office 2008 Apps, since yesterday with the actual 12.2.3 patch.
    If I try to open and save a .docx I can do that on a given netapp or w2003 share although netapp says it does not work..
    If I try the same with a .doc it fails. It gives the information that it is not able to write the .doc
    Findercopies do work in my case for both the netapp and the w2003 shares. In fact error -36 does not happen here anymore..
    I use the ACL Settings that Brandon Seymour posted above.
    These are no breach in security and do well in terms of findercopies and .docx or .xlsx Documents.

    I tried with 10.6.1 and 10.6.2. That makes no difference. A 10.4.x mac has no problems opening and saving .doc or .docx documents as well as 10.5.

    I figure out that mainly MS Office has this problem. Try saving a Indesign 3.x Document or something simple as Textedit and this will work (for me...) Of course this does not point the whole problem to MS, I simply did not test any more applications..

    I am totally ****** as there is no clue coming from apple why this does not work, while older OS versions do work...

    regards
    Oliver
  • Lord Kamina Level 1 Level 1 (0 points)
    Have you guys tried enabling writing of extended file attributes, like some said earlier?

    I mean, it is fixed for me (Simple File Sharing On), but maybe it's NOT a bug that it will give an error on incorrect permissions if you're actually using the full permission system.
  • Oliver Kess Level 1 Level 1 (45 points)
    Please try the following:
    go to thursby.com and download an eval version of Dave.
    Connect to the smb volume and try whatever you did to copy or save your document.
    Pls write about your results.
    For me, Dave did it. I can open and save .doc and .xls documents out of office 2004 or 2008. Same for every other document. This narrows it definitly down to the SMB / CIFS Implementation of 10.6x
    I do not have this problem in 10.4x or 10.5x.
    I do not have the problem of -36 when saving.
    I use netapp 7.31p3(!) and win2003 shares.
    I only had problems when I tried to save an office (doc or docx, same for excel...) document to theses shares.
    Dear Apple devs, when will you release on OS that does the job of Dave....?
    regards

    Oliver
  • gswd Level 1 Level 1 (0 points)
    as to the "extended file attributes", that is not an option that I have on my NAS device. I do not have a windows network server. When it was first brought up, I looked for some setting like that in my admin interface, and was unable to find one.
  • Oliver Kess Level 1 Level 1 (45 points)
    Problem seems to be solved.
    What remains is the question why 10.4x or 10.5x had no problem and why 10.6x is more sensitive to some ACL Settings.
    How did I solve the problem?
    I figured out that my netapp based SMB shares had the owner of "netapp/administrators". by changing this to "ourActiveDirecotory/Administrators" I was able to fix this problem.
    I do not have a clue why this turns out to be a problem for the macs.
    This solution works for AD bound macs as well as for "standalone" macs that only mount the SMB share with the AD account.
    One addition: Make sure the .Trash and .TemporaryItems folder (if you use MS Office) have Full Access for every share-user.
    regards

    Oliver
  • Stuart Marden Level 1 Level 1 (5 points)
    Hi Oliver

    Could you provide the steps in a bit more detail please?
    Where do I look to change the "netapp/admin" to "ouractivedirectory/admin"?
    On the Mac or the external drive?

    What does AD bound macs mean?

    Many Thanks
    Stuart
  • Oliver Kess Level 1 Level 1 (45 points)
    Hi Stuart,
    these are steps that have to be done on the SMB Server, in our case, this is a netapp bound via ActiveDirectory (AD).
    We manage the shares via our AD Server.
    So this is the place where the changes have to be done.
    We manage our Mac Accounts on AD and manage the settings for the Macs in OD (OpenDirectory).
    google for magic triangle.
    But as I stated before, the solution works (for me) also for Macs that are standalone without directory binding.
    If all of this seems to be quit confusing, I would ask my local admin and show him discussion.

    kind regards

    Oliver
  • dee.pee Level 1 Level 1 (0 points)
    Same here,

    I'm using an FNSA Server, basically an external network harddrive, since installing leopard, I can't open files form the FNSA drive with my Macbook and can't save to the drive either. Everything was fine until I upgraded to Snow Leopard.

    Come on Apple - sort it out!
  • dsjokvis Level 1 Level 1 (0 points)
    Hi Oliver.
    You are the first one where I have found some solutions to my own problems with my Linux/Samba server (domain). Since i am trying to create a fully functional domain here at home, that I might eventually move to the office, i want it to be correct before I do it.
    I run a Suse Enterprise Server 10.3 and 3 Vista clients as well as my MacBook OS X 10.6.2 and a MacMini OS X 10.6.2. The Vista machines are able to do everything on all shares. Both my Macs have problems with saving Office 2008 files, especially Excel-files.
    You made me curious on one thing and that is: Where to find .TemporaryItems and .Trash?
    I want to change the ACLs for them both in that case.

    Apart from all that, I totally agree with you that the SMB-feature does'nt work as well in 10.6 as it used to. Now and then I have some issues with connecting to the shares, but in general it works.

    Best regards
    Dag S.
  • Stuart Marden Level 1 Level 1 (5 points)
    Dear all

    I recently sent a letter of complaint to Apple in Ireland regarding this issue.
    I have now submitted a data file to their tech's and a full explanation of the problem I am having - connection via SMB is fine but data cannot be written error code -36.

    They have said they will now look at this and get back in a few days.
    I spoke with a complaints relations officer also who has confirmed this will be followed through to solution.

    Watch this space - now they are aware of the problem.
    Something the tech told me was that they don't get anything from the forums or read/use them.
  • Oliver Kess Level 1 Level 1 (45 points)
    Hello Dag,

    Both .TemporaryItems and .Trash are on the top of your share. As their names begin with a .dot they are invisible.
    ls -lA from the CLI and you will find them. As I mentioned before I also changed the owner of the share to make saving of Office docs and xls possible.

    One thing I did stumbled over today was the way of mounting the share from the mac. I had problems to save a PDF from Acrobat Prof. when I mounted the share with cifs://... but succeeded when I mounted it with smb://....

    I hope this helps.

    regards

    oliver
  • gglockner Level 1 Level 1 (90 points)
    TidBITS wrote about this bug recently: http://db.tidbits.com/article/10772 - this issue is broader than just SMB. I wish Apple would address this ASAP. Several of us have reported it but I have heard little about fixing it.
  • Magic__Dan Level 1 Level 1 (0 points)
    Hello, Sorry to be joining this disscussion so late!

    I'm having the same problem as everyone else trying to transfer a file from a mounted share to a windows folder, but im getting the error:

    'The operation can’t be completed because an unexpected error occurred (*error code -41*).

    I've looked everywhere on the forums for a -41 error but can't find it anywhere. What is it?
    Magic Dan
  • dsjokvis Level 1 Level 1 (0 points)
    Hello Oliver,

    I found them. Thank you so very much.
    I have changed ownership on both to "nobody" and "user".

    So, now i am even closer to a solution, probably.
    Word (Office2008) is now working properly.
    Still Excel is not with. It either crashes or tries to save files with
    temporary filenames (instead of the name I give).

    So, you have helped me a lot and again, THANK YOU!

    Best regards
    Dag S.



    I always mount as smb
Previous 1 6 7 8 9 10 Next