Previous 1 2 3 Next 199 Replies Latest reply: Apr 8, 2010 8:35 PM by Robert Bosch
MacUser4_20YRS Level 1 (15 points)
Anyone else having any problem copying to a shared network drive on Snow Leopard?

Every time I copy to out corporate shared network drives, I get an Error -36

"The Finder can’t complete the operation because some data in “file name” can’t be read or written.
(Error code -36)"

Can anybody hep with this? It started ONLY AFTER upgrading to Snow Leopard.

MacPro 3.0 Xeon, MacBook Pro 17" C2D, MacBook Pro 15" LED C2D, Mac OS X (10.5.4)
  • atrv7 Level 1 (0 points)
    same problem, so frustrating, let me know if you find a solution, by any chance are u using smb to mount/connect to the network drive (mine is a win xp machine)
  • gglockner Level 1 (90 points)
    Hi, I am having the same problem. In my case, my network share (a Time Capsule I use for sharing, not backups) uses AFP. I have only experienced the problem with applications, not with ordinary files. I have tried to repair disk permissions but this does not help, and I have checked the file permissions for some files, but this is not the issue. One workaround I have found is to create a compressed version of the application and copy the compressed version to the network share.

    If you could provide more information about the cases where you have experienced the problem, that would be helpful: what kind of file(s), what kind of network drive, how you are mounting (AFP, SMB, etc.).
  • MacUser4_20YRS Level 1 (15 points)
    I notice other abnormalities when logging into a shared disk, it sometimes lets me log in to the network, as we have security built in to our corporate network, but after I authenticate, it doesn't show me on the disk or folder, I have to re-click the path on my favorites, and it will take me there.

    But I still cannot copy to the shared folder at all without the -36 error....
  • imrdata Level 1 (0 points)
    I just experienced the same. I have a shared drive on a network and prior to SL I was able to copy back and forth no problem. Now, error code -36. I guess we are all the beta testers for SL. I am having some other weird issues, I think I am going to have to revert back to Leopard.
  • atrv7 Level 1 (0 points)
    I have spent a couple hours with Apple tech support and they seemed to know less than me about the issue. So here is my problem again in more detail:

    1. When copying files between my snow leopard machine and my windows xp machine over smb I get error code -39.

    2. When copying files between my snow leopard machine and my other macbook running 10.4.10, the file transfer gets stuck at zero kb.

    3. No problems copying files between 10.4.10 macbook and win xp machine over smb.

    I have tried via wired ethernet connection as well as over wireless and encounter the same problems. I have not tried a direct connection between the snow leopard computer and either the win xp machine or the other macbook running 10.4.10 because I do not have a crossover cable, if someone does, can they try it and see if they get the same problem? This cant be a universal problem as it is a far too big flaw and 10.6 would never have been released if you couldn't copy files across the network. I'm thinking that in the upgrade, some software is not compatible and is somehow complicating the transfer of files across the network. Could it be something to do with permissions? Anyone have any clues?

    here is a screenshot of the issue:
  • gglockner Level 1 (90 points)
    Hi, if you're having these problems, could you provide the following information:

    1) What type of files cause the problem - Applications, ordinary files, etc.
    2) What kind of network storage is involved - Time Capsule, an OS X server, another type of server
    3) Can you copy the file to another Mac via the network?
  • MacUser4_20YRS Level 1 (15 points)
    1) What type of files cause the problem - Applications, ordinary files, etc.

    Ordinary files. PDF, Framemaker from Windows XP machine, log files, JPG images

    2) What kind of network storage is involved - Time Capsule, an OS X server, another type of server

    Other Server and Virtual Servers on Corporate network. Windows, Apache and other servers.

    3) Can you copy the file to another Mac via the network?

    YES copied fine to my macbook pro on network, running SL.

    Message was edited by: MacUser4_20YRS
  • atrv7 Level 1 (0 points)
    oops i meant error code 36, not error code 39
  • atrv7 Level 1 (0 points)
    guys I am having a bit of a breakthrough as I am able to copy to one of the volumes on the windows xp machine fine, I think it might have to do with the characters in the name of the sharepoint, try getting rid of any spaces or brackets
  • gglockner Level 1 (90 points)
    Can you be more specific? I am experiencing the -36 error with a mount point called "share" on a server called "500GB Time Capsule". For me, it happens with a couple of files but not most.
  • gglockner Level 1 (90 points)

    4) What protocol are you using to connect to the share: AFP, SMB, etc.
    5) Have you successfully copied other files to the same server? If so, try to describe the differences in these files (name, size, type, permissions, etc.)
  • gglockner Level 1 (90 points)
    In my case - all of the files that I can't copy are packages. I opened up the packages and noticed that they contain some aliases (pointers) to other files; when I delete these pointers, I am able to copy the files.

    This isn't a workaround by any means, but hopefully some Apple engineers are reading this thread and might find this useful.
  • coldrick Level 1 (0 points)
    I have an OpenSolaris system with smb shares: simple names, no spaces or special characters. From my Snow Leopard systems, I can create folders on the share, but I can't copy any files: when I try, the file gets created, but never gets beyond 0kb before I get Error code -36
  • rust_ita Level 1 (0 points)
    same problem here.

    Connected to a machine with XP Pro with a shared folder on an external drive ( connected via firewire ).
    If I try to copy/move a file from Snow Leopard to the shared folder, I'll get the error -36.
    No problems copying from Windows to Snow Leopard.

    and... no problems copying from Snow Leopard to Windows if the shared folder is located in the internal hard drive.

    (no problems with Leopard)
Previous 1 2 3 Next