Previous 1 2 3 4 5 Next 1,559 Replies Latest reply: Jun 19, 2014 9:28 AM by claybiggerstaff Go to original post Branched to a new discussion.
  • Bluesummer Level 1 (0 points)
    This is still an active problem on my end. No new news from Apple on the subject, going to try calling back in on my case in the AM will post anything that I find out.
  • vincefer Level 1 (0 points)
    I have a similar but worse problem with MBP 2,1. Just after the upgrade I see the "service battery" message ( In spanish in fact: "Reparar batería"). And what is worse, when I took the laptop to put it into the carrying case, I felt it was bulky. The battery was deformed.

    After the upgrade the fan was on most of the time as the computer was running hotter. Using the same programs that I used Leopard nothing that could require a high CPU load. I never thought a regular use of the laptop could damage the battery so badly.

    Apple Care says that I have to take the computer to the closest service and they will decide if the battery is faulty. But it is quite faraway and I don't have the time. Don't you think Apple should send a new battery immediately in those cases?.

    They didn't even suggest to take the battery out of the computer. But I decided to do so, as it is obvious that the pressure to other parts can cause more damage. And I don't feel save having that bulged battery getting hot under may hands.

    This is not the quality and service I spect on a 3000$ laptop.
  • tiefschwarz Level 1 (0 points)
    I'm sorry to hear about your problem. The short and simple answer is that Apple is not obliged to send you a new battery under European consumer law. However if you have warranty or the defect is evidently due to other products sold by the manufacturer (which is hard to prove) they should offer you service within reasonable terms. What reasonable is, is hard to assess. A substantial geographical barrier can be unreasonable. You best bet is to try to get some collect and return service.
  • tiefschwarz Level 1 (0 points)
    I'm getting more and more frustrated as this situation drags on. I have yet to do a successful calibration, since my MacBook just won't go to sleep. I get the warning that battery is low... the screen goes black, and the MacBook becomes unresponsive, but it never writes an image to the disk and never shuts down entirely. I've waited for almost 24hrs this time (instead of 5 prescribed) but when I hooked in the power adapter the screen just lit up immediately and I could log on, without the MacBook restoring an image. Seems like there is a chunk of power left in the battery that the software doesn't account for when it's calculating the battery time and goes into sleep mode.
    Pre-SL it took about 2 hours to charge up from nothing. Now, it thinks it's done in 40 minutes. I've seen the capacity drop from 4250 mAh to 2500 within a matter of days...
  • David Nichols Level 1 (5 points)
    How did you get the battery to charge completely? My message is that the battery is "not charging" and it doesn't charge even when my MBP is plugged in. Tried it all day yesterday. Did it charge after an SMC reset? I haven't done one yet since so many in this thread said it didn't work for them, but may give it a shot now.
  • ffredburger Level 1 (0 points)
    Hi all,

    My battery power has been poor since the SL upgrade, and once it's gone my MBP (2,1) shuts down without warning. Last night the time remaining went from two hours to one before the system shut down, all within a relatively short amount of time.

    Tonight I finally noticed the dreaded "Service Battery" message, but it only displayed briefly before disappearing (I keep checking and it hasn't returned yet).

    What can we do?
  • remraf Level 1 (0 points)
    Further proof - in my eyes - that this is an SL issue and not an issue with our batteries.

    I had replaced my battery with a genuine Apple replacement, but kept the old one as a back up. Tonight I put the back up in, and I'm getting the same "Service Battery" message. That battery was fine - less a couple of hundred cycles - when I replaced it.
  • sasaldivar Level 1 (0 points)
    David Nichols wrote:
    How did you get the battery to charge completely? My message is that the battery is "not charging" and it doesn't charge even when my MBP is plugged in. Tried it all day yesterday. Did it charge after an SMC reset? I haven't done one yet since so many in this thread said it didn't work for them, but may give it a shot now.

    Yes. did the SMC reset for the MBP 3,1 (Early 2008)... and then let it sit overnight charging... I have not experienced the high temps either... haven't heard the fan since then as well... better keep my fingers crossed...
  • chem10 Level 1 (40 points)
    Got the same message yesterday. Called applecare, reset the SMC X2 and then the batter appeared "normal." The battery however, took a long time to charge after 90% or so. Also, the computer began to restart by itself after it shutdown, only if the ac adapter was plugged in. They transferred me to another applecare specialist, who send out a new battery (free of charge per applecare). They said to call back if I still have problems after the new battery.
  • LeafsMac Level 1 (20 points)
    Brand spanking new battery tonight... first charge. I'm getting that silly notice.
  • LeafsMac Level 1 (20 points)
    Update... resetting the SMC and zapping the PRAM did not work. My battery is showing 100% charge.

    Model Information:
    Manufacturer: SMP
    Device name: ASMB012
    Pack Lot Code: 0000
    PCB Lot Code: 0000
    Firmware Version: 0102
    Hardware Revision: 0300
    Cell Revision: 0200
    Charge Information:
    Charge remaining (mAh): 4726
    Fully charged: Yes
    Charging: No
    Full charge capacity (mAh): 4726
    Health Information:
    Cycle count: 3
    Condition: Check Battery
    Battery Installed: Yes
    Amperage (mA): 1
    Voltage (mV): 12589

    Update... unplugged the charger, waited for the thing to calculate time remaining (3:35), then plugged it back in. The silly message is gone, and the numbers went up...

    Charge Information:
    Charge remaining (mAh): 5198
    Fully charged: Yes
    Charging: No
    Full charge capacity (mAh): 5224
    Health Information:
    Cycle count: 3
    Condition: Normal
    Battery Installed: Yes
    Amperage (mA): -1576
    Voltage (mV): 12306

  • chuwright Level 1 (0 points)
    Out of interest, how many of you have reported this issue directly to Apple? I have the same issue and will report later today. Hopefully they'll come up with a solution before any permanent damage is done.
  • MichelVod Level 1 (0 points)
    I read all topic about "Service battery". I've done SMC and PRAM reset for 2 times. Then I've calibrated my battery for 2 times. But nothing is changed. I'm angry. On 10.5.8 battery status was good.
  • tiefschwarz Level 1 (0 points)
    Contacted Apple today in The Netherlands. They know nothing. 'It must be your battery sir, I can't imagine software causing this'. After being persistent they wanted to go as far as 'escalate' my case. I was planning on buying a new battery anyways next year. I'm arriving at a point where I can't be bothered with this anymore and go for it right away. Though I'm not installing it before I know what is going on exactly.
  • MichelVod Level 1 (0 points)
    Good news. I booted into 64-bit mode (by pressing 6+4 while booting) and battery status was good!
Previous 1 2 3 4 5 Next