Previous 1 2 Next 19 Replies Latest reply: Nov 19, 2009 7:13 PM by Michael Weiss
Gary P Level 4 (1,395 points)
SL is generally running fine, but there is a problem in Mail. When I search, I can select From, To, and Subject, but Entire Message is grayed out and inaccessible. I need to search message content, so this will not do.

2008 Mac Pro 8 Core 2.8 GHz + 2007 MacBook Pro 17" 2.33 GHz, Mac OS X (10.6), 10 GB RAM in the Pro, 3 GB RAM in the MacBook Pro
  • V.K. Level 9 (56,110 points)
    make sure that the mail folder in your homedirectory is not excluded from spotlight searches. check Spotlight's privacy pane in spotlight system preferences. what's there?
  • Gary P Level 4 (1,395 points)
    Oops, that was it. I had turned off Spotlight for my boot drive in order to facilitate the upgrade process, & forgotten to turn it back on. Thank you!
  • philipegberts Level 1 (0 points)
    My mail had this option available in leopard. However, I just noticed today that this option is greyed out/not available since upgrading to snow leopard. How can I re-enable it? I check in my spotlight preferences, and there is nothing that is not being indexed.
  • ashealey Level 1 (10 points)
    I am having the same issue. "Entire Message" is greyed out and cannot be selected. I checked and nothing is being hidden from indexing.

    I even used the mdutil to turn it off and on to make sure that it reset it. That was when "Entire Message" greyed out. Prior it was there but didn't work. Searches were taking forever.

    Now they are also taking exceedingly long times when searching in the From/To fields as well.

    Thoughts?
  • ashealey Level 1 (10 points)
    Followup...

    I had previously had WideMail installed. It should just be disabled in Mail under Snow Leopard. However, I downloaded it again and used the Installer Dmg to Uninstall the program.

    "Entire Message" is now selectable again.

    However, the performance is horrible. Searching through my Gmail Inbox which only has around 200 messages takes several minutes. The other searches seem to have reasonable performance.

    Now honestly... this makes no sense to me. There doesn't seem to be a logical connection between the two. However, those were the steps and that was the result. It seems more likely that something else changed in the background while Mail was down.

    Message was edited by: ashealey
  • Gary P Level 4 (1,395 points)
    My question was answered, but it appears some other users still have issues.
  • Luke Lahnstein Level 1 (5 points)
    Iv got the same problem here turning spotlight on and off for mail didnt work

    its a real pain because i use mail search so often!
  • superdave98 Level 1 (0 points)
    I'm also experiencing this problem. Nothing is being skipped by spotlight in the privacy pane.

    I can confirm that it must be an indexing issue because if I mouseover the "Entire Message" option, I see the popup message:

    "Entire Message" search is not available because Spotlight is unable to index /DriveName/Users/UserName/Library/Mail.

    Thanks,

    Dave
  • jzents Level 2 (215 points)
    Have you tried repairing permissions to see if perhaps that got put out of kilter in the upgrade?
  • superdave98 Level 1 (0 points)
    Yep, did that. Didn't solve the problem. Thanks for the suggestion though.
  • ashealey Level 1 (10 points)
    I did the same and it didn't help.

    However, removing wide mail did re-enable the button. Once I did that, letting the system sit for a day or so fixed the issue. I have no idea why... it said it had already completed the indexing. But it's working just fine now and I did nothing other than wait.
  • superdave98 Level 1 (0 points)
    Finally fixed it.

    I went through the various "Fixing Spotlight" steps here.

    After going through all the steps, it worked.
  • imoviebill Level 1 (120 points)
    I'm having the exact same problem. Can no longer search Entire Message after upgrading to SL. I'm gonna try the spotlight fixes first...
  • Ian Williams3 Level 1 (35 points)
    Thanks for the suggestions. I had the same problem. I didn't need to go through the five "fixing spotlight" steps. The first one worked just fine:

    • Launch ‘Activity Monitor’ (located in /Applications/Utilities/)
    • Locate the process ‘SystemUIServer’, highlight it, and click the red button “Quit Process”
    • Within a few seconds the menubar will rebuild itself and often Spotlight will magically work
Previous 1 2 Next