5 Replies Latest reply: Oct 5, 2009 6:00 AM by DyLinn
wunnspeed Level 1 Level 1 (0 points)
I installed Snow Leopard last night, which went really well until I opened Safari only to find out that all 1000+ of my bookmarks were being opened when I started Safari. How do I prevent that from happening again?

Otherwise, things seem to be working quite well.

Thanks.

iMac, Mac OS X (10.6), Happy Hump Day!
  • Carolyn Samit Level 10 Level 10 (95,995 points)
    HI,

    Reset Safari

    To reset Safari, choose Reset Safari from the Safari menu.

    From here you can clear history, empty the cache, clear the downloads window, remove all cookies, remove all website icons, remove saved names and password, remove other AutoFill form text, clear Google searches, and close all Safari windows.

    You can do these all at once, or one at a time to try to preserve items you want for convenience.

    Try deleting this file. com.apple.Safari.RSS.plist

    /Users/YourName/LIbrary/Preferences. Drag that file to the Trash, empty the Trash and restart your Mac.







    Carolyn
  • wunnspeed Level 1 Level 1 (0 points)
    Carolyn, thanks for the quick answer. I'll try the suggestion tonight when I get home. As I'm tied to an ancient Windows machine all day at work, OSX is a breath of fresh air each evening.
  • wunnspeed Level 1 Level 1 (0 points)
    I know people hate it when your reply to your own response. Sorry.

    So, the report worked... kind of. This morning I rebooted my machine and the file seemed to have recreated itself and suddenly all my bookmarks were being opened again (I killed Safari and re-deleted the file). It then worked as per before.

    Hmmm. Ideas? Does anyone know if this behaviour is going to continue? I was just getting used to Safari being a pretty good browser again.
  • seba.bat Level 1 Level 1 (0 points)
    i have exactly the same problem!! it's frustrating cause every time i have to use "close all other" from the tab (right click) menu...

    anyone that could solve this??
  • DyLinn Level 1 Level 1 (0 points)
    I was having a similar issue.. Safari opened all the tabs from my bookmarks bar... Turns out I told it to... Under preferences, "New Windows Open With: Tabs for Bookmarks Bar"... I guess that was the problem, because it seems to be better now that I set it to Same page.