Previous 1 2 3 Next 149 Replies Latest reply: Apr 9, 2010 4:44 PM by jice0
dropadrop Level 1 (30 points)
My home network consists of an Airport Extreme connected via ethernet to a fiber / ethernet bridge limited to 100/100 (by the fc/ethernet converter).

After installing snow leopard my dns is broken. Looking from the airport extreme to see which dns servers I received via dhcp and directly doing queries (or ping) to the dns servers works fine. I can also open web pages via ip addresses I receive by directly doing a "dig hostname @dns-server" on the command line.

Rebooting did not help, but adding opendns nameservers seems to have at least temporarily allowed normal usage.

Message was edited by: dropadrop

iMac C2D, Mac OS X (10.6)
  • dropadrop Level 1 (30 points)
    I should probably note that while networking was broken on my mac I was able to use other devices just fine (so the problem was not on the ISP's end).
  • John Block Level 1 (0 points)
    Have you cleared all manual DNS entries under network settings? I had the same problem (sort of) this morning and had to clear all manual settings to use the DNS entries that DHCP was setting for me...

  • William Kucharski Level 6 (14,985 points)
    That's precisely it.

    In Mac OS X Leopard, any user-set DNS settings were used in addition to those specified by a DHCP server, with the user-specified settings taking precedence.

    However, in Snow Leopard, if any DNS servers are specified by the user, any DNS server address specified by the DHCP server is not used at all.

    The important point here is that DHCP-provided DNS server addresses will not be used in Snow Leopard unless all user-specified DNS servers are deleted.

    So if a user has manually specified say, a school or work DNS server or one that is no longer applicable to their network, DNS service will fail in Snow Leopard, where in Leopard the DHCP-specified server would have (eventually) been used after requests to the manually-specified addresses failed.
  • PhatBaja Level 1 (0 points)
    I believe there's a bug in Snow Leopard which is causing it to disrespect the DNS hierarchy.

    I've also run into DNS problems after upgrading to Snow Leopard. In my DNS settings I saw 3 DNS that were grayed out - which means they are the default DNS servers provided by the DHCP server in my network. Those DNS should be used in the order they are listed with the one in the top having the highest priority. That's where Snow Leopard is failing.

    When we removed the last DNS entry from the DHCP configuration (not in the MacBook settings but in the DHCP settings on our DHCP server) and renewed the DHCP lease on the MacBook it fixed the problem. Now I see only 2 DNS entries. When Apple comes out with a fix for this we will put the 3rd DNS back in the list.
  • Barnski Level 1 (0 points)
    Also experiencing DNS bugginess.
    I have a desktop Mac set up here with manual IPv4 config. IPv6 is disabled. A DNS server is on the LAN, and correctly specified in network config. All worked 100% reliably under Leopard.
    Since Snow Leopard, DNS sometimes stops working. Ping, http, telnet access to LAN resources will not work, but dig lookups against the LAN DNS server resolve IP's just fine.
    Interestingly, I have two DNS servers specified; the second is a DNS proxy that will only resolve internet hosts (i.e. no authoritative zones), and when DNS borks, I can still surf the web - I do NOT get the browser offline mode mentioned at
    Smells very much like a Snow Leopard bug to me - all non-snow leopard hosts on the LAN are fine (various Linux distros, Tiger and Leopard Macs and various Windows versions).
  • ~Bee Level 7 (31,425 points)
    Barnski --
    Did you read Williams response?
    And Phat's?
  • William Kucharski Level 6 (14,985 points)
    Look at your /etc/resolv.conf file - that reflects the true order the servers will be tried.

    The listing in the DNS settings window is not necessarily representative of that, just of what the DHCP server provided.
  • PhatBaja Level 1 (0 points)
    William, did you read the comments in the /etc/resolv.conf file? See below:

    # Mac OS X Notice
    # This file is not used by the host name and address resolution
    # or the DNS query routing mechanisms used by most processes on
    # this Mac OS X system.
    # This file is automatically generated.
  • William Kucharski Level 6 (14,985 points)
    Yes, but it's generated by the mechanism that "knows" the order in which the DNS servers will be used and thus is indicative of it.
  • John Block Level 1 (0 points)
    Is this a bug or a fix to what was broken before? I would realy like to have the old functionallity back, it was great that I could add to the list of DNS servers that was given to me by DHCP, it saved me a lot of manual steps when I would move my laptop around a lot.

  • Statman1 Level 1 (5 points)
    Great question John...I'm not sure what happened, but there is something different in how airport assigns IPs since SL. William says no change in protocol as that is universal, but I'm a skeptic...still no one can explain it.
  • Anchann Level 1 (10 points)
    Spent an hour or two trying to connect to my school's network after upgrading. The computer teacher had no idea as everything, as he claims, was set perfectly. We were both stumped, until I ran across this thread on one of the school's desktops. Took me less than one minute to clear the DNS settings, and lightning speed internet was at my finger tips. Thanks a million!
  • William Kucharski Level 6 (14,985 points)
    This is entirely different from the DHCP issue.

    Systems are free to use or ignore DHCP server-provided DNS server information.

    If you're going to be moving around and must manually set DNS servers that are not usable elsewhere, that's the perfect reason to create different network locations.
  • dropadrop Level 1 (30 points)
    Thanks for all the replies!

    I don't think I had manually entered any DNS servers prior to the upgrade, but I can't say for sure. I did have a static ip-address at my old address (moved two months ago) and I might have added the dns servers at some point.

    I do have some addresses from my lan added to /etc/hosts to provide easier access though.

    Once I get home I'll verify if I have forgotten any old dns servers in the network configuration.
Previous 1 2 3 Next