8 Replies Latest reply: Dec 28, 2009 5:44 AM by irfanhab
EOS iPhone 3G 705 WiFi Level 1 Level 1 (5 points)
Hi All,

Just formatted and installed SL.

Ran safari for the first time ever. It loads SO fast.

However I have two problems.

Most importantly when I click a download link the screen goes black and states loading but nothing happens, and secondly how can I get the address bar to work like firefox does with google so that when I type in 'apple discussions MacBook pro' it takes me there without a proper address?


Thanks,

fred

MacBook Pro 13 inch, Mac OS X (10.6), 2.53GHz, 500GB, 4GB, 9400M
  • Kent Svensson Level 1 Level 1 (5 points)
    I have exactly the same problem as you're first one and you're the first I have come across with the same problem. Stupid thing is that I can't download Firefox as a substitute...

    I did a clean install of SL and had most of my programs updated which I transferred back together with documents with CCC. I've repaired my privileges, loads of errors, repeated the repair and had no more errors.
  • Loopyboy Level 1 Level 1 (0 points)
    I have the same problem. A black screen and that is it. But it also happens with Firefox. It is getting frustrating.
  • Kent Svensson Level 1 Level 1 (5 points)
    Update.

    I downloaded Firefox on my G5 and transferred it on a stick to my MBP and experienced the same behavior. This tells me it's not Safari as such but something with how a browser uses OSX.

    On a Norwegian forum I came across the same problem but also a work-around. Right click on the download link and select "download linked file" (perhaps not correct english as I have my system in swedish) and the file is downloaded. I haven't tried the same work-around on Firefox, but I guess it works. Perhaps some of you guys could try?

    However this is not the proper way of behavior and Apple should fix it.
  • Taiwanese Foreign Student Level 1 Level 1 (0 points)
    Hi,
    Yes, I had the exact same problem. Actually ever since I bought my new MacBook (with Snow Leopard) I have had it. I can never download a program (DMG file) unless I manually right-click, like was suggested on the Norwegian forum. Don't understand why it has not been fixed yet.
  • John Gray1 Level 1 Level 1 (25 points)
    After clean install of SL, I also get the blank screen instead of a download. I've noticed it for links to dmgs or zip files, but may apply to others as well.
  • marky70 Level 1 Level 1 (0 points)
    Same problem here, just a black screen when i click on a download link.
    any help would be really appreciated
    thanks
  • irfanhab Level 1 Level 1 (0 points)
    Same issue here!
  • irfanhab Level 1 Level 1 (0 points)
    Hi,

    I've solved the issue.

    The problem was that a "Speed Download Plugin" was interferring with the Safari download capability. (In case you've installed Speed Download, if not then some other plugin is interfering, to find out which plugins are installed go to Safari Help -> Installed Plugins and check for those plugins that have associated with general files like dmg, zip etc..).

    To remove the Speed Download plugin go to /Library/Internet Plugins/ and remove the Speed Download plugin and restart Safari! Enjoy!