Previous 1 2 Next 19 Replies Latest reply: Oct 10, 2009 12:05 PM by georgevargas
JonMalice Level 1 Level 1 (0 points)
Updated to 10.6 and immediately lost all internet connectivity. Network control panel reported "Cable Unplugged."

Restarted in 10.5.8 -- 100Mb connection worked fine.

Restarted again and back in 10.6, I fiddled with settings and found that by manually switching to "half-duplex" ethernet (under the "advanced" tab) internet connectivity returned. (Connectivity also resumes if I choose the "automatic" configuration, because that too switches over to half-duplex). Either way, the working connection seems a noticeably slower than 10.5.8, which I assume is the difference between half and full duplex.

Any ideas on how to restore the connection to full duplex?

2.66GHZ Dual-Core Intel Mac Pro, Mac OS X (10.6)
  • rack0 tack0 Level 4 Level 4 (2,595 points)
    Not sure what you are plugged into but have you tried manually setting both ends i.e.switch and router to 100Base TX full duplex. Sometimes the auto config of both end of the link get confused and cannot sort themselves out.

    apart from that try a different cable and port on the switch/router

  • rack0 tack0 Level 4 Level 4 (2,595 points)
    Sorry should have said switch/router and Mac fixed at 100 BASE TX Full duplex. The speed difference will be due to the half duplex.
  • theskibum Level 1 Level 1 (0 points)
    I've encountered the same problem with my Mac at work. Caused some problems with the installation as well, as apparently once the installed forced the connection back to half-duplex, with the resulting connectivity loss, software update left a number of directories (like my home directory) with the wrong file ownership.

    Also, in my case, the ethernet port that I was using (Mac Pro tower) appears to be dead. After the install, and cleaning up the file ownership issues, I had to switch to the other port, and allow half duplex to regain connectivity to our corporate network.

    So, I back up and running... kinda...
  • DaddyPaycheck Level 6 Level 6 (16,035 points)
    Have you tried a new Ethernet cable?
  • JonMalice Level 1 Level 1 (0 points)
    Actually, no -- the desk is bolted to the wall in such a way that the jack is inaccessible. But I doubt the cable is to blame since OS 10.4 - 10.5.8 all use full duplex just fine.

    I also tried a clean install with the same result -- half duplex accepted. Full duplex immediately returns "cable unplugged" error.

    The switch is set to manual 100/Full duplex. Will ask the admin to set the switch to auto-negotiate and see if that helps...
  • JonMalice Level 1 Level 1 (0 points)
    +Will ask the admin to set the switch to auto-negotiate and see if that helps...+

    No luck -- got bounced down to 10Mb/Full duplex. Network admin says, "I think it is some issue with the NIC card of your machine."

    FWIW, here are the ethernet card specs:


    Type: Ethernet Controller
    Bus: PCI
    Vendor ID: 0x8086
    Device ID: 0x1096
    Subsystem Vendor ID: 0x8086
    Subsystem ID: 0x3499
    Revision ID: 0x0001
    Link Width: x4
  • rack0 tack0 Level 4 Level 4 (2,595 points)
    You probably already know this but in case you don't. The info that you have posted about the networks suggests its an Intel Pro 1000 EB see

    I have had a look around the net but cannot find anything about the card in relation to Apple.

    The software in my pack states a 90 day support by telephone, if you have that available it may be worth giving Apple a call. You pretty well have got the problem down to the driver/ethernet card. The only other thing I can suggest is a replacement card of different make.
  • DaddyPaycheck Level 6 Level 6 (16,035 points)
    Each subsequent upgrade of OSX seems to make the Mac's network hardware "pickier" about cabling.

    As long as you are certain that all the wiring from your Mac to the switch is quality Cat 5E minimum than no worries. However, I have beat my head against many walls only to find that it was a simple cable issue.
  • JonMalice Level 1 Level 1 (0 points)
    Thanks for the tips

    It is looking more and more like a driver issue with the Intel Pro 1000 card that came with the Mac Pro. I've found people with similar loss of full duplex with this card (sometimes unrelated to Snow Leopard).

    Intel no longer supports the card or driver apparently, having sold that operation to SmallTree's Web site states that a problem exists with the driver and Snow Leopard and offers a possible work-around at

    (The driver must be installed with the current ethernet card removed. Unfortunately, every how-to guide I've seen assumes you're replacing the easy-to-access PCI cards, but the preinstalled Mac Pro card appears to be hidden back behind the main fan and I don't see an easy way to get to it.

    Am I missing something obvious?)
  • rack0 tack0 Level 4 Level 4 (2,595 points)
    I don't know the build of the MacPro but if the card was a standard install by Apple when the machine was new I would expect them to provide suitable software or state in the system requirements of SL that your config is not supported.

    Why not ask them?
  • theskibum Level 1 Level 1 (0 points)
    Don't think you're missing anything, as I'm experiencing the identical problem on our corporate LAN. Everything worked great with 10.5.8, with full-duplex being manually set, but stopped working after (actually during) the 10.6 upgrade. Sounds like the vendor (SmallTree) is working with Apple based on the link you posted, so I expect we'll see a fix in 10.6.2+

    I was thinking of performing a clean install, but others have said that doesn't fix the problem, so I guess I just wait. Sigh...

    As an aside, when I upgraded my Mac Pro at home, I didn't have this problem, since at home I'm currently connected via WiFi as I install structured wiring in the house.

    Not much help, but confirms the problems you're seeing.
  • JonMalice Level 1 Level 1 (0 points)
    My experience keeps getting murkier, partly because I'm getting conflicting info from our tech people about the true extent of the Cat-5 cabling in the building -- and a ton of other stuff that muddies the picture further.

    But I'll skip top the punchline:

    Earlier today I used Cocktail to force a setting that I'd never heard of -- and that does not appear in the Network control panel: 100Mb at Full Duplex (hw-loopback) (click "force speed and duplex settings").

    Problem solved instantly. Measured throughput is now 92Mb. "About This Mac" shows connection as 100Mb/Full Duplex.
  • DaddyPaycheck Level 6 Level 6 (16,035 points)

    This is a classic symptom.

    Cabling, my friend, cabling ;-)
  • JonMalice Level 1 Level 1 (0 points)
    I was wrong to have doubted you
Previous 1 2 Next