Previous 1 26 27 28 29 30 Next 525 Replies Latest reply: Nov 3, 2010 9:22 AM by @martinlabelle Go to original post
  • Yann Bizeul Level 4 (1,320 points)
    I had an issue like this for a fair amount of time until I finally spent the day to find the culprit, as the issue was not there with a fresh user on my system.
    Finally, it was TextExpander that freezed the whole machine when performing mobile me syncing.

    Check in the processes list if textexpanderd is running to make sure you disable it, in case you are a TE user.
  • T&B Level 2 (165 points)
    You didn't mention wether you did any disk checking. Have you used Disk Utility's "First Aid" function on the boot drive? Have you run "SMART Utility" on the drive to check for failure? "SMART Utility" identified my faulty drive, so I replaced it and solved all my problems.

  • redpola Level 1 (25 points)
    Hi Adrian,

    There seem to be two different problems here which seem like they may not be related, but which seem to be clearly divided into

    - Hangs for 30 seconds or so

    - Hangs for several minutes at a time

    I suffered the latter, and if I booted in non-safe mode and waited for the login window, then left my machine for a few minutes, I would see the beachball when trying to get focus into the "username" window in my loginwindow. So my machine was unresponsive before any non-root user-specific stuff has loaded! From your comments I'm not sure this is the same as your problem where you refer to specific applications freezing. My symptoms were every app was blocking for something to clear every few minutes.

    I truly feel your pain - it's been unbelievably frustrating. If there's any stuff I can send you to compare, please shout. Frustratingly I don't know how I fixed the problem. I can only tell you that my approach was one of extreme reluctance to reinstall (mainly because it would force me to learn more about how the boot process of OS X worked).

    Good luck, and I really mean that. I feel like I was lucky that it started working again for me!

  • JuiceZ Level 1 (0 points)
    I suffered with this issue for a couple months. My system would either hang for a few seconds every few minutes to the point of frustration. After trying every solution in this thread, I finally removed my boot camp partition all together and what do you know, I haven't experienced a problem since.
  • Adrian Robert Level 1 (10 points)
    Yes, I ran Disk first aid, checked SMART, etc.. The disk is good.

    BTW, while it might be true that the freezes could divide into multiple symptomatic classes and have different causes, the kernel can and should be able to detect and avert such conditions, period. Tiger did. Linux does. The OS needs to expect the unexpected and not be sensitive to whatever software, buggy or not, the user has installed. Perhaps SL sold its soul here, so to speak, sacrificing proper safety checks and locking practices in some areas, to gain performance.
  • z1ross Level 1 (10 points)
    Adrian Robert wrote:
    Just to add another datapoint, I've been experiencing this as well. Steps:

    1) Clean install Leopard 10.5.0.
    [no problem]

    2) Migrate a user (+ apps and /contents) from a Tiger backup drive.
    [hangs start, mainly in Camino but sometimes Finder; switching to Safari doesn't help]

    Adrian, The step you showed in your post explain exactly why your having issues & this is a cause of many peoples problems!!

    DO NOT MIGRATE PROGRAMS AND SETTINGS FROM TIGER OR LEOPARD using the migration assistant or time machine!!!!

    A. Grab your documents, music, photos, movie folders from your old profile and thats it!

    B. For each program you want on your system that was on your old one, Check that there is a SnowLeopard updated version of that app. If there isn't then you may need to check web-groups for work arounds or go without.

    C. for programs that are Snow Leopard compatible, you can manually copy over your settings and "application Support" folders for those apps, BUT NOT THE APPS from the drive, Download and install the snow leopard versions of each app.

    Here are the major reasons why lots of people are having so much trouble with software on SnowLeopard!

    1. OS X Tiger wasn't Unix Certified.
    2. Leopard became Unix Certified by following a set of guide lines and started clamping down on many ways hacks and plug-ins were implemented that programers took advantage off in the road to being unix certified.
    3. Snow Leopard Changed Finder and other core component app and permissions radically, also clamped down further on haxies and plug-ins and add-ons doing things the wrong way as it moved to 64-bit.

    Lots of programs have handles and plug-ins associated with Finder and the older core components that are no longer available for use in the way originally written but have to be updated to do it the Apple documented way.Without doing it the proper way within the unix world.
  • Adrian Robert Level 1 (10 points)
    If clean reinstall was a guaranteed means of success I'd think about it. The fact is many have reported reinstalls without success. It seems to relate to some combination of apps, extensions, etc., and if you reconstruct that in any way, including fresh installations of OS and apps, you are still in the same place. In my own case I've definitely been able to reduce the frequency of hangs through disabling web plugins like Flash, not using iTunes, etc., but never eliminate them.

    Regardless of workarounds to triggers of the symptoms, the cause is clearly a kernel and/or Window Server level issue relating to improper locking. Unfortunately it has remained beyond Apple's resources to narrow it down and fix it. If it's still there in 10.6.3 I'll try a fresh install followed by a downgrade back to Tiger if it still remains.
  • jk_baller23 Level 4 (2,120 points)
    Yes, ever since I installed my Boot Camp partition my computer has been receiving beach balls constantly. I'm thinking about removing it myself. I wonder if it depends on what OS you use for the Boot Camp partition. My battery full charge capacity has hit the fan also since installing Boot Camp.

    Message was edited by: jk_baller23
  • JuiceZ Level 1 (0 points)
    I had Windows 7 x86 installed in my BC partition before removing it and its been almost 2 weeks now and I've had zero issues with freezing after suffering with it for several months. Now I just use VMWare Fusion for my Windows needs.
  • fwolf Level 1 (0 points)
    You can delete BC or simply follow the steps I posted some time ago - after those, BC and SL are running fine.
  • firman Level 1 (25 points)
    I have been experiencing lots of odd problems since I installed Snow Leopard when it was released. I only get these problems on my iMac24" (iMac 6,1 Core 2 Duo 2.16 ghz). My Macbook (MacBook 4,1 Core 2 Duo 2.4ghz). Both are running the latest 10.6.2 update.

    The problem seems to happen when switching between apps. General symptoms are

    1. image ghosting on the screen. If I drag a window its like dragging a board duster along. It wipes out ghost images and creates new trails. Often the dock and desktop icons get scan lines similar to bad TV reception (analog style).

    2. finder continuously restarts when trying to create new windows (eg. cmd N)

    3. older apps like Excel 2004 for Mac often hang and crash

    The most disturbing thing is the very bad graphics effects as described in 1. Even at boot up there is often a one pixel thick line in the main desktop background (from 10 cm to full screen width).

    Quite often the current in focus window will have an image defect painted onto it by an adjacent and underneath image where the vertical slider bar intersects the in focus window. This sometimes effects the function of the in focus window / app.

    Any freezing generally occurs if I leave this situation unresolved for too long. However, I usually reboot. Its is after these reboots that the pixel thick line defects appear.

    In an attempt to resolve this I have

    1. Run disk verify
    2. run permissions verify and repair
    3. Done a complete wipe and clean install of Snow Leopard
    4. Run Disk Warrior from CD
    5. Remove Bootcamp and run entirely from VMWare Fusion

    This is all a bit embarrassing as the current behaviour of OS X is beginning to resemble windows and having convinced my business partner to switch to Macs 2 years ago I am now recommending that he defer an upgrade from Leopard for the immediate future.

    I am very interested to know if anyone else is experiencing problems like this as I suppose there is a possibility there is a transient hardware defect in my graphics subsystem.

  • djdawson Level 2 (170 points)
    I've been having the long hangs/beachballs (a minute or two) with increasing frequency. I would happen whether or not Safari was running, so I ruled out Internet plugin issues. I ran the hardware diagnostics on the install DVD and the basics tests were fine but the extended tests said I had a SATA problem. So I downloaded the SMART Utility everyone's been referring to and it said both my internal drives were failing (I have a second bootable drive installed that I only use to run diagnostics, etc.). The main drive was a WD Green 500GB and the diagnostic drive was an old Maxtor I had sitting around from a previous Mac. I replaced both drives with WD Caviar Black drives and so far so good.

    So, add me to the list of people whose system hangs were caused by drive problems. It's disconcerting that Apple's built-in utilities don't catch this sort of problem, and that there are no specific error messages in any system log file.
  • Adrian Robert Level 1 (10 points)
    TWO drives "failing" at the same time? Hmm. What exactly did these programs say was wrong with them? Were you always running them from Snow Leopard?

    My guess -- and it's just a guess -- is that they are hitting up against the same kernel bug that causes the beachballs: for some reason certain drive models trigger it.

    It seems like a bajillion different causes and fixes have been proposed and found here, and the simplest way to make sense of them all is that there is some locking bug that gets triggered by certain IO timing patterns -- which can be generated in different ways depending on hardware and software combination.

    This theory can be proved wrong: if anyone has solved this by replacing with the SAME MODEL hard drive (same firmware too though), or gets similar "fail" results when running tests under Tiger, please speak up.
  • redpola Level 1 (25 points)
    Interesting. I do have a user-installed drive and suffered a major inexplicable bout of the beachballs.

    WDC WD5000BEVT-00ZAT0:

    Capacity: 500.11 GB (500,107,862,016 bytes)
    Model: WDC WD5000BEVT-00ZAT0
    Revision: 01.01A01
    Native Command Queuing: Yes
    Queue Depth: 32
    Removable Media: No
    Detachable Drive: No
    BSD Name: disk0
    Rotational Rate: 5400
    Partition Map Type: GPT (GUID Partition Table)
    S.M.A.R.T. status: Verified
    Macintosh HD:
    Capacity: 499.76 GB (499,763,888,128 bytes)
    Available: 18.66 GB (18,658,107,392 bytes)
    Writable: Yes
    File System: Journaled HFS+
    BSD Name: disk0s2
    Mount Point: /
  • nashxiv Level 1 (0 points)
    I fixed this problem. Even thou i am using Mac OS X Snow Leopard 10.6.2

    Easy fix.

    Do a clean install of Snow Leopard. Erase everything.

    Careful - DO NOT UPDATE to 10.6.2 immediately.

    Next, download 10.6.1 update manually. Install it.

    Do restart. Then, install this performance update.

    then do a restart.

    Then, please install the necessary codec to avoid freeze while playing movies.

    Now, update it to 10.6.2 and the rest of update.

    There should be no problem now.


Previous 1 26 27 28 29 30 Next