Previous 1 27 28 29 30 31 Next 525 Replies Latest reply: Nov 3, 2010 9:22 AM by @martinlabelle Go to original post
  • djdawson Level 2 Level 2 (170 points)
    I don't know for sure that both drives failed, but I do know that the Apple extended hardware diagnostics reported a SATA problem, error code "4HDD/11/40000004:SATA(0,0)", and when I replaced both drives and re-ran those diagnostics that error went away. I suspect the problem was with the main drive, the WD Green 500 GB, partly because the "SATA(0,0)" part of the error code, and partly because I almost never actually use the other drive even though it was physically installed and mounted (I suppose Spotlight could have been trying to index it). I've since run SpinRite on both drives and it didn't find any bad sectors on either drive, so my guess is the problem was with the SATA interface on the drive itself (I had to use a different PC to run SpinRite, since it won't run on the Mac platform). The reason I replaced both drives was that the second drive was very old anyway, and I didn't want to spend even more time fighting this issue.

    I suspect that the SMART Utility software cries wolf sometimes, especially since I've read and heard several times over the years that the SMART technology is poorly defined and implemented and is not necessarily a reliable indicator of the health of a drive.

    So, that's what I know. I'd encourage others to use the hardware diagnostics Apple provides any time they encounter a problem that's not easily fixed by more routine approaches. In my case it reported a problem which was corrected by replacing the hard drives.
  • someone else Level 1 Level 1 (5 points)
    We have had this issue too over the last two weeks. Tested all drives(3 in total) in Mac Pro all fine first week. Ran disk warrior and repaired a few minors. Problem seemed to ease off for three days and then came back. 2nd week all drives red and unrepairable in disk util at the same time. I have never seen this before.
    Today installed new drive. Installed clean 10.6. Problem is now even worse and completely repeatable on every occasion. Even got beach ball on login window before I typed anything.It has had no migration or any third party software but has had Apple updates. Performance update not available for this machine. Surely can't be another bad Drive???????? Arggggg I'm losing my hair now. I have already consumed every finger nail I have.
    I have tried every solution on here apart from firmware. I have also removed all Ram and installed new Kingston 4 gb kit. I also tried booting from another known good HD with same system. Same result. Tomorrow I will test the hardware by swapping out with a known good machines parts. I have run all diagnostics over machine including service diagnostics. Again no fault found. It sounds like a hardware problem to me. Surely it is a bit of a coincidence that we all seem to be having a similar issue here.
  • Raphael Pereira Level 1 Level 1 (0 points)
    Hello,

    I have just bought my MacBook Pro. Installed almost no other software, just Skype and Transmission (bittorrent). I noticed that it locks up every time I leave Transmission working. I really think it is a kernel bug related to AirPort and Hard Disk IO. It is really easy to reproduce the problem. Just need to enable a lot of Transmission files, and wait some time. If I start some heavy IO process in the disk, the lockup triggers faster. have already checkd SMART status, repaired permissions and checked disk.
  • Allan Eckert Level 8 Level 8 (45,320 points)
    Hi Raphael Pereira;

    Since your question has nothing to do this the rest of the thread, I suggest you start your own thread for it.

    Allan
    tiger
  • denise CLARK Level 1 Level 1 (0 points)
    Hi there,
    how old is your MacBook pro? Check out the disscussion'. Display anomalities' on this site, it could be relevent.
    I started on this disscussion and found my problem related to a failed graphics card. I did have the similar problem to yours ,
    Best wishes Denise
  • Adrian Robert Level 1 Level 1 (10 points)
    Hi Raphael,

    Does using a wired connection reduce the problem? I just tried after reading your post and it does for me, though not completely to zero, alas.
  • Raphael Pereira Level 1 Level 1 (0 points)
    Hello Allan,

    I'm sorry. I really thought the problems were related, but they aren't. I have just found another post, in Transmission forum (http://forum.transmissionbt.com/viewtopic.php?f=4&t=4564&start=255#p34698), showing the problem is actually related to a bug in the TCP stack of MacOSX begining with Leopard. It seems the problem is still up.
  • Raphael Pereira Level 1 Level 1 (0 points)
    Adrian,

    Go to the post I mentioned to Allan. They discuss some solutions, although I don't like any, as they are just a workaround for a bug we can't solve.
  • Brill Pappin Level 1 Level 1 (0 points)
    I'm also having this problem. In my case dmesg shows that the machines is going into emergency swap mode with these messages:

    (default pager): [KERNEL]: Switching ON Emergency paging segment
    (default pager): [KERNEL]: System is out of paging space.
    (default pager): [KERNEL]: Recovered emergency paging segment

    over and over again.

    I've narrowed it down to Apple Mail and it actually looks like a bug in Mail.
    During this time, Apple Mail ramps up memory usage to 2+ gigs (I have 4 in the machine). Quitting Mail resolves the issue, starting it again eventually results in the same issue so its most definitely Mail doing the damage.
  • Brill Pappin Level 1 Level 1 (0 points)
    I'm seeing the same dmesg logs... Try shutting down Apple Mail and see if it recovers after a while. If it does, does it come back when Mail is started (giving it time to consume memory)?

    You can watch the Mail process in the activity monitor and if its memory keeps going up (mine went to 2 gig used before quitting) you should start to see the emergency swapping messages.
  • Raphael Pereira Level 1 Level 1 (0 points)
    Isn`t the Kernel responsible for kill resource hungry apps when reaching this kind of situation?
  • Adair Level 1 Level 1 (5 points)
    I've read though a lot of this thread, which recently seems to be focussing heavily on the hanging misbehaviour in Safari. My real problem is with Word, which was mentioned as a problem at the beginning of this thread.

    I ran Word 2008 very nicely under leopard. When I upgraded to Snow leopard I began to notice a real time lag between pressing a key and having the action completed. I was so annoyed I went back to Leopard (and sanity) and Word returned to its usual sprightly self.

    With the release of 10.6.2 I thought it safe to return to Snow leopard, and the hang/delay problems reappeared when I open documents. I am not talking about a 'general' open, as in searching for a document, but clicking a recent items document. Doesn't happen with Acrobat or any other program.

    It is most noticeable when I edit documents, there is a long delay between key entry and the action being completed, in cut and paste, style application, adding text and deleting text. Page scrolling is particularly tedious as I have to do it click by click. I have turned off spell check while you type, live word count, worked with only word running, run all utilities: disk utility, disk warrior, and techtool pro (no problems reported in any of them), removed duplicate fonts, and the problem remains.

    The fact remains that the problem doesn't exist using the same software and hardware under leopard, but it does with snow leopard. Snow was supposed to be 'snappier' in feel. When I am editing documents (and I am only talking about 4 pages) it makes Word 2008 chug and feel like it is about to crash at any moment.
  • David Bedford Level 1 Level 1 (70 points)
    I tried to add my Bootcamp partition to my Spotlight Privacy list...got an error saying it could not be added...quit the pane... reopened that there it was Bootcamp was on the Privacy list....somethings screwed up somewhere..... Now to see if I can run a day without the beachball and a frozen my system.
  • Brill Pappin Level 1 Level 1 (0 points)
    I resolved the problem here.

    It's was generated by Apple Mail which after taking up two gigs of ram, started swapping.
    What caused Apple Mail to do that, was an RSS feed from TED Talks. Deleting the RSS feed resolved the problem.

    Looks like a bug in SL's Apple Mail to me.
  • ianbright Level 1 Level 1 (0 points)
    I tried Disk Utility and got the response that "usr/share/derby" should be drwxr-xr-x instead of "lrwxr-xr-x, but Disk Utility doesn't fix it (or it reappears as drwxr etc after a re-boot, even with the original OS disk operating Disk Utility)

    Also I get a warning that SUID file"System/Library/CoreServices/RemoteManagement/ARD Agent.app/Contents/MacOS/ARDAgent has been modified & will not be repaired"

    I did have other SUID warnings before I re-installed my system but these have disappeared.

    These may not be contributing to my freezing Mac, but they make me uneasy as I wonder if my security has been compromised. Until recently Snow Leopard was great! But now I have to use the "off" button to escape, as the Command/Option/Escape route won't work.
Previous 1 27 28 29 30 31 Next