Previous 1 2 Next 15 Replies Latest reply: Jan 19, 2010 5:22 AM by bu11etpr00f
BradPDX Level 1 (75 points)
We have 4 Macs in our house - a late 2006 iMac and 3 early 2009 MacBooks. All are loaded with SL at present. I am using a typical home network with Airport Extreme which works fine. I enable File Sharing on all Macs so that files can be browsed and shared between machines.

On one MacBook, the SL upgrade appears to have broken AFP File Sharing. When any other Mac tries to connect to it via the Finder, the connection fails after several minutes.

If I add SMB file sharing, that works. Likewise Screen Sharing works as well - and thus other network services are functional on this MacBook.

The MacBook appears to "advertise" that AFP is available - if I run iStumbler from any other Mac, it "sees" the AFP and SMB services via Bonjour, and of course the MacBook is visible in the "Shared" section of the Finder sidebar on the other Macs. It's just that the AFP dead ends on this one machine.

I have tried restarting File Sharing, fixing permissions, restarting the whole machine - but the results never vary. Suggestions?

iMac Intel Core 2 Duo, MacBook Intel Core 2 Duo, Mac OS X (10.6)
  • a brody Level 9 (65,736 points)
    Snow Leopard doesn't support AFP.
  • BradPDX Level 1 (75 points)
    "Snow Leopard doesn't support AFP."

    That's not true at all. SL doesn't support the old AppleTalk protocol, but we are talking about Apple File Sharing (AFP), which is the default protocol invoked when you choose "File Sharing" in the Sharing preference pane.
  • Bruno Enz1 Level 1 (30 points)
    I've the same problem here with my Macs (MacBook Pro/Air). My MacBook Air had a clean install of 10.6.

    " have tried restarting File Sharing, fixing permissions, restarting the whole machine - but the results never vary."
    Me too!

    I tried different firewall settings - no effect!
  • a brody Level 9 (65,736 points)
    Oh, I thought they were based on the same protocol.
    Did you install Rosetta on one machine, but not others?
  • BradPDX Level 1 (75 points)
    Rosetta is installed on one machine only, and it is not the one having this problem.

    I don't see what Rosetta has to do with it, really. It is only related to old PPC code, not networking per se.
  • a brody Level 9 (65,736 points)
    Rosetta allows more PowerPC code to run.
    I suspect AFP may still be PowerPC based. Try installing Rosetta on the other machines having trouble and see if it makes a difference.
  • BradPDX Level 1 (75 points)
    a brody wrote:
    Rosetta allows more PowerPC code to run.
    I suspect AFP may still be PowerPC based.

    Not true. AFP is the THE native protocol for OS X, and is in no way tied to Rosetta. It is implemented in pure native Intel code as a core part of OS X networking. I think some folks are confusing this with AppleTalk, which is a very old and now completely unsupported protocol. AFP has nothing to do with AppleTalk.

    Only this one machine is affected. Others WITHOUT Rosetta work fine, as does one WITH Rosetta - it simply has no effect one way or another, which is exactly what one would expect.

    (I only have Rosetta on one machine to run crappy old Quicken 2007, otherwise I have no PPC applications of any kind, dumped them all.)

    So, thanks, but that's barking up the wrong tree, methinks.
  • Bob Leland Level 1 (40 points)
    Try this. After several days of trying many things, this fixed my connections:

    Open the System Prefereces/Sharing panel.

    In the first verticle panel Click on "File Sharing"

    In the second verticle panel, "Shared Folders" click on your Public Folder.

    In the third verticle panel "User's" click on the "+" to add a User.

    Add another User's sign on Name and Password.

    Do the same for you drop box.

    The added User will now be able to connect.

    Repeat, adding Users needed.

    Good Luck

    The Permissions Read & Write
  • BradPDX Level 1 (75 points)
    Thanks for all the replies - that's what make this site work (when it does)!

    I figured it out. It had to do with my home network and NOT Snow Leopard.

    I took 2 of the MacBooks to my office, which uses a Microsoft Active Directory setup. Instantly AFP worked perfectly in all directions, which let me know that my home network was likely at fault.

    I checked my router, over which my ISP (Clear WiMAX) gives me limited control. The DNS entries were incorrect, and so I flushed them. I then added DNS entries on each Mac for use of the OpenDNS servers, as I was not happy with the speed of Clear's DNS.

    Results: everything works now. The Macs all see each other quickly, AFP works fine and websites snap into view like they should.
  • [ shua ] Level 1 (50 points)
    The problem with this is, for example, if I create a file (Word, Pages, whatever) and save it locally in a shared folder, even users who are on the "Users" list and set as Read & Write can't edit that file. It results in a permissions error.

    Anyone found a fix to this?
  • donv (The Ghost) Level 5 (4,600 points)
    You are correct. I use afp between my MBP and iBook--no Rosetta installed. Your problem is a strange one. You could try resetting your [PRAM and NVRAM|]. Also you could try reinstalling Sno over Sno as in an upgrade install. The procedure is very safe, but it still is an install. So, be well backed up.
  • Stephen Hanson Level 4 (1,875 points)
    This fix worked for me with a variation. I have SL on a Mac Book Pro. my Desktop is a G5 running 10.5.x. I could always connect 10.6 to 10.5, but not the other way.

    When I was in the sharing preferences on the MBP, with "File Sharing" ticked and selected, I noticed that there was a folder called username's Public Folder-1. The username being my administrative account. I deleted this folder by clicking on the "-", then added a folder, clicking on the "+", and navigated to the correct Public Folder. Screen sharing and file sharing instantly worked between all machines, both ways.

    Thanks for this tip!
  • donv (The Ghost) Level 5 (4,600 points)
    BradPDX wrote:

    It's just that the AFP dead ends on this one machine.

    I have tried restarting File Sharing, fixing permissions, restarting the whole >machine - but the results never vary. Suggestions?

    On the errant Mac, if you haven't done so, go System Preferences > Sharing > Check mark File Sharing > Go Options > Check mark the AFP blurb. I feel confident that you have selected these settings. But, ....

    I suggest that, for now, you use Go > Connect to Server--afp://IpAddress in trying to connect to the errant Mac. To some extent, connecting using the shared section of a Finder window is broken for some in Sno.
  • Tajmari Level 1 (50 points)

    I'm following this thread because I've had sharing issues, too. I have noticed that lately Firefox and Safari tend to be very slow. I have a Linksys router for a home network that links two 2009 macbook pros and one G4 older box. I have some control via a web page of my router, too. Would you please explain in a little more detail the process you used to change the DNS for your computers? I don't know what an OpenDNS server is.

    Thanks so much!
Previous 1 2 Next