1 2 3 4 Previous Next 54 Replies Latest reply: Dec 27, 2009 12:33 PM by mnemonick
BluePhilosopher Level 1 Level 1 (0 points)
It's only happened once, but I received a progress bar on the gray start-up screen on a reboot. It was after a normal restart and after it ha shutdown and then started it boot up I got the progress bar, it has only happened once, but I was wondering what this bar was.

MacBook Pro 5,1, Mac OS X (10.6)
  • 1. Re: Progress Bar on Grey Boot Screen
    macjack Level 9 Level 9 (50,510 points)
    When did you install 10.6? It may have been an incomplete install and the installer completed it when you restarted. Do you have any log entry on the event in Console? Or in Install.log?



    -mj
  • 2. Re: Progress Bar on Grey Boot Screen
    BluePhilosopher Level 1 Level 1 (0 points)
    It was installed on the 28th.. It only just happened today

    I have rebooted several times since the install. This is the only time that I have seen this bar. It occurred on the Gray screen with the Apple logo. I rebooted again to see if it happened again, and the system started normally. I don't see much in the logs, but I will admit not knowing what to look for.
  • 3. Re: Progress Bar on Grey Boot Screen
    Rory Kennon Level 1 Level 1 (10 points)
    The grey progress bar on startup appears when your mac is updating the firmware, which is normally done by holding down the power button until it emits a tone.

    It is possible that you have held the power button down for slightly longer than normal activating a firmware update that you may have downloaded previously.

    That would explain why it has not happened since the time you mentioned.

    Just my thoughts.
  • 4. Re: Progress Bar on Grey Boot Screen
    BluePhilosopher Level 1 Level 1 (0 points)
    I initiated the restart from the apple menu while it was running. It restarted on it's own and I did not interact with the system after starting the the restart. The system appeared to starting normally, I got the gray screen, the the apple logo, and the spinning wheel... then the bar appeared and slowly filled in. The boot time was probably a couple of minutes which is good deal longer.

    One of the reasons I was asking is it could have been an update... But I did not have the software update running so why would the firmware have been updated?

    I want to know if I should be looking for problems, like did the system decide something was wrong have to do a more extensive test? And if so what did it detect? Or was this just the system clearing some trash or log files or something extraneous that it no longer needed? I don't mind if that is the case, I just want to know what it was was doing and why.
  • 5. Re: Progress Bar on Grey Boot Screen
    DJRumpy Level 1 Level 1 (35 points)
    I saw this as part of the Snow Leopard update. It warns you about the update before you restart, but it's very likely they simply clicked continue and didn't read the warning itself. The EFI update was pulled down via software updates. You probably just got the update a few days later. I think it defaults in week intervals for each check for updates.
  • 6. Re: Progress Bar on Grey Boot Screen
    BluePhilosopher Level 1 Level 1 (0 points)
    I ran the software update a few times after installing. Partly to make sure that everything I installed was up-to-date. However the software update was not running when I rebooted the computer. I closed all of my applications before initiating the reboot, and the software update was not one of the applications I closed.

    Looking at the list of installed software by the updater, it is not listing any sort of firmware update. The last items listed installed was on the 8-30-09, listed as optional installs.

    So if this was an update it was not an apple update that I can see...

    Message was edited by: BluePhilosopher
  • 7. Re: Progress Bar on Grey Boot Screen
    DJRumpy Level 1 Level 1 (35 points)
    I installed 10.6 on a brand new Mac Mini. It was the first thing it did after rebooting and it warned me before I rebooted that it would show a progress bar on a gray screen.
  • 8. Re: Progress Bar on Grey Boot Screen
    BluePhilosopher Level 1 Level 1 (0 points)
    I received no such warning. When I started the reboot I got the normal "Are you sure you want to restart your computer now? If you do nothing your computer will restart in x seconds." "Cancel" or "Restart Now" I selected restart now.

    I think I found what may have cause it. Around the reboot time the system checked my startup volume. It's the only think that I can see that is out of the ordinary.

    From my fsck_hfs.log (Filesystem repair log)

    /dev/rdisk0s2: fsck_hfs run at Thu Sep 3 09:10:09 2009
    Executing fsck_hfs (version diskdev_cmds-491~1).
    ** Checking Journaled HFS Plus volume.
    ** Checking extents overflow file.
    ** Checking catalog file.
    ** Checking multi-linked files.
    ** Checking catalog hierarchy.
    ** Checking extended attributes file.
    ** Checking volume bitmap.
    ** Checking volume information.
    ** The volume Macintosh OS X appears to be OK.

    But what I don't understand is why it decided to check it. It does not appear to have made a change to the system or repaired any part of the file system.
  • 9. Re: Progress Bar on Grey Boot Screen
    macjack Level 9 Level 9 (50,510 points)
    BluePhilosopher wrote:
    I don't see much in the logs, but I will admit not knowing what to look for.


    Launch Console in your Utilities folder. EDIT: From the sidebar choose Install.log. Then look for the last date in the log and/or the date the log was last modified.



    -mj

    Message was edited by: macjack
  • 10. Re: Progress Bar on Grey Boot Screen
    BluePhilosopher Level 1 Level 1 (0 points)
    Last Edited today at 11:41 am. There are alot of checks on the printer... But the printer is off and is only connected via wifi. Looking back through the log, this is the earlist entry for today.

    Sep 3 11:30:52 macbook-pro Software Update[677]: JS: 10.6
    Sep 3 11:30:54 macbook-pro Software Update[677]: JS: Firmware is up to date.
    Sep 3 11:30:56: --- last message repeated 2 times ---
    Sep 3 11:30:56 macbook-pro Software Update[677]: JS: model = MacBookPro5,1
    Sep 3 11:30:59 macbook-pro Software Update[677]: JS: 10.6


    Everything before that is from 2 days or earlier. But is the same message

    Sep 1 21:53:20 macbook-pro Software Update[5540]: JS: 10.6
    Sep 1 21:53:21 macbook-pro Software Update[5540]: JS: Firmware is up to date.
    Sep 1 21:53:22: --- last message repeated 2 times ---
    Sep 1 21:53:22 macbook-pro Software Update[5540]: JS: model = MacBookPro5,1

    So I interpret this mean nothing was installed, right?
  • 11. Re: Progress Bar on Grey Boot Screen
    macjack Level 9 Level 9 (50,510 points)
    If this is from your Install.log, then I'm not sure why you'd be getting those messages today.
    For instance, my install.log has nothing written to it since the say I installed. During the install I got many "Software update [6218]: JS: Connected Printer update messages. But none beyond the install date.



    -mj
  • 12. Re: Progress Bar on Grey Boot Screen
    BluePhilosopher Level 1 Level 1 (0 points)
    It looks like times when I ran the Software Update on my own.
  • 13. Re: Progress Bar on Grey Boot Screen
    Scott Watkins Level 1 Level 1 (15 points)
    What probably happened was you hit the shift key during start up. In 10.6 when entering Safe Boot you now receive a progress indicator.

    You may have just had something on the keyboard without noticing (like a book), I've done it a few times.

    Check out:
    Safe Boot takes longer than normal startup
    http://support.apple.com/kb/TS1884

    Mac OS X: Starting up in Safe Mode
    http://support.apple.com/kb/HT1455

    Can't find anything on 10.6 yet but to test it out you can hold shift as your machine restarts, it does no harm. Once its booted in safe boot simple restart again without holding anything to go back to normal.

    The extract from your log would seem to indicated a safe boot as it referenced the FSCK which is performed in the background during a Safe Boot.
  • 14. Re: Progress Bar on Grey Boot Screen
    john.grayson Level 4 Level 4 (2,495 points)
    this just started happening to me BUT EVEY TIME the computer starts. this started after a bootcamp installation, it's not installing any kind of firmware and no, i am not holding down shift (or any other key).
1 2 3 4 Previous Next