Previous 1 2 Next 22 Replies Latest reply: Feb 12, 2010 12:45 PM by superdane73
MacGRDEsq Level 1 Level 1 (15 points)
I just bought the Cricket A600 USB Broadband Modem and am able to use it on my Dell laptop and on my 13 inch Mac Book Aluminum in Parallels/Windows XP. However, in Snow Leopard the modem is not recognized. Please help!

13 inch Mac Book Aluminum (Purchased 1 day before it bacame a MacBook Pro!, Mac OS X (10.6), iMac and iPhone 3G
  • Carolyn Samit Level 10 Level 10 (95,995 points)
    HI,

    Go to the manufacture web site and make sure it's Mac OS X 10.6 compatible. If it came with software, you may need to download and install updates for 10.6.





    Carolyn
  • akjeff Level 1 Level 1 (5 points)
    I'm having the same problem. The drivers embedded on the modem appear to not very happy with 10.6
  • christinefm Level 1 Level 1 (0 points)
    I'm also having this problem. My Cricket modem worked fine before I upgraded to Snow Leopard, but now it doesn't work at all. The device isn't recognized and each time I insert the modem into the USB port, the image shows up with the install package, as if it's not been recognized as installed. Very frustrating! There is absolutely nothing on the Cricket website about this.
  • Richard Daniels Level 1 Level 1 (0 points)
    I found this on a forum which worked for me :http://www.evdoforums.com/thread12573.html


    ricket kinda works, but not by using their connection software (but using their drivers). This is what I had to do from a fresh install of SL (I may be missing some steps).

    Install the software. Mac OS will complain that the installer installed stuff incorrectly.

    Move the CDFree* and DevGuruVsp* kexts from /System/Library/Extensions to the desktop.

    Delete the panther versions

    Rename the tiger versions to CDFree.kext and DevGuruVsp.kext

    Copy them to /Library/Extensions

    Go into terminal, and fix permissions in the the /Library/Extensions directory:

    cd /Library/Extensions
    sudo chown -R root:wheel *
    sudo chmod -R 0644 *

    Load the driver:

    sudo kextload -v *

    Then at some point, either by removing and inserting the USB adapter, or playing around with the Software, I got a popup saying that a new network adapter was detected.

    Then, I went into System Preferences, and to the first A600 device, added #777 as the phone number, cricket as the username, and my last 7 digits of my phone number as the password. I was then able to use this device to connect.
  • christinefm Level 1 Level 1 (0 points)
    I saw that post and attempted to follow those steps, but they are not specific and I got errors, probably used incorrect syntax. If anyone has had luck with that set of instructions and would like to post a more detailed, concise version, that would be great!
  • jamus j Level 1 Level 1 (15 points)
    At the evdoforums link above, there's a new post which has a link to a script and a screencast I did to show the procedure. Good luck!
  • MacGRDEsq Level 1 Level 1 (15 points)
    Couple of questions about the video and script.
    1. How do I save the postflight? When I click the link, a new tab on the browser opens with the script. How do I save it?
    2. What are you typing in the Terminal?
    The first line looks like cd=/Desktop? 2nd line looks like sudo bash postflight?
  • jamus j Level 1 Level 1 (15 points)
    Alt-Click on the link to save it to the download folder, then move it to the desktop.

    1) cd ~/Desktop
    2) sudo bash postflight

    It's clearer on youtube if you view in "HD" mode and expand the viewer. I've also added an annotation that spells it out, too.

    Jamus
  • MacGRDEsq Level 1 Level 1 (15 points)
    When I Alt+ click the link, it is saved as postflight.sh an html file. When I run terminal, I type the first 2 lines as above and then it asks for a password and when I type my profile password, it says that no such file exists.
  • jamus j Level 1 Level 1 (15 points)
    Make sure to use safari, and move the file that you downloaded onto your desktop.
  • PT Sandiford Level 1 Level 1 (50 points)
    The best way I found for "native" Cricket support was to downgrade to 10.5.x, installing the modem software using the installer on the A600, then upgrading to 10.6. Make sure to preserve users and settings when downgrading.

    What a pain. All of my 3G modems (VZ and Cricket) worked but the installers were legacy.
  • mommieto9 Level 1 Level 1 (0 points)
    Jamus, Please help me "fix" my issue with the A600 + Snow Leopard, I tried to dl the script but it wont work when I sudo bash postflight. it says no such file or directory. I looked at the video and on it your icon for "postflight" looks like a .exe icon, on my desktop the file looks like a sheet of paper. I am assuming that's the problem. Please help I chasing you down on youtube, EVDO, Here I just need a dumbed down step by step. btw... What is a superuser? and how do I run the script? Thanks
  • MacGRDEsq Level 1 Level 1 (15 points)
    I, too, am having the same problem. Even with the ALT + click, the postflight file downloads as an .sh file from Safari. From terminal, I get stuck at password. I enter my system password and then it states no such file exists. As for the other recommendations of downgrading to Leopard, I am opting not to do that. Over the last several days, Cricket on the web site under Broadband has indicated that the A600 will be Snow Leopard compatible "Coming soon." I guess I'll wait for that to happen. Coincidentally, since I run Parallels, the A600 works on that. The unfortunate part is that I can't figure out to share this network connection from Parallels to Snow Leopard in order to use Mail and my synced iCal calendars.
  • MacGRDEsq Level 1 Level 1 (15 points)
    You are Awesome Jamus! Thanks for the help!

    The solution to the problem is as follows:

    instead of typing sudo bash postflight, type sudo bash ./postflight.sh

    and follow the remaining steps.
Previous 1 2 Next