Previous 1 73 74 75 76 77 Next 1,153 Replies Latest reply: May 8, 2013 9:30 AM by Go to original post Branched to a new discussion.
  • sebastian77 Level 1 Level 1 (0 points)

    No it is not far enough. My Problems problems startet since 10.5.3. And as i know, Tiger never had any Airport-Problem.


    Just look at:


    But Apple is ignoring this problem. It seems that somebody should start a Homepage like



    Is there a Webdesinger in this thread. What about ???




  • Ian L-F Level 1 Level 1 (10 points)

    Any resolution on this as I am having a similar issue on my Leopard PB 10.5.8????

  • drjthomas Level 1 Level 1 (0 points)

    My wi-fi is back to being intermittent after a few hours of relief. My enthusiasm for a 'fix' was premature! It really is very, very irritating and has seriously slowed my work down.


    Perhaps this is a problem of compatibility with the router firmware as some have suggested .... has anyone tried changing their router? Mine is very old and I wonder if this would help.




    PS In response to the various doubters... I had no problems at all with SL - this definitely a lion issue in my case.

  • juanito77 Level 1 Level 1 (0 points)

    I upgraded my 3 machines to Lion over the weekend and am now experiencing the same issue and see this in the console of the machines "airport link down on reason 2 previous authentication no longer valid".


    My access point is an Airport Extreme with 802.11N. Never had a problem with 10.6. If I reboot the Airport Extreme, everything seems to work again for a few hours, but then the problem arises again.



  • putnik Level 3 Level 3 (780 points)

    I am intrigued by the message "previous authentication no longer valid".  Maybe I am barking up the wrong tree, but I noted in times past, that the keychain entry for the wifi holds the user ID, PW and another long character string. This latter changes sometime when the network re-connects and so the keychain entry becomes invalid. Well, it seems to me this is introducing an unnecessary unreliability into the system, but who am I to know


    Try deleting the two keychain entries in Login and System, and re-connecting. You will need to re-enter your encryption password.

  • Adriano C Level 1 Level 1 (20 points)

    Most MacOS network problems can be fixed with a simple cleanup of the network configuration:


      sudo rm /Library/Preferences/SystemConfiguration/*




  • putnik Level 3 Level 3 (780 points)

    Perhaps this problem relates to another older thread on the same subject:



    There is an answer from Tenortim, attached to the original post, that seems to work well.


    Maybe a bit too advanced for the common user though?

  • rjulao Level 1 Level 1 (0 points)

    I had the EXACT SAME ISSUE. I wanted to slam my iMac on the ground. I tried all the "fixes" posted but none worked. I was on my last resort of going back to SL then i got brave and decided to upgrade my router.


    I was using an old Lynksis wireless G router that i've had for many years. I had a $50 BB gift card laying around and figured what the heck. I purchased a NetGear N600 Dualband Wireless N router. Took it home and set it up.......2 weeks in......NO ISSUE. At all. My iMac stays connected and has not dropped (5.0mGhz band). Even after sleep, it finds and connects. I don't know if it was wireless G old router just banging me out but this surely "fixed" my issue.


    I'm just glad i had that gift card.

  • Jabbamanno Level 1 Level 1 (0 points)

    Hi i'm from Italy and i tried a lot of solutions seen in this and in other posts.After a lot of backups i turned back to Snow Leo and i  to disabled the IPv6 in the TCP/IP from the advanced tab in Network Preferences; then i installed the "Supplemental Update OSX 10.6.8"  found here:

    Then i've installed Lion and now I have a stable wifi connection.Hope this will help!

  • putnik Level 3 Level 3 (780 points)

    According to this discussion, which has been going on for years, it seems Apple have used a firmware version in Lion that has already been found to cause problems on some computers with both the Atheros and Broadcom chipset. There is a post by BananaMacintosh that summarises a procedure for installing a previous version. It is not for inexperienced users and may not be the answer anyway. Atleast Apple will be aware of the issue.



    Also a good writeup here too.





    eg. My MBP uses the Broadcom chipset...


    Screen Shot 2011-08-12 at 03.04.39.jpg

  • putnik Level 3 Level 3 (780 points)

    I should add that the kudos goes to "tenortim" for the original answer.

  • putnik Level 3 Level 3 (780 points)

    Well, now we are advised that this is in fact a dangerous procedure. Perhaps I have been precipitous in endorsing it and will be more circumspect in future!


    See William Kucharski's posts:


  • nora333 Level 1 Level 1 (0 points)

    I have a Macbook pro  since December 2010 which has been constantly dropping home wifi (but nowhere else). Yesterday I put" ping" in the terminal and have done this again today when starting up the laptop and so far.......not dropped once. Hope it lasts. (apologies if someone else has already posted this)

  • nora333 Level 1 Level 1 (0 points)

    Sorry, just ignore my last post about doing "ping"........its stopped working and I get lots of lines saying "Request timeout for icmp_seq". Oh well, it was good while it lasted.

  • ergoplex Level 1 Level 1 (0 points)

    Hi All,


    I started suffering dropped network connections on one of my machines and here's what I did to fix it.  


    My network consists of: 1 Airport Extreme, 2 Airport Expresses, 1 Netgear wired router (which runs the DHCP server), 1 Linksys AP and a variety of client HW (MacBook, MBP, etc.).  In my case, network connectivity would drop on the MacBook.  Every other device seemed solid and fine.  I tried all of the fixes I could find, short of replacing the Lion driver, to no avail.


    Finally, I looked at the DHCP lease information on the Netgear router and I discovered that two devices had been handed the same IP address - the MB and a Roku.  The interesting thing is: no "duplicate IP address" messages on the MB, either as a notification or in the kernel log.  Anyway, I fixed the configuration error that was causing the duplicate address to be handed out, renewed the MB DHCP lease and now all is well.


    I hope this information is helpful to some of you.