Previous 1 73 74 75 76 77 Next 1,153 Replies Latest reply: May 8, 2013 9:30 AM by Go to original post Branched to a new discussion.
  • hannesr Level 1 (0 points)

    I had exactly the same problem. The following link worked for me


    Check what wifi chipset you have as it only seem to apply to Atheros Wifi hardware.

  • Darko Martić Level 1 (0 points)

    I did as described on that link, successfully downgraded the driver.

    But, now I have new problem - I cannot make my iMac automatically connect to my Wifi network which is set as only preferred...


    I tried everything I could possibly google on this subject, and nothing helped.


    Interestingly, when I boot into Recovery mode, the autoconnect to my Wifi network works...??? It got automatically connected...

    Does it reads configuration from the same place where the "regular" boot does or maybe it uses those "default" 4.0 drivers insted of downgraded ones ?

  • William Kucharski Level 6 (14,985 points)

    "Downgrading" your driver is not supported, so I'm not at all surprised that doing so may have broken something else.


    I've mentioned before that doing so is like dropping an engine from a 2008 vehicle into a 2012 one and expecting it to just work with no issues.

  • savedave_uk Level 1 (0 points)

    I have tried just about everything I can to fix this, including the various kext fixes.  I have tried going back to the 10.6.4 Kext, didn't help, and now I am using this set up:

      Software Versions:

      Menu Extra:    6.2.2 (622.2)

      configd plug-in:    6.2.5 (625.6)

      System Profiler:    6.0.1 (601.1)

      Network Preference:    6.2.2 (622.2)

      AirPort Utility:    5.5.3 (553.20)

      IO80211 Family:    3.2 (320.1)



      Card Type:    AirPort Extreme  (0x168C, 0x86)

      Firmware Version:    Atheros 5424:

      Locale:    ETSI

      Country Code:    GB

      Supported PHY Modes:    802.11 a/b/g

      Supported Channels:    1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13, 36, 40, 44, 48, 52, 56, 60, 64, 100, 104, 108, 112, 116, 120, 124, 128, 132, 136, 140

      Status:    Not Associated


    Still no connection.


    Anyone else still suffering?

  • Darko Martić Level 1 (0 points)

    I suppose everyone here got a notification about 10.7.3 release... right ?



    wel, there are some good news, according to release notes one of the fixes is:


    "Resolve a Wi-Fi connection issue when waking from sleep"



    hoooray !

  • ChrisHoover Level 1 (0 points)

    The fix at worked for me as well.  Many thanks.

  • Darko Martić Level 1 (0 points)

    I resolved my issue by switching to ethernet LAN


    Doing some extra google research in the meanwhile, if I understood correctly the issue is connected with bluetooth usage (keyboard, mouse, trackpad), since both BT and WiFi use "similar" GHz range, and all those other microwaves (microwave oven, neighbours wifi...) are making that extra noise.


    Some people resolved this issue by installing Wifi router that works on 5 GHz...


    Since I have BT keyboard and both Magic Mouse and Trackpad, my next step is to replace keyboard with wired/USB one (alu with numeric) and sell Trackpad, but I'm keeping Magic Mouse as there is no other mouse with gestures like this one, and it just sits nice in hand. Or is there? A wired/USB one?

  • ChrisHoover Level 1 (0 points)

    Not to be a wet blanket, but I don't use any bluetooth peripherals at all, but I still have the wifi problem.  It's a real bummer, and only affects one machine (my 2011 iMac.  My Macbook air and iPad don't have this problem, and neither do people visiting my network with their various Mac laptops).

  • MelMar Level 1 (0 points)

    I have followed this discussion with interest for months. More specifically, I have followed it since upgrading my mid-2007 Mac Mini to Snow Leopard 10.6.5.  It had been working fine up until that point, but the upgrade resulted in the loss of stability of my wifi connection.  I tried most of the suggestions mentioned on this discussion, but nothing worked. I was using an Airport Express router, and tried various configurations, but could not maintain a reliable connection. Meanwhile, my first gen iPad worked great.  I ultimately had to reload SL 10.6.4 on the Mini, and have lived with that ever since. About 2 weeks ago, I bought a new Mac Mini. It is a mid-2011 model, loaded with Lion 10.7.3.  It works great!  No problems with the wifi connection at all. I'm still using the same Airport Express router, and the same iPad. I did not change the router configuration in any way.  I had been using a wired keyboard and mouse with the old Mini, but I replaced them with wireless Apple keyboard and wireless mouse. I am NOT a techie in any way, so I can only conclude that there was some incompatibility issue between the old Mini, Snow Leopard 10.6.5, and/or Airport Express.  It certainly was frustrating, and I'm amazed that no permanent solution was ever found that solved the problem for everyone.  I sympethize with everyone who is still fighting the problem. Best of luck in finding a solution.

  • nilave85 Level 1 (0 points)

    I had the same problem with my MacBookPro for the past 2 months. Here is a brief background of the issue:


    Im staying at an apartment with my friends with total 3 computers (1 Mac and 2 WIndows PC). Starting we had Netgear router with Comcast connection. Then we had this problem of Wifi dropping where the Windows PC will lose connection while my MBP will run fine. We had to reboot the router to fix that.


    Then Comcast replaced the Netgear router with their horrible Xfinity modem+router. Connection speed became slow and my MBP gave lots of problem. Suddenly my internet will go off. The Airport icon will show connected but still internet will not come. As a resolution I will be turning off airport and turning it on . This will fix the issue. While the Windows PC will not have any disconnects. Recently this problem has become from bad to worse. every 1 minute my connection will go. I was of the idea maybe my Airport card has gone. But recently I got the new Ipad and that also faced the same problem. It was clear that there was some problem with Airport software.

    This frequent on and offs made me a psycho and I was on the verge of breaking my PC


    Finally I came across this discussion and found some solace that Im not the only one having this problem. I tried the troubleshooting steps provided in some posts (DNS change to / Deleting User accounts / Removing router security / placing my PC near the router, etc) .. Nothing worked!. Finally a came across a post informing to change the channel of router. I tried changing to 1 .. same issue. But when I changed to 11 .. its working superbly. This is awesme news and for the past 24 days there has been no disconnects in both my MBP and IPAD.


    Thanks to whoever gave the idea of changing the router channel to 11.

  • mateussouzaweb Level 1 (0 points)

    It worked for me too! Thanks!!!

  • PDiggy Level 1 (0 points)

    All Things Apple claims to have the definitive two-part solution, for both Lion and Mountain Lion.  It involves:


    Fix #1: Add a New Network Location and Renew DHCP

    Fix #2: Change MTU Size to prevent Dropped Connections

    and I'd add one more important step from their additional suggestions:

    Fix #3: Try changing the channel of the router you are connected to


    For that last one, consult your router's manual. For the first two, instructions are here:


  • TanITKMS Level 1 (0 points)

    I tried your suggestion with Fix #1, 2 and 3 but still not working. I'm using:


    - Cisco Linksys E2000 and E2500 in my network

    - Authentication WPA2 Enterprise (authenticate with Domain Active Directory via Radius Protocol)

    - User using Mac book pro 13-inch Mid 2012 with Mountain Lion


    Does anyone here using the same as me?



  • Level 1 (0 points)



    I too sufferred with this and was constantly trying to get it back up. I am good now and able to have it connected for almost 18 hours.


    The things that I did on my phone was:


    1.Try changing the SSID of your wireless router , apply settings on the router and simulatenously switch off the Mobile data and Wifi. Rebbot the Device and turn it on. Turn the mobile data followed by Wifi (enable it).


    2.Delete the caches and temporary internet files.


    2. Reset the Network Settings


    Thats what brought my lil devil and am happy with it again

Previous 1 73 74 75 76 77 Next