Previous 1 2 3 4 Next 1,153 Replies Latest reply: May 8, 2013 9:30 AM by i5.com Go to original post Branched to a new discussion.
  • William Kucharski Level 6 Level 6 (14,890 points)
    Look in your system.log (viewable via Applications->Utilities->Console) and look for reasons your connection may be dropping and report back.

    You're looking for messages like:

    <pre>AirPort: No beacon for too long time</pre>

    or:

    <pre>AirPort: Link Down on en1. Reason 4 (Disassociated due to inactivity).</pre>
  • David J. Reeves Level 1 Level 1 (15 points)
    Turning off Airport and using Ethernet only fixed my problems temporarily, a day later it started dropping connections again.
  • rickrob Level 1 Level 1 (10 points)
    Same problem here. I'm on a public wifi signal, no security (WPA,WEP,etc.) involved. I have a full signal, but after 10-15 minutes, the internet connection is lost. Retarting the computer reconnects me, but then it just drops off again. Sounds like this will only be solved by an update. Hopefully it comes out soon to avoid reinstalling 10.5.
  • Mike from LR Level 1 Level 1 (0 points)
    I want to add my name to the beleaguered who are enduring the dropped Wi-Fi. I've had this MBP for a month, and it never dropped the signal. After I installed SL, the Wi-Fi intermittently drops, but the airport icon shows me connected and at full bars. My Vista PC maintains an active connection even when my MBP+SL goes out.
  • William Kucharski Level 6 Level 6 (14,890 points)
    No one here has yet answered the question as to whether they see any messages related to their drops in their logs (see my post above.)
  • pjrothman Level 1 Level 1 (0 points)
    This solution worked for me as well.
    I found the whole problem quite perplexing. I couldn't connect to WWW or get email, yet I could connect to my school's server directly and control server via ARD.
    I could connect using ethernet to everything vis ethernet.
    Trashin SystemConfiguration did work.
  • Adam Hall1 Level 1 Level 1 (0 points)
    Yes, getting the Link Down on en1 message on 10.6. The router a linksys running (DD-WRT v23 SP2 (09/15/06) ) reports a slowly degrading signal quality from the MacBook Pro (15") . Starts at about 50% (this is 9 feet away from the router) and drops over the course of a few hours (2-3) to around 10%, which is when drop outs start occurring. A reboot does not fix. You have to power down and wait at least a few minutes to get back to where you started with a 50% signal that starts dropping over time. I did not move the laptop from its physical location while the signal slowly degrades. Later went back to 10.5 from a backup drive, and could not reproduce the problem anymore. Reinstalled 10.6 as an upgrade to 10.5 as well as a clean install and problem comes back... Here is some kernel log entries to show the last few drop outs, if you need more info, I can reproduce this fairly consistently:

    Sep 7 20:19:33 localhost kernel[0]: BSD root: disk0s2, major 14, minor 2
    Sep 7 20:19:33 localhost kernel[0]: jnl: unknown-dev: replay_journal: from: 9133056 to: 10576896 (joffset 0x951000)
    Sep 7 20:19:33 localhost kernel[0]: jnl: unknown-dev: journal replay done.
    Sep 7 20:19:33 localhost kernel[0]: [Bluetooth::CSRHIDTransition] switchToHCIMode (legacy)
    Sep 7 20:19:33 localhost kernel[0]: [Bluetooth::CSRHIDTransition] transition complete.
    Sep 7 20:19:33 localhost kernel[0]: CSRUSBBluetoothHCIController::setupHardware super returned 0
    Sep 7 20:19:33 localhost kernel[0]: hfs: Removed 7 orphaned / unlinked files and 0 directories
    Sep 7 20:19:33 localhost kernel[0]: AppleIntelCPUPowerManagement: initialization complete
    Sep 7 20:19:34 localhost kernel[0]: AppleYukon2: Marvell Yukon Gigabit Adapter 88E8053 Singleport Copper SA
    Sep 7 20:19:34 localhost kernel[0]: AppleYukon2: RxRingSize <= 1024, TxRingSize 256, RXMAXLE 1024, TXMAXLE 768, STMAXLE 3328
    Sep 7 20:19:40 localhost kernel[0]: yukon: Ethernet address 00:16:cb:91:ee:ae
    Sep 7 20:19:42 localhost kernel[0]: systemShutdown false
    Sep 7 20:19:43 localhost kernel[0]: Waiting for DSMOS...
    Sep 7 20:19:46 localhost kernel[0]: Previous Shutdown Cause: 0
    Sep 7 20:19:46 localhost kernel[0]: DSMOS has arrived
    Sep 7 20:19:46 localhost kernel[0]: Warning - com.apple.driver.InternalModemSupport declares no kernel dependencies; using com.apple.kernel.6.0.
    Sep 7 20:19:46 localhost kernel[0]: Atheros: mac 10.3 phy 6.1 radio 10.2
    Sep 7 20:19:47 Adam-Halls-MacBook-Pro-15 kernel[0]: AirPort_AthrFusion: Ethernet address 00:16:cb:08:bf:7a
    Sep 7 20:19:47 Adam-Halls-MacBook-Pro-15 kernel[0]: IO80211Controller::dataLinkLayerAttachComplete(): adding AppleEFINVRAM notification
    Sep 7 20:19:47 Adam-Halls-MacBook-Pro-15 kernel[0]: AirPort: Link Down on en1. Reason 1 (Unspecified).
    Sep 7 20:19:47 Adam-Halls-MacBook-Pro-15 kernel[0]: athset_rxchainmask[5113] sc->sc_config.rxchainmask 5 mask 5
    Sep 7 20:19:47 Adam-Halls-MacBook-Pro-15 kernel[0]: athset_txchainmask[5124] sc->sc_config.txchainmask 5 mask 5
    Sep 7 20:19:47 Adam-Halls-MacBook-Pro-15 kernel[0]: getWOW_PARAMETERS: Can't set wow params. Wow is not supported
    Sep 7 20:19:49: --- last message repeated 1 time ---
    Sep 7 20:19:49 Adam-Halls-MacBook-Pro-15 kernel[0]: AirPort: Link Up on en1
    Sep 7 22:23:55 Adam-Halls-MacBook-Pro-15 kernel[0]: decmpfs.c:1314:decmpfsreadcompressed: clustercopy_upldata err 14
    Sep 7 22:23:55 Adam-Halls-MacBook-Pro-15 kernel[0]: decmpfs.c:1337:decmpfsreadcompressed: err 14
    Sep 7 22:59:33 Adam-Halls-MacBook-Pro-15 kernel[0]: hfs: Removed 1 orphaned / unlinked files and 0 directories
    Sep 7 23:01:01 Adam-Halls-MacBook-Pro-15 kernel[0]: AirPort: Link Down on en1. Reason 4 (Disassociated due to inactivity).
  • William Kucharski Level 6 Level 6 (14,890 points)
    Are any of you seeing an inactivity disassociation finding your connection still drops if you have background activity going on, like playing a streaming radio station?
  • alpha4omega Level 1 Level 1 (0 points)
    hi guys, i used to have this same issue on leopard, but this is how i fixed it. After alot of reading, it seems theirs an issue btw macbook n compatibility with third party routers, so go to your router change it to "G" then restart it. you can also delete the connection on your apple so you can create a new one to the router. that should resolve it. Also i notice,you might need to change the channels to see which one is faster and stable. Since then i havent had the issue. I also got snow leopard on the day it was released and installed it, everything works fine as well, so i took the confidence to the change the router back to "N" now am surfing at super speed.. Try this, if any success post back.
  • Adam Hall1 Level 1 Level 1 (0 points)
    Went to G only. I can still reproduce the problem. I think the slow degradation of the signal quality from the Macbook may be a clue. If you make adjustments and reboot your computer you have the distinct possibility of simply resetting the problem and mistakingly thinking the problem is fixed. I never have the dropout after the laptop is off for a little while. It first comes up fine, it is only after an hour or more that the dropouts start occurring. (Sometimes longer). Also people may not notice a problem if they are relatively close to the router or use it for short times, thus thinking there is no problem or an earlier issue was some sort of anomaly. I can reproduce the problem fairly consistently with both Apple routers as well as a Linksys running DD-WRT, but can not do so with a 10.5 installation on the same laptop. My procedure is to use the computer at around 50 feet or so from the router and surf the web etc for 2-3 hours. Then you can have a dropout and it is impossible to reconnect unless you turn the laptop OFF for AT LEAST a few minutes. It's a little baffling but hopefully my earlier log could help.
  • alpha4omega Level 1 Level 1 (0 points)
    did you try changing the channels as i have problem staying connected on channel 9, but i have success with 6 and 13. well, i dont think the distance in my case is a problem as i live on the top floor of a two storey building and my router is on the first floor. Try changing the channels .
  • alpha4omega Level 1 Level 1 (0 points)
    also,while you in G mode , go to keychain and delete your previous wireless password as well as your network settings then save, restart it . After reboot, try connecting again and save the password in your keychain.
    another step you can try is adding public dns to your network setting.
  • Qtip1423 Level 1 Level 1 (0 points)
    I'd been having this same issue with my Mini since upgrading to SL. Tried all the fixes I came across (changing channels, trashing plists, deleting/rejoining network, moving it to the top of my preferred networks list, et al). I'm connecting to a Time Machine, and I found that making one change in the security settings on the TC fixed the issue for me; all I did was change the security on the TC from WPA/WPA2 Personal to just WPA2 Personal. Made the change an hour ago, and even after half a dozen restarts (I wanted to be sure), it reconnects to the network right away and stays connected for the duration of my uptime.

    I'll post again in the morning with an update, but it seems that (for now at least) it's working again.
  • ccfarr Level 1 Level 1 (0 points)
    I upgraded to Snow Leopard and the wifi drops about 8 to 10 times a day. I have an Airport Extreme. Please respond Apple...

    Thanks.
  • Adam Hall1 Level 1 Level 1 (0 points)
    No change. Drop outs still occur.
Previous 1 2 3 4 Next