Previous 1 8 9 10 11 12 Next 206 Replies Latest reply: Jun 14, 2010 8:57 AM by lolondonkb Go to original post
  • William Hasselo Level 2 (420 points)
    Check out DejaVue, works great, no problems.
  • pr1m3_5u5p3ct Level 1 (0 points)
    William Hasselo wrote:
    Check out DejaVue, works great, no problems.

    Link please?
  • bendbuddy Level 1 (0 points)
    I'm having the same frustrating problems as everyone else. I have two Seagate 1 TB drives connected and that 109 error started popping up the last few days. I sold on that Deja Vu service (enough already with all those gunk and hardware mess).

    Thanks for posting y'all,

  • rsva Level 1 (10 points)
    As promised I've put on my geek glasses and greased up my hair to hack my way to a solution,
    As I learned in med school, the next best thing to a cure is a full relief of the symptoms, so what I did is using some oldschool unix based commands to go beyond the capabilities of disk utility to fix the errors and -oh joy oh glory- it works! I just got back my 300 gig of backups and it has been working perfectly since (24h and counting...)!

    The following tutorial should be working in almost all cases to repair the corrupted sparsebundles.
    It DOES NOT however fix the bug, as tampering with the firmware may be illegal and blow many of your warranties so I left that part behind for now.

    Also, with the mentioned prevention tips&tricks stated earlier in the forum and this little trick to repair any damage, I think we have a workable solution for now. Good luck!

    Step 1: Take all the prior-mentioned prevention measures so the error won't return and so we can make sure these don't solve the corruption. The most useful tips have included:
    - Trying to do a backup with the drive directly connected to your mac.
    - Using disk utility to see if any errors are found (in this case, it would be a good sign as this will mean this tutorial will probably work for you).
    - Renaming all the drives, the AEBS, the sparsebundle to short names, not involving any special characters like symbols, spaces, ', etc.
    - Disabling backups on battery power.

    Step 2: Have about an hour of your time reserved, connect your HD to your Mac(book) directly and have both on a reliable power supply.

    Step 3: Make sure nothing pulls on your external HD.
    The harddrive must be accessible trough terminal (e.g. mounted), but the damaged sparsebundle by all means not (yet)! If you can't mount your drive for some reason, you might try to use the same trick we will use later on to attach the sparsebundle.
    Time Machine must also be off, disk utility too, check the processes in your activity monitor and keep an eye on them if you get access errors, restarting might also help if you can't find the right process or killing them doesn't seem to help.

    Step 4: the reparation process:

    - Get your Terminal running everything we do will run from there from now on
    - Navigate to your external hd (goto top level using "cd .." as many times as necessary then cd volumes then cd {yourdriveorpartitionname},
    - Now we will try to attach the corrupted sparsebundle instead of mounting it, this is what disk utility and TM do and and fail at sue to the corruption. Use the following command line:

    hdiutil attach -nomount -readwrite whateveryounamedit8634278.sparsebundle

    Now wait! let your drive work for a while, it could take some time especially if the damage is extensive. If succesful, you will get something like this:

    /dev/disk4 Applepartitionscheme
    /dev/disk4s1 Applepartitionmap
    /dev/disk4s2 Apple_HFSX

    Good, now you can input this command.

    fsck_hfs -rf /dev/disk4s2
    (*note: here you need to input the bottom /dev/, the one respective to Apple_HFSX!)

    Your drive will now go bonkers and a log of the reparation process will follow, it will mention a lot of errors and repair some of them, this is once again a good sign. This process takes a while, take a meal, a bath, give your friends/kids/partner some attention and check again every once in a while.

    At the end, after mentioning "repairing volume" your terminal might mention "drive contains errors, cannot repair" and interrupt the process. Ignore that. It has done some work.

    Now we will have to do the rest of the work with a new command.
    Restart your mac with the external hard drive out to make sure it isn't in any way mounted.
    Now go through the steps mentioned before, but now with a "hdiutil" command with other parameters set. Use the following commands in step 4 now, and be patient again.

    hdiutil attach -nomount -readwrite -noautofsck -noverify whateveryouname8634278.sparsebundle

    *lists the drives again*

    fsck_hfs -rf /dev/disk4s2

    Now (in my case) the util spoke of "minor damage" and work was done much faster, and indicated success!

    It might be an option to try this second option directly, the first command does a sort of autocheck that needed to be disabled so the reparation process could continue so in theory the second alone should be okay. I haven't tried that though, this is how it worked for me, and I don't need to repair anything anymore! (*knocks on wood*)

    Good luck to all of you, I wish you all a happy 2010 with lots of working but unnecessary backups!
  • BPK Ohio Level 1 (0 points)

    I am having this problem, as of today, after using a WD 1TB drive since last March and connected to the AEBS. I have upgraded to SL but all was working fine until today.
    I have to say, all this talk about Apple not officially supporting Time Machine backups through AEBS is puzzling....I think most people see that USB port and either think printer or external HD. Would be a shame to see that functionality either totally tank or not be addressed in an effort to sell more TC units.
    I have had no luck with the detailed instructions offered on some other posts here. I can't even get the Sparsebundle to attach.
  • rsva Level 1 (10 points)
    BPK Ohio, did you try my tutorial?
    If yes, what happens when you use the terminal command to attach the sparsebundle?
    My time machine had been working like a charm since I fixed it by the way.
  • PeterO2 Level 1 (40 points)
    Bob, I'm trying your fix, but after entering the hdiutil attach -nomount -readwrite nameofbundle.sparsebundle command the terminal just gives me a ">" and no other information.
    Peter O.
  • jdullman Level 1 (0 points)
    I'm having the same issue as everyone here. I just got my time capsule for Christmas. I've tried everything but am thinking that it may have to do with my name being so long (or at least that may be part of the problem). Does anyone know how to reinstall or change the name ?

  • Pondini Level 8 (38,715 points)
    jdullman wrote:
    I'm having the same issue as everyone here. I just got my time capsule for Christmas. I've tried everything but am thinking that it may have to do with my name being so long (or at least that may be part of the problem). Does anyone know how to reinstall or change the name ?

    See #C9 in the Time Machine - Troubleshooting *User Tip,* also at the top of the +Time Machine+ forum.
  • BPK Ohio Level 1 (0 points)
    IT WORKED! :> Not sure why I was having issues yesterday with the "attach" command, but today it worked like a charm! You are a Saint for coming to the rescue of folks on here with this issue.

    A big shout out of thanks goes to RSVA for posting his lengthy tutorial on how to address the "109 error" for folks using an external HD connected to their AEBS. I followed the instructions line by line and had the Time Machine back up and running in less than one hour. Tested it first hooked up directly to the computer and then moved it back to the AEBS.

    Thanks again to you, RSVA!
  • jdullman Level 1 (0 points)
    I saw a forum post on the error 109 and taking to look to prepare backup that indicated that the sparseundle file was causing the error and that Apple support indicated to delete the sparsebundle file, reboot and backup again...this worked for me!
  • zzz99 Level 1 (0 points)
    Hi rvsa,

    What about if I have already deleted the sparsebundle on the Ext. Hd that attach on the AEBS?

    Is there any "way" to make TM backup-able again?

    Please advise.
  • Topher Kessler Level 6 (9,865 points)
    Your only option if you've deleted the sparsebundle is to start over from scratch. Try formatting the drive and freshly setting it up.
  • rsva Level 1 (10 points)
    That means it's trying very hard to attach your drive, I suppose you waited a while?
    Killing terminal and trying again might help, but as I told in the tutorial, you must be absolutely sure that nothing else is using your HD: getting to read a corrupted file is hard enough as it is for a computer, is the drive is reacting slowly as well it might get so slow it will timeout before it's done!

    Tip: try the tutorial after running disk utility to repair the partitions (NOT the sparsebundle, that won't work) on a fresh reboot, with the HD connected directly as the only peripheral.

    If it still freezes up you might wanna check if your HD isn't at fault (check the access and copy/reading of any random new files on that partition and listen for any ticking, interrupted humming sounds, the beep of death (might be subtler than you think) or a complete silence while operating)
Previous 1 8 9 10 11 12 Next