Previous 1 9 10 11 12 13 14 Next 206 Replies Latest reply: Jun 14, 2010 8:57 AM by lolondonkb Go to original post
  • DesiDS Level 1 Level 1 (0 points)
    Thanks RSVA for the detailed instructions - it worked great. I had run along fine for months with no problem, then on Dec 23 got the 109 error. I have a USB drive connected to an Airport Extreme - so doing backups over the network (wired). I actually got a good result after the initial part of the process - it stated all errors fixed (or something similar). Once done, tried a backup, and Time Machine is alive again.

    Desi
  • davida Level 1 Level 1 (0 points)
    Thank You RSVA,

    Something for the future. I am a program on IBM iSeries systems but I don't know Unix. I had some difficulty cd ing to the volume could no find and example and spent a good 30 mins googling. finally figured it out and cd /Volumes/DriveName and it worked fine.

    The attached worked very fast with no problems. The reparation took a while and ended by with the message that it could not be repaired. I ran it again and it worked fine and repaired the damage.

    Learn a bit from this process. With this happening to those with the drive attached directly and via Airport Extreme plus Time Capsule there must be a software bug or some bad logic that should be able to prevent this damage. I have 2 iMacs and a Mac Book with an eMac using the same 500 gb drive as backup and the only one with the problem has been a New iMac 21" purchase about 3 weeks ago.

    Thank You again. This kind of debugging can be time consuming.
  • Sean Mcclafferty Level 1 Level 1 (25 points)
    I have this same issue...just get the > symbol. I waited about an hour for something happen, but no dice.
  • rsva Level 1 Level 1 (10 points)
    It's hard for your system to attach the drive, since there's obviously a corruption interfering with the usual I/O commands.
    Best thing to do is to start all over with a freshly rebooted OS with as little other processes running as possible, especially anything that might interfere with the read/write commands going on between your mac and the HD. Also make sure the partition containing is properly mounted and as error-free as possible (your OS's disk util works fine for that part of the repair).

    Keep trying a few times, almost all of the people I spoke to up to now eventually got it working at some point with some perseverance. If it doesn't attach after so many tries, I guess your level of file corruption might be too high for my fix to handle. You'd be a first though, so I'd recommend not to give up too quickly.

    Good luck!

    OT: My TM has now been working for about two weeks since the fix, no errors yet, all data accessible.
  • Sean Mcclafferty Level 1 Level 1 (25 points)
    Thanks! I'll keep trying. Appreciate your help!
  • rsva Level 1 Level 1 (10 points)
    No problem, and keep us posted on your issue! I'll be back to work from tomorrow on but I'll try to answer as many enquiries as possible in my private time.
  • mitconsulting Level 1 Level 1 (0 points)
    I have an AEBS using an Airport Extreme and a USB attached WD Passport. It worked fine until recently when I upgraded to Snow Leopard, then I started receiving the sparse bundle error 109 as well. Backup was being done wirelessly.

    I plugged the external drive into my MacBook Pro and used disk utility to look at the drive. There was still 1.4G of free space on the drive. The information that caught my eye was in the bottom right hand corner. It showed Master Boot Record instead of GUID as the partition format.

    In my case, I decided to re-partition the drive into GUID instead of MBR. Since then, it's been working flawlessly. This is a consideration if you are using an external drive that was formatted to work with both the PC and the Mac.

    HTH.
    Stephen
  • aboutel Level 1 Level 1 (0 points)
    I had this problem on various machines (MBP, white iMac, alum iMac), and on each of them it eventually turned out to be a keychain problem. The solution was to delete my keychain items for the AEBS external drive, restart, re-select the AEBS drive in Time Machine prefs (re-entering my password for the disk). Voila; the back-up disk mounted, and all the old back-ups were available again.
  • henry67 Level 1 Level 1 (0 points)
    Well, I thought I had found a solution: after all the past problems, the last month I was backing up flawlessly just switching off and then on the external drive before run the TM backup, but suddenly the error 109 come back again.

    I then tried the rsva fix, and it didn't work the first time (after the whole process I've got a message that disk can't be repaired) but the second time I've got the message "The volume Backup of Time Machine was repaired successfully"!!

    I tried to enter in TM and it worked, then I performed a 25GB backup without any problem.

    Thank you rsva for the great fix and tutorial!

    I've to say I met some problem during the process: just after the command "fsck_hfs -rf /dev/disk2s2" I got the message "Can't open /dev/rdisk2s2: Resource busy".
    I spent some time to figure out, how to go ahead and finally monitoring the processes I figured out that just after get the list of the drives, a process called "fsck_hfs" was running, giving the above result of busy resource; killing the process allowed me to proceed.
    Perhaps this can be helpful for somebody else out there!
  • Stecki Level 1 Level 1 (0 points)
    I'm trying rsva's tutorial with my MBP and TC and I'm getting the following Terminal message:

    Mycomputer:Data Myname$ fsck_hfs -rf /dev/disk1s2
    ** /dev/rdisk1s2
    Executing fsck_hfs (version diskdev_cmds-491~1).
    ** Checking Journaled HFS Plus volume.
    ** Detected a case-sensitive volume.
    Catalog file entry not found for extent
    (4, 0)
    ** The volume could not be verified completely.

    Also, the command hdiutil attach -nomount -readwrite whateveryounamedit8634278.sparsebundle just took seconds which was strange to me.
    Could anybody help?
  • mrurmil Level 1 Level 1 (40 points)
    Hello,

    I am getting the following error after following rsva's steps. This is after the 2nd step, where I should be expecting a successful repair:


    ** The volume Time Machine Backups could not be repaired after 3 attempts.
  • markusn Level 1 Level 1 (0 points)
    I suddenly got the dreaded 109 error, and then found this thread. After repairing the attached drive (consisting of two partitions of which one is used for TM), I then started to follow rsva:s tutorial. Now, I'm stuck at where I enter this command: "hdiutil attach -nomount -readwrite /Volumes/tidsmaskin/Markus\ MBP_001b63bb915f.sparsebundle "

    (I had too google how to get the correct path to the disk since I have a space in the name, and I even dragged the sparsebundle file into Terminal to get the correct characters and path.)

    When this command is entered, I get:

    hdiutil: attach failed - not recognized
    Markus-MBP:~ markus$

    What to do? Any ideas?
  • briajens Level 1 Level 1 (0 points)
    Hi markusn

    I have exactly the same problem. As suggested in this thread I have rebooted multiple times to try the command without any luck.

    My error came out of nowhere. I didnt do any updates or changes to the airport extreme nor to the MBP.
  • rsva Level 1 Level 1 (10 points)
    Haha those dreaded command windows are always a pain if you're not used to the.
    Ok, so what you guys should try is to navigate to the folder where your sparsebundle is located IN TERMINAL, so do not input the path in the command window. This is how.

    go to top level using "cd .." as many times as possible, you'get something like "computername: homefoldername$
    Then, for instance, in Marcus' case:
    cd volumes
    cd tidsmaskin
    cd Markus

    THEN input

    hdiutil attach -nomount -readwrite MBP_001b63bb915f.sparsebundle

    All commands are not case sensitive or anything, just white out right.
    Get the difference?
    This should work, let me know if anyting is still unclear.
  • rsva Level 1 Level 1 (10 points)
    Fix your drive (NOT the sparsebundle) first using disk repair, and make sure you try the first command first and let it run, it's ok if it's slow, then and only then run the second.
    I got the same kind of error using the first command, it still fixed enough to make the second one working.
    Let us know if it worked.

    Cheers.