Previous 1 10 11 12 13 14 Next 206 Replies Latest reply: Jun 14, 2010 8:57 AM by lolondonkb Go to original post
  • briajens Level 1 Level 1 (0 points)
    rsva. I am greatful that you are taking the time to help us but your solution doesnt work for me.


    This is what I get in the terminal:

    Last login: Thu Jan 7 13:56:32 on ttys003
    Mithril:~ brianj$ cd /Volumes/
    Mithril:Volumes brianj$ ls
    Macintosh HD Misc Time Machine
    Mithril:Volumes brianj$ cd Time\ Machine/
    Mithril:Time Machine brianj$ ls
    Old Backup.sparsebundle
    Mithril:Time Machine brianj$ hdiutil attach -nomount -readwrite Old\ Backup.sparsebundle/
    hdiutil: attach failed - not recognized
    Mithril:Time Machine brianj$

    and this is after having used the disk utility to repair the drive.

    rsva. Thanks for the tutorial, but the problem is it doesnt work in my case.
  • rsva Level 1 Level 1 (10 points)
    "Not recognized" looks like a pure syntax or path error. Not like a failed mount
    Try changing the sparsebundle name till it contains only alphas, and move it at the highest possible level (ie at the root of your external HD)
    And make sure you killed disk utility properly.

    If it still won't work it might mean the sparsebundle is really, really FUBAR but I doubt that's the reason for such an error.
  • briajens Level 1 Level 1 (0 points)
    hi rvsa

    Ok I changed some names and tried again. Same error:

    Mithril:TimeMachine brianj$ pwd
    /Volumes/TimeMachine
    Mithril:TimeMachine brianj$ ls
    Backup.sparsebundle
    Mithril:TimeMachine brianj$ hdiutil attach -nomount -readwrite Backup.sparsebundle/
    hdiutil: attach failed - not recognized
    Mithril:TimeMachine brianj$


    And yes Disk utility is closed
  • rsva Level 1 Level 1 (10 points)
    Hm, weird, Time Machine is turned off as well?
    My last guess would be to reboot and try one more time.
    If that doesn't work I'm afraid the FUBAR hypothesis might be true after all.
    Or maybe someone else has an idea?
  • briajens Level 1 Level 1 (0 points)
    Yes time machine is off. However I did a ls -lsA in the terminal and got:

    0 d--------- 3 brianj staff 238 4 Jan 19:18 Backup.sparsebundle

    no permissions!

    so I did chmod u+rwx Backup.sparsebundle

    and then hdiutil attach -nomount -readwrite -noautofsck -noverify Backup.sparsebundle/

    and I got a success!

    then I did the sudo fsck_hfs -rf /dev/disk2s2

    Output:
    Mithril:/ brianj$ sudo fsck_hfs -rf /dev/disk2s2
    ** /dev/rdisk2s2
    Executing fsck_hfs (version diskdev_cmds-491~1).
    ** Checking Journaled HFS Plus volume.
    ** Detected a case-sensitive volume.
    ** Checking extents overflow file.
    ** Checking catalog file.
    ** Rebuilding catalog B-tree.
    ...
    errors fixed

    bottom line: It was a permissions error, once I fixed that then I was able to follow your guide.
  • markusn Level 1 Level 1 (0 points)
    Hi rsva & briajens! I admit that I'm very, very non fluent when it comes to fiddling around in Terminal. However, I understand as much as where to be in the hiarchy =) Here's a transcript of what I just did without success in getting my Time Machine-disk up and running again. I also re checked in Disk Utility so that the disk is veryfied. Then, I quit Time Machine & Disk Utility.

    What may make my case different from briajens is that my sparse bundle filename consist of a space. I also have my girlfriend's backup at the same disk (as seen in the listing below)

    Last login: Fri Jan 8 16:41:02 on ttys000

    [cd:ing a few times until I got to the correct place to be:]

    Markus-MBP:~ markus$ cd ..
    Markus-MBP:Users markus$ cd ..
    Markus-MBP:/ markus$ cd ..
    Markus-MBP:/ markus$ cd volumes
    Markus-MBP:volumes markus$ cd tidsmaskin
    Markus-MBP:tidsmaskin markus$

    [doing what briajens did in his last post:]

    Markus-MBP:tidsmaskin markus$ ls -lsA
    total 32
    8 -r-------- 1 root wheel 16 2 Jun 2009 .0017f22ce422
    8 -r-------- 1 root wheel 16 18 Jun 2009 .001b63bb915f
    16 -rw-r--r--@ 1 markus staff 6148 8 Jan 16:42 .DS_Store
    0 drwx------ 3 markus staff 102 8 Jul 2009 .Spotlight-V100
    0 d-wx-wx-wt 3 markus staff 102 8 Jan 16:40 .Trashes
    0 -rw-r--r-- 1 markus staff 0 8 Jul 2009 .com.apple.timemachine.supported
    0 drwx------ 13 markus staff 442 8 Jan 16:40 .fseventsd
    0 drwxr-xr-x 4 root wheel 136 8 Jul 2009 Backups.backupdb
    0 drwx------ 6 root wheel 204 12 Jul 21:34 Cecilia’s MacBook_0017f22ce422.sparsebundle
    0 drwx------ 7 root wheel 238 5 Jan 23:48 Markus MBP_001b63bb915f.sparsebundle
    Markus-MBP:tidsmaskin markus$

    [then, doing the chmod-command:]

    Markus-MBP:tidsmaskin markus$ chmod u+rwx /Volumes/tidsmaskin/Markus\ MBP_001b63bb915f.sparsebundle

    [then, did this:]

    Markus-MBP:tidsmaskin markus$ hdiutil attach -nomount -readwrite -noautofsck -noverify /Volumes/tidsmaskin/Markus\ MBP_001b63bb915f.sparsebundle

    [and that resulted in the same attach-fail-command as earlier:]

    hdiutil: attach failed - not recognized
    Markus-MBP:tidsmaskin markus$


    Now, how can I make sure that permissions are okay? Anyone up for typing down another tutorial for a non-command guy like myself? Cheers.
  • rsva Level 1 Level 1 (10 points)
    Istead of your last command, try this one:
    hdiutil attach -nomount -readwrite -noautofsck -noverify MBP_001b63bb915f.sparsebundle
  • markusn Level 1 Level 1 (0 points)
    rsva,
    thank you for trying to help me out.

    Ok, entered this instead of the last command:
    hdiutil attach -nomount -readwrite -noautofsck -noverify /Volumes/tidsmaskin/Markus\ MBP_001b63bb915f.sparsebundle

    And got this familiar one:
    hdiutil: attach failed - not recognized
    Markus-MBP:tidsmaskin markus$
  • Brdgr Level 1 Level 1 (0 points)
    Enter the exact command supplied by rsva while in the correct directory.

    You added the directory part to the file name, and that's probably causing the issue as there is probably a space or a backslash in the directory name. The error suggests that it's not able to determine the image name correctly.

    The directory (/Volumes/tidsmaskin/Markus/) is superflous if you are in that directory when entering the command.
  • Brdgr Level 1 Level 1 (0 points)
    My case is exactly similar to yours. I have found no way to fix the sparsebundle nor can it be mounted. Please let me know if you find a way to fix the image.
  • markusn Level 1 Level 1 (0 points)
    Brdgr, there's actually an error in rsva's example. There's no directory named "Markus" as this text is included in the filename -> "Markus MBP_001b63bb915f.sparsebundle"

    As I stated a few times earlier, I have a space in the filename of the sparsebundle, and to make this space overridden I have to enter a backslash plus a space, hence "\ " (this is verified by dragging the sparsebundle file into Terminal where it automatically adds the correct characters to the command.

    Cheers,
    Markus

    Message was edited by: markusn
  • Brdgr Level 1 Level 1 (0 points)
    I'd rename the sparsebundle as suggested earlier to a name containing no special characters (including spaces). The first part of the filename can be pretty much anything, only the MAC-address of the system in the file name is significant (the hex string 001b63bb915f).
  • Stecki Level 1 Level 1 (0 points)
    Thanks a lot for your efforts rsva!

    Could you give me another hint, please. As I only recently switched from PC to MAC I am not quite familiar with MAC procedures. Here is my question: How do I use "disk repair" with my Time Capsule? Time Capsule does not show up in the disk utility tool.

    I could even re-format Time Capsule as I have transferred all data to an external hard disk. But how would I do this?
  • henry67 Level 1 Level 1 (0 points)
    Yesterday I've got again the Error 109!!
    Today I did again the rsva fix - we'll see how long will last.
    Frankly I hope much more than the last time.
  • rsva Level 1 Level 1 (10 points)
    Stecki,
    Both repairing and reformatting are possible using disk utility.
    This tool can be found by default in your applications folder, in the "utilities" subfolder.
    You could also alternatively search it (cmd+space) by typing disk utility and clicking the app's icon in the results tab.

    Cheers