Previous 1 10 11 12 13 14 Next 206 Replies Latest reply: Jun 14, 2010 8:57 AM by lolondonkb Go to original post
  • Pondini Level 8 (38,715 points)
    rsva wrote:
    Both repairing and reformatting are possible using disk utility.

    You can do a +*Repair Disk+* on a Time Capsule's sparse bundle (see #A5 in the Time Machine - Troubleshooting *User Tip,* also at the top of the +Time Machine+ forum), but you can't reformat it.

    You can, however, erase it via the +*Airport Utility+* app, in your Applications/Utilities folder.
    Select +*Base Station > Manual Set-Up+* from the Menubar, then Disks in the tool Bar, then Erase.
  • Stecki Level 1 (0 points)
    Thanks rsva and Pondini for getting involved.

    I know disk utility. But my Time Capsule does not show up in disk utility and I can neither choose it from the menu nor drag & drop the drive or volume into disk utility. What do I do?

    Remark: I can drag & drop the sparsebundle into disk utility. It says it cannot repair it. Therefore, I wanted to do rsva's tutorial.
  • Jason Scott5 Level 1 (15 points)
    I tried all the above solutions regarding repairing the sparsebundle file, etc and nothing worked. However if you simply delete any keychain items you have regarding the airport extreme disk it all amazingly started to work just fine. So far its been working perfectly again with my iMac and MBpro both connecting to the same (time-capsule) backup disk on an airport extreme base-station for 2 days and counting... In fact as I'm typing it just did another flawless backup like it always used to.
    It seems that something stuffed up the passwords somehow in the most recent Apple Software Update.
  • FXR Level 1 (0 points)
    Thx Jason,
    I deleted the keychains and it worked !!
    Many thanks for the tip !

    Message was edited by: FXR
  • Gerhard Adler Level 1 (5 points)
    My airport extreme has worked fine with an external 1.5GB hard drive and 10.6.2 for months. The Error 109 "sparse bundle problem" presented itself over the last few days.
  • markusn Level 1 (0 points)
    I still haven't gotten my disk to work with TM despite all tips from you Terminal-dudes. I now even recorded a small movie with me fiddling around in a newly created user account (just to be sure). Can perhaps anyone spot anything noticeable in it? Watch the utterly interesting movie here:
  • Anita26 Level 1 (0 points)
    And how do you 'simply' delete the keychain items.......thanks in advance !
  • SnapperNZ Level 1 (0 points)
    Go in to Applications - Utilities - open "Keychain Access" application.

    In there, highlight All Items on the left and find your AirPort or remote disk - mine is a NAS and is listed under it's IP address. If you have an AirPort you've likely given it a network name, so look for that.

    Find it - highlight it, delete it.

    Now go in to Time Machine Preferences again, select disk, select the AirPort disk (Time Capsule or whatever it is you use) and you should be good to go.

    Worth noting though - this method has not fixed my issue with error 109 - I'm merely giving you this advise as you asked how to delete the keychain information.

    Hope it works for you!

  • pking Level 1 (0 points)
    I read through this whole thread on Sunday after experiencing the "error 109" message.

    Previously I had done a fresh install of SL 10.6.2 on a new HD and then moved all of my files/settings over from a disk image using Migration Assistant. All of that went smoothly. I used time machine to backup my machine once while directly connected to my external 1TB drive (with 2 500gb partitions) via Firewire - that was nice and fast, and successful.

    I then set up Time Machine to use that same external drive connected to my AEBS via USB and started a backup. It connected successfully and started a full backup. I'm not sure why it didn't just do the differences, maybe because it was connected via the AEBS rather than via Firewire. That backup took 12 hours to get through about 20gb out of 135gb, and I noticed via iStatPro (monitoring widget in dashboard) that my Mac was pulling down about 2-4x as much data as it was sending out via wireless - that didn't seem right so I manually stopped the backup and restarted. That's when the Error 109 started.

    I could not get TM to backup and I couldn't mount my time machine backup files via Disk Utility to repair them. So, after much consternation, I:

    1. Deleted the time machine backup folder on my remote drive. I noticed that the amount of free space on that drive didn't change when I did this... so that didn't seem right. Following this I was no longer able to find my drive in Disk Util via my wireless connection.
    2. Deleted all of the keychain access records for my AEBS.
    3. Connected to my remote drive directly via Firewire and ran Disk Utilities. I repaired the volume, which took a while but was successful.
    4. Reconnected my external drive via USB to the AEBS and remounted it to my mac via wireless.
    5. Started a new backup via Time Machine via wireless. It successfully connected and started the 135gb backup. It successfully finished the backup about 20 hours later (today). All appears to have gone well.
    6. Time Machine just finished an incremental backup a few minutes ago after having been asleep all afternoon.

    So - solved? We'll see. Doing the above may work for some of you, though only time will tell if the 109 comes back.
  • Pondini Level 8 (38,715 points)
    pking wrote:
    . . .
    I used time machine to backup my machine once while directly connected to my external 1TB drive (with 2 500gb partitions) via Firewire - that was nice and fast, and successful.

    I then set up Time Machine to use that same external drive connected to my AEBS via USB and started a backup. It connected successfully and started a full backup.

    Hi, and welcome to the forums.

    Yes, that's correct. Time Machine stores it's backups differently when done over a network (it doesn't matter if it's via Ethernet or WIFI). You cannot switch back and forth.

    You now have two sets of backups on that disk, one done while connected directly (in a Backups.backupdb folder), another done over the network (in a sparse bundle).

    At some point, you'll probably need the space the Backups.backupdb folder is taking up. When you do, connect the drive directly to your Mac to delete them. It will take a very long time even while connected directly, but much less than via Ethernet or WIFI.

    If you decide to back up directly, though, you can delete the sparse bundle relatively quickly.
  • orangechevy Level 1 (0 points)
    SOULTION !!!!!!!

    Run disk utility and "verify disk"

    if you need to "repair disk"

    Simple, Done.
  • SnapperNZ Level 1 (0 points)
    That's good news for you, but it is not "the solution" - there are a number of causes, each of which has a different fix.

    Certainly I've seen this with customers before and never has the DU fixed it. The sparesbundle gets broken beyond the DU repair function and the only option I've found is to recreate it.

    Still, you're up and running, good news
  • brokentry Level 1 (0 points)
    This is maddening. I upgraded to SL within a few days of its release and everything worked fine until yesterday. I have an AEBS with 1.5 TB connected to it. My imac just stopped being able to connect to it. My wife's MB however is working fine and that hdd is always on her desktop and mounted. I have noticed on mine it doesn't show mounted and will not show in Disk Utility, however it will show up in the finder and I can access files. I wonder if there is something on my imac I need to change.
    I don't understand why Apple would sell and AEBS with external storage capabilities, and have a program like TM is its OS, but not support TM backups with its AEBS. It's plain BS.
  • Alfred Barnat Level 1 (5 points)
    Same thing here. Everything was working great, and then "error 109". I had always wondered how Apple prevented Time Machine from corrupting the disk images it uses when the network connection is interrupted, and now I see that they don't. I am left wondering why they didn't just augment the protocol used for AFP shares to the point where Time Machine could backup remotely to a Time Capsule in the same manner it backs up to a local disk. Now I'm left with 324GB of useless disk image rather than 324GB of files which I could at least manually recover. I'm just happy I didn't decide to rely on Time Machine as my only backup, though it's very frustrating to lose months of backup history because of this flaw in Time Machine's design.
  • chad von nau Level 1 (10 points)
    I've had error 109 a few times in the past w/ 2 macs backing up to the same external HD on my AEBS. I'm pretty sure that the backup image gets corrupted due to sleeping the computer while a backup is in progress.

    Before today, I always just deleted the backup image and started over. Very easy, and you wind up w/ smaller backup images (for a while anyway). Today I wanted to see if I could recover the data, if I couldn't, I was gonna change backup programs. I had to connect the HD locally to one of our macs and run DiskWarrior on the backup image. It said it repaired a few dozen items. I reconnected the HD to the AEBS, ran Time Machine, and Presto! it's backing up as we speak.

    Anyway, my guess is that most of the corruption people are seeing is probably fixable w/ Disk Utility, DiskWarrior or rsva's command-line methods on page 10 of this thread.

    It'd be nice if apple prevented sleep on computers that are backing up until time machine can clean up after itself.