Skip navigation
This discussion is archived

Internet sharing doesn't work. Why?

8635 Views 17 Replies Latest reply: Nov 15, 2009 2:04 PM by MacDesigner RSS
1 2 Previous Next
Ninda Level 1 Level 1 (0 points)
Currently Being Moderated
Sep 5, 2009 7:05 AM
Before I upgraded, usually I like to turn on internet sharing from my mac and use it on my phone. But now on 10.6 it doesn't work anymore. Why is that? How do I fix it?

I share connection from ethernet to wi-fi using airport. Now it just doesn't show.
There used to be that black arrow pointing up on the wifi bars. But now there's none.

Help.

Thank you.
MacBook Pro, Mac OS X (10.6),  Classic • Nano  iPhone 3G
  • Vincent Verdun1 Calculating status...
    Currently Being Moderated
    Sep 5, 2009 7:50 AM (in response to Ninda)
    Same problem for me... I think it's because the "create wifi network" doesnt work…
    not found any solution …
    MacBook pro 15, Mac OS X (10.6)
  • RodneyW Level 4 Level 4 (3,030 points)
    Currently Being Moderated
    Sep 5, 2009 8:22 AM (in response to Ninda)
    I can replicate this problem (inability to create a network) - and I don't have a solution, other than logging a bug report to Apple.

    Cheers,

    Rodney
    MacBook (2.16 Ghz, 2 GB), Mac OS X (10.6), Powerbook G4 12i (867 MHz, 640MB, 10.4.11)
  • BigBen93 Calculating status...
    Currently Being Moderated
    Sep 7, 2009 7:05 PM (in response to Ninda)
    Same problem. Thought maybe it was a result of junk from the old system, so I reformatted and did a clean install, and pulled in my data from the Time Machine with migration assistant. Same issue.

    The Sharing comes on and initially works, but then fails. When it comes on the DHCP leases it gives out at 10.0.2.X as you would expect. After failure they are 169.254.167.X And you cannot even ping the host at all.

    PLEASE FIX THIS, APPLE.
    20" iMa, Mac OS X (10.5.8)
  • ActIIsc2 Level 1 Level 1 (20 points)
    Currently Being Moderated
    Sep 13, 2009 8:12 PM (in response to Ninda)
    Similar problem here. Internet Sharing turned on from my iMac running 10.6.1, which is connected by ethernet to cable modem, and shared through Airport to both my 13"MacBook and my iPhone. The connection works for a while, but then simply stops. Restarting the iMac usually gets things working again.

    But I've also noticed after the fail that the DNS setting for the Airport on the iMac in Network Preferences read: "AirPort has the self-assigned IP address 169.254.104.96 and will not be able to connect to the Internet." Again, restarting seems to bring internet sharing back on, and I can connect to the internet with my MacBook and iPhone again

    But, why the intermittent failures? Worked fine, with no failures under Tiger and Leopard. This problem has only started after the install of SL, and the update 10.6.1 has not fixed the issue.
    20" iMac 2.4GHz, Mac OS X (10.6)
  • Kaiwen Calculating status...
    Currently Being Moderated
    Sep 13, 2009 9:22 PM (in response to Ninda)
    This is definitely a bug since 10.5.8

    I talked with Apple support via e-mail and phone over a week about the problem, hopefully their engineers can get it fixed soon. I told them: "Hopefully this bug won't exist in 10.6", apparently it still exists.
    Macbook Aluminum (Late 2008), Mac OS X (10.6)
  • icerabbit Level 3 Level 3 (765 points)
    Currently Being Moderated
    Sep 14, 2009 9:08 AM (in response to Ninda)
    Same issue here.

    Can't share the Airport internet connection from a Mac Mini 10.6.1 over ethernet to a DP G5 running 10.5.x. No matter what settings I try, auto or anything manual, the G5 doesn't pick up the web. Also seems like the mini drops its internet at the same time.
    G4 450 CUBE + G5 DP 2.5 PM + G4 1.67 PB 15" HiRes + MacBook 2.0 + G3 iMac 333, Mac OS X (10.6), Even if the OS field is outdated, I am always up to date.
  • icerabbit Level 3 Level 3 (765 points)
    Currently Being Moderated
    Sep 14, 2009 9:21 AM (in response to icerabbit)
    Actually ... upon second look it works.

    On the system sharing the internet connection (from Airport to Ethernet), I turned ethernet "off" and saw both the "server" and "client" pull up a page in Safari.

    It seems that the mini was giving preference to the ethernet with manual ip settings from the previous setup at the old house; and thus both systems were polling each other over ethernet.

    So at least if you are sharing internet from AirPort to Ethernet, turning of ethernet in the network preferences may help.
    MM C2D 2.26 + G4 CUBE + G5 PM 2.5 + G4 PB 1.67 HiRes + MB 2.0 + G3 iMac 333, Mac OS X (10.5.2), Even if the OS field is outdated, I am always up to date.
  • 8740ridgeroad Calculating status...
    Currently Being Moderated
    Sep 14, 2009 6:52 PM (in response to icerabbit)
    Icerabbit, you are a genius.

    I haven't been able to share my internet since Snow Leopard and now if I deselect ethernet and firewire and only leave airport selected it is sharing.

    Thank you very much!

    C
    MacBook Pro, Mac OS X (10.6.1)
  • ActIIsc2 Level 1 Level 1 (20 points)
    Currently Being Moderated
    Sep 14, 2009 7:38 PM (in response to Ninda)
    Not sure I follow you on this. I'm trying to share the Internet from my iMac which is connected by ethernet to a cable modem. If I turn off "Ethernet" on this computer, then I don't get an internet connection at all to share! And I certainly can't turn off ethernet on my iPhone.

    So, something about Internet sharing is still causing the connection to drop between my iMac, connected by ethernet to the cable modem, and my iPhone sharing this connection over airport.

    Any other possibilities?

    Thanks!
    20" iMac 2.4GHz, Mac OS X (10.4.10)
  • ActIIsc2 Level 1 Level 1 (20 points)
    Currently Being Moderated
    Sep 17, 2009 4:01 PM (in response to Ninda)
    I've been having the same problems as everyone else here. Trying to share internet connection from my ethernet wired iMac to my MacBook and my iPhone. Tried all the workarounds, but nothing works, or lasts very long.

    Yesterday, I finally talked with AppleCare for over an hour. All their suggestions (trashing preferences, changing settings, etc.) failed, as well. The AppleCare person then put me on hold to speak to an engineer, who told her that Snow Leopard no longer supports Internet Sharing as of 10.6.1.

    Not willing to accept that answer, I had them set up an appointment at the Apple Store Genius Bar for me, and after chatting with the Genius for a while, he also confirmed that Internet Sharing is no longer supported under Snow Leopard. Apparently, there were many hardware issues that the engineers decided to circumvent, and so did not include support for Internet Sharing with the internal airport in Macs. They said that the Airport it is intended to receive, not to send a signals! Yet, it worked fine, doing just that, under Tiger and Leopard! The only fix he could offer was to wipe my drive and take me back to 10.5, which I declined.

    However both the guy at the Genius Bar and the lady at AppleCare inferred that Apple "may" release another update to fix this issue, if they get enough complaints and bug reports.

    So, there you have it. Apple no longer officially supports Internet Sharing in Snow Leopard.
    20" iMac 2.4GHz, Mac OS X (10.6.1)
1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.