Previous 1 2 Next 29 Replies Latest reply: Mar 20, 2010 10:55 AM by jonbirduk Go to original post
  • Level 1 (10 points)

    Please please help!

    I am helping my mum ( in UK ) out installing her new Macbook. She just got the ZTE modem from 3.

    Have done all of the above.


    1. Tried normal way to install the Modem via the Setup assistant.
    2. As it failed I started to google and found you guys.
    3. Followed the instructions from "Nalluri" installing the Telstra Drivers
    4. Ran the 3 Connection Setup. It worked.
    5. Changed the network settings *99# and apn to 3internet + generic + 3G
    6. Tried to connect via the 3 connection.
    7. Got error messeage 100001
    8. Tried to connect via network settings as here described ( didnt see that first )
    9. Nothing works

    We have 10.6.1 - installed the 10.6 disc that came with the package, then upgraded online.

    Any advice?! What should we do now!?

    Thankful for any replies as soon as possible!
  • philg1824 Level 1 (5 points)
    I called the 3comm help line and found them very useful, so that is an option if you cannot find the solution here.
  • Level 1 (10 points)
    So you mean that they could provide a solution for Snow Leopard users? How did they do that?
  • philg1824 Level 1 (5 points)
    Sorry it was not 3 comm is was the mobile network 3. In my case with a different modem, huawai, they explained that I needed Rosetta installed and that I needed a particular advanced setting
  • Level 1 (10 points)
    Ok! Understood. Did you try this on Snow Leopard? ( what version ) or only on version 10.4.6 as it says you have?

    ( we also installed rosetta, altough i dont know exactly what configurations you mean in the advanced settings, is it maybe something you could post? )

    thank you very much.. it would be wonderful if this could work.. i am in sweden.. and she is in uk.. so it has to be done from a distance.. tricky.. but not impossible.. ( i hope )
  • philg1824 Level 1 (5 points)
    yes, it is the latest version of Snow Leopard (have just updated my details). The advanced setting was to ignore dial tone for the Huawiai modem. However for yours, (which I also use), it is wait for dial tone. Good luck Phil
  • philg1824 Level 1 (5 points)
    model is other, modem is 3 connect setup script (from the drop down box) in advanced (or similar)
  • Level 1 (10 points)

    Problem now solved.

    Action taken.

    1. Erase both installed options, as described in this thread
    2. install the Telstrapackage
    3. Run setup assistant ( works )
    4. change only the number to *99# in preferences on the 3Connect modem
    5. Press connect button in the 3connect application

    Works! internet connection established. Not a very fast one, but it sure works.

    Thanks all!
  • humblenick Level 1 (0 points)
    nice one, thanks everyone for the fix
  • wkeenan Level 1 (0 points)
    The 3 ZTE MF627 now has supported Snow Leopard drivers, donwload and install the link at the bottom of:

    Check ther for inof, direct link:

    I uninstall the existing 3connect software (maybe optional step), installed the above driver and then installed the 3ConnectZTEMF627_Mac_r66Installer from the downloads site and have a working dongle.
  • gambit110011 Level 1 (0 points)
    Hey guys. I have a ZTE MF626 , and it seems to work well on my mac (lets me navigate). The thing is that it doesn't let me stay online in MSN, or talk in Skype, which is pretty weird. I didn't have this problem before snow leopard. Does anyone have an idea of what's happening ?
    This doesn't happen when I'm using the internet of my school.
  • maattyddd Level 1 (0 points)
    This dosen't work for me it just can't find the device when trying to install. Am I missing something?
  • bjmundey Level 1 (0 points)
    HELP !

    I tried the above info, downloaded & installed the Telstra driver package but still no good, getting the same error "could not detect device".

    Also could not connect through network preferences as when trying to set up an new connection, the ZTE usb modem is not apprearing anywhere as an available interface option (or any phone modem for that matter)

    Any ideas anyone? please help!

    So frustrating, I have spent hours trying to get this working and I just want it sorted!
  • Imol Level 1 (0 points)

    some advise please!

    do you know if the ZTE MF636 will work on snow leopard (10.6.2)?
    I still don't understand what has to be installed and how.
    Is there a specific driver that has to be installed for SL? Is this how OS X recognize the stick as a modem?
    Then there should be a "connection manager" or some sort of app to get connected to Movistar mobile Internet? Is this app mandatory or I can connect using network preferences for dialing?
    Any help will be much appreciated.
    Thanks a lot.

    by the way my carrier is Movistar Argentina.

  • jonbirduk Level 1 (0 points)
    ZTE MF627 not found. OS - Snow Leopard upgrade.

    Try link to 'old' 3Connect Manager Software:-

    (My thanks to fearoffish)

    Modem device now found and connects successfully.
    (No thanks to 3).
Previous 1 2 Next