13 Replies Latest reply: Oct 18, 2009 1:14 PM by Erick@Basel
Alienworkshopper Level 1 Level 1 (0 points)
So I have starcraft installed on my mac, it installed very easily.

I insert the Broodwar disc, the expansion.. Nothing happens when you put the disc in so I have to open the disc. There are 4 options - Brood War Installer, B W Archive, an ISP folder which has "Mind Spring" in it, and a Preview icon.

So I tried clicking them all, the Installer first of course. Nothing works, I just get the message, "You can't open the application "Brood War Installer" because the CLassic environment is no longer supported."

Anyone know what's up?
  • Kurt Lang Level 7 Level 7 (34,590 points)
    It means that those programs which will not run require OS 9 (Classic). Since Classic is dead in Leopard (and Snow Leopard), they will not run.

    About all you can do, if your Mac can run Tiger, 10.4, is to create a separate partition, or set up an external drive to install Tiger onto. Since Tiger supports Classic, you would be able to run your games while booted to that drive.
  • Alienworkshopper Level 1 Level 1 (0 points)
    why would the original start craft install without issues, it's an older game?
  • Kurt Lang Level 7 Level 7 (34,590 points)
    If it's older, I doubt it. Check the requirements on the box. If it says OS 9 or earlier as the required OS, then it won't work in Leopard as it would need Classic to run.
  • Alienworkshopper Level 1 Level 1 (0 points)
    it has to be older. Brood war is the second starcraft game. Starcraft original installs without any issue and in just a few seconds.

    System Requirements for both games are - Mac OS 7.6 or higher, 16MB RAM, 105 MB Available Hard Drive space.


    I found this page http://www.apple.com/downloads/macosx/games/demos_updates/starcraftbroodwar.html

    I tried using the Mac OS X native installer 1.1 on that page but it said "Failed to mount".
  • Kurt Lang Level 7 Level 7 (34,590 points)
    System Requirements for both games are - Mac OS 7.6 or higher.


    Then you'll never get them to work in Leopard as they would require Classic. Your only option is to set up another drive with OS 10.4.x on it, which does support Classic and play those games there. This if your Mac is a G5 or older. Any Intel based Mac will not work at all no matter what you do.
  • Alienworkshopper Level 1 Level 1 (0 points)
    hahaha

    I'm lost. One of them DOES work. It works right now. It is running on this very computer as I type this. The second one (The expansion: Brood War) does not, yet they both have the same requirements.

    Furthering my question - Why would a more advanced operating system not be able to run a simple game from 1998. I hate computers. I'm computer illiterate I don't know what setting up a second drive means.
  • keats2010 Level 2 Level 2 (285 points)
    It would really help if you added your computer profile, ie the make, the system your running, etc.

    Cheers
  • biovizier Level 5 Level 5 (7,925 points)
    It could be that the software you mention are "fat binaries" that will run both in OS X and the old Mac OS, but use an installer restricted to the old Mac OS. With Snow Leopard, users are experiencing similar issues with some native-Intel software requiring PPC code running under Rosetta to be installed.

    ..."I tried using the Mac OS X native installer 1.1 on that page but it said "Failed to mount"."...

    What failed to mount? If it was the volume on the dmg containing the OS X native installer, try downloading it again -- perhaps it got corrupted. If the company was good enough to provide a native OS X installer, that will likely be the easiest way to get around the issue...
  • Erich Meatleg Level 2 Level 2 (170 points)
    you need this to install:
    http://us.blizzard.com/support/article.xml?locale=en_US&articleId=21149
    (make sure to click on the Mac Os X version not the windows version)

    however, i just realized that even though my Starcraft will boot up, and I can hear it, the screen is blank. I cant see anything so I cant play it in Snow Leopard....
    bummer...
  • Mac_Info Level 1 Level 1 (5 points)
    I had been using Eudora 4.2 (no smart-butt comments, please) quite well in 10.5, and it WAS running in 10.6, until a couple days ago, now "the Classic envoronment is no longer supported." 'Sup wit dat?

    Oh, it gets better - I booted off an external 10.4... Says "Classic not Supported" too!

    So evidently, something happened with Rosetta settings, or, the Eudora App suddenly decided not to work... What do you think?
  • Kurt Lang Level 7 Level 7 (34,590 points)
    The error message doesn't make sense at all if it was running in 10.6. Classic is OS 9 run within OS X (on PPC hardware, G5 or earlier) and has nothing to do with OS X directly.

    That it's doing the same thing in 10.4 suggests either the application is damaged, or it could just be a bad .plist preference file. Try creating a new account and running Eudora from there. If it launches, then something in your normal account is damaged. Most likely the preference file. If you get the message about Classic even in a new account, then remove and then reinstall Eudora.

    Eudora's web site also has this note:

    Notice to OS X 10.5 'Leopard' users:

    In order for Macintosh Eudora to work well under OS X 10.5.x 'Leopard', you need to turn off the use of specific sounds in Eudora. These are the sounds Eudora plays when you get new mail or Eudora needs your attention, or are played by Filters. The sounds that are problematic are the ones that contain 'Eudora' in their name as they were created using a sound synthesizer that Leopard does not support. To disable or change the sounds used in Eudora, do the following:

    Turn off or change the 'New Mail' and "Attention" sounds:

    Open Eudora->Preferences and select the 'Getting Attention' panel
    In the 'Sounds' section, for both 'New mail sound' and 'Attention sound', select a sound OTHER than one that has 'Eudora' in its name (ie. NOT 'Eudora Attention', 'Eudora New Mail' nor 'Eudora Short Warning')
    Click OK to the close the Preferences
    Turn off sounds triggered by filters:

    Open Window->Filters
    Look through all your filters for filters that have a 'Play Sound' action.
    Select a sound that does NOT have 'Eudora' in its name, or disable sounds all together by selecting 'None' from the action popup menu.
  • Erich Meatleg Level 2 Level 2 (170 points)
    I found that if I hit Command M and take teh game out of full screen, then I can see everything. after I hit command M again, I can see everything fine.

    Then i connected to battlenet, and I downloaded the new patch.
    Now starcraft boots up as normal....
  • Erick@Basel Level 1 Level 1 (0 points)
    I know its been a while since this question was posted, but if there is still no answer, you may want to download the Starcraft installer (available in the Blizzard webpage) - I had exactly the same error, in my case also with the original Starcraft, and I was able to install without any problem. The installer can be found in this link:

    http://us.blizzard.com/support/article.xml?locale=en_US&articleId=20891&parentCa tegoryId&pageNumber=1&categoryId=2641

    Cheers and battle on...