Previous 1 2 Next 28 Replies Latest reply: Jan 2, 2010 11:04 AM by CJ Crucke
Rene Schmidt Level 2 (375 points)
I just got a new HP Photosmart Premium c309a to replace another HP printer that died. Luckily, most things work, but a few don't. I am connect via an ethernet cable to a time capsule 1gb (2009 model).

Things that I can't get to work;

1. The scan button on the printer, won't scan to the computer. I get an error message "Scan Problem".
2. I can seem to get it to print using the preset "print from photo tray". It still prints using the main tray. I was printing using the address book, and had envelopes in the top tray.

Any suggestion?

fyi - I tried printing via Bluetooth, and I get the same results.

iMac 2.8/Powerbook/a couple of iPods, Mac OS X (10.5.1)
  • Rickmeister Level 1 (10 points)
    Hi Rene

    the new scan interface software in Snow Leopard for the HP All-in-Ones does not support button pushing from the device itself. I believe this is noted in the HP support document found at this URL. Remember this is the first version of the scan software &jumpid=regR1002USEN

    (Although I am an HP employee, I am speaking for myself and not for HP)
  • Rene Schmidt Level 2 (375 points)
    Thank you , that was useful information. I'm hoping that the buttons will be enabled in a future release of the HP software.

    I also discovered that the card readers in the printer aren't able to be "seen" from my computer.
  • buffyr Level 1 (0 points)
    I also am having problems scanning to this HP device. I understand that the buttons may not work (although I don't understand why...) but it isn't working from the desktop, either. As soon as I open ScanPro I get a message that the scanner is not found. I have found an on-line work around, but this is a pain.
  • Rene Schmidt Level 2 (375 points)
    Have you tried scanning from Preview, or from the Printing Preference pane? Both these work for me (yes, none of the bundled HP software works).
  • Joseph Kriz Level 5 (5,090 points)

    I have a different all-in-one HP but mine is also hooked up via ethernet to a Time Capsule.
    It does print.

    My card reader does not work through ethernet...
    However, if I plug the printer into the computer with a USB cable, the card readers are automatically mounted on the desktop.

    Works for me until HP hopefully comes out with newer drivers for our printers.

    Give it a try if you have a USB cable laying around.
    You will have to add a new printer as this one will be connected via USB. Or, actually, mine was added automatically as soon as I hooked up the USB cable. I didn't have to do anything.
  • HP Mac Architect Level 3 (530 points)
    I'll be back in a little bit, but a quick how to, for networked devices under Snow Leopard, you can mount the card by using the "Connect to Server..." command under the Go menu in the finder, and typing smb://ip.address.of.printer (obviously replace the real IP address of your printer in that string.

    Just trying to help.


    PS, I need to add this to the FAQ too.
  • Joseph Kriz Level 5 (5,090 points)
    Thanks Andrew,

    That did work.
    A little slow to view the photos but it definitely does work.

    Very helpful and thanks again.
  • HP Mac Architect Level 3 (530 points)
    Just to be clear, button support will be enable for your device when the full software solution for Snow Leopard is released. For the Photosmart Premium c309a, while I won't commit to a timeline, I don't think you'll have to wait much more then a week or so (and maybe even sooner).

    Just trying to help.

  • Rene Schmidt Level 2 (375 points)
    I was unable to mount smb://10.01.2

    I can open the page so I know that the printer is connected correctly.

    I have my firewall turned off on my mac.

    I can't think of what else to check.
  • Rene Schmidt Level 2 (375 points)
    I got this to work;


    And then it prompted me for a username/password . I just entered connect (without entering a password), and it mounted.

    hmmmm...Why would the IP address not work?

    Not so intuitive.
  • medicro Level 1 (0 points)
    Andrew - I got an HP C8180 the other day.
    Although I could print wirelessly - no scanner/lightscribe device was found.
    As others say - the buttons to scan to computer don't work either.

    I was using Leopard.
    I upgraded to Snow Leopard hoping that would sort any problems - but I have the same problems still.
    I can print wirelessly - but the other functions won't work.

    I read a solution telling me to uninstall using the HP uninstaller - reboot -
    and this time add the printer manually.
    The solution said I would be informed that Apple had new software for this printer - and should accept that.
    All went swimmingly until I tried accept the download and install command from Apple.
    It tried to find the software - then I was told the software was 'currently unavailable'.

    Have you any insight into this?
    Does it mean Apple are re-writing their software to accommodate this device?

    I don't mind waiting a few days in the meantime - but I would return the item if it were going to take some weeks to come up with the drivers.

    Thank you
  • medicro Level 1 (0 points)
    Andrew -

    I should have read your HP FAQ post first. Doh!

    I have downloaded and installed the drivers from the link you posted -
    and at least I can scan from my computer now.

    I cannot seem to select printing from the photo paper tray yet -
    but I will keep trying in the meantime.

    I'm not quite sure how to get the OCR function at the moment.
    I chose a text scan - but must have chosen the PDF format as it won't let me edit.

    The button on the touch panel remains disabled for the present.

    Will the HP functionality software eventually work on Snow Leopard?
    I mean the device manager, scan devise etc?

    I haven't tried Light-scribe yet - but I'm more hopeful than I've been in the past few days.

    It seems like a lovely AIO - I just wish I could get it all up and running.

    Thank you again.
  • Susca Level 1 (0 points)
    I'm a brand new user to MAC and I just installed the new operating system, Snow Leopard. My printer is HP Photosmart c309a and unfortunately I installed the printer driver, etc. from that printer after I installed this new operating system. Now I understand I should not have done this. Help! How do I uninstall? The printer works, but the scanner (button or from computer) does not. Thanks so much. Susan
  • HP Mac Architect Level 3 (530 points)

    We will have a full solution for your 8180, including LightScribe support, available soon. We are working as hard as we can to get full solutions for everything posted. They should start showing up this week, but with the added complexity of the 8180 the full solution may be a week or so later. But we are working on it.

    Just trying to inform.

Previous 1 2 Next