Previous 1 2 3 Next 37 Replies Latest reply: Feb 23, 2010 3:19 AM by jamiana
TestPilot Level 1 Level 1 (0 points)
I upgraded to Snow Leopard a few days ago. Since then, when copying files to the Shared Documents folder on my laptop running Windows XP and connected to the same router as my iMac, I get the following error message:

"The Finder can’t complete the operation because some data in “<file name>” can’t be read or written. (Error code -36)"

This error message wasn't seen with OS X 10.5.8 and earlier.

The files do show up on my Windows laptop and appear to be complete, but the error message is very annoying, since I have to open each of the transferred files to be sure they were correctly copied. I this just one of the bugs in the new OS or is there something else wrong?

iMac, Mac OS X (10.6)
  • GFNG Level 1 Level 1 (0 points)
    I have the same problem, but only with my NAS (Network attached Storage). But it work great with the shared folder in windows Vista... Now I have two macs isolated from their files in the NAS. I can not even open DOCs or Excel files.
  • Carolyn Samit Level 10 Level 10 (95,950 points)
    HI,

    Try repairing disk permissions.

    Quit any open applications. Launch Disk Utility (Applications/Utilities).

    Select MacintoshHD 10.x.x in the panel on the left, select the First Aid tab.

    Click: Repair Disk Permissions

    Quit Disk Utility when it's finished and restart your Mac.








    Carolyn
  • TestPilot Level 1 Level 1 (0 points)
    Carolyn,

    Thanks for the advice. I repaired the disk permissions as suggested and restarted, but get the same error message. As stated in my first post, the files are copied correctly despite the message, so the message is mostly a huge PITA.

    Karl
  • thomas_r. Level 7 Level 7 (29,760 points)
    I'm not sure why she even suggested that, since you're copying files to a Windows machine, and thus the permissions on your Mac aren't very relevant, and repairing permissions won't do anything with the permissions on your documents anyway. That was a pretty silly suggestion, IMHO.

    A -36 error is an IO error, which in my experience is often associated with hard drive damage. My first suggestion would be to repair your Mac's hard drive using Disk Utility. (If it's the boot drive, you have to reboot from the install disk to repair... try verifying first to see if that's necessary.) For the Windows machine, I'm not sure what you do, but you should check the drive there too.

    If both drives pass with flying colors, it's probably some kind of networking issue. You'll probably want to post over on the [networking forum|http://discussions.apple.com/forum.jspa?forumID=1343] to get better answers in that case.
  • herveyw Level 1 Level 1 (10 points)
    I too started getting this error copying files to a Windows 2008 Server after upgrade to Snow Leopard - everything was fine with Leopard 10.5.x. Most frustratingly, the copy is fine if you use terminal:

    cp -R <fileorfolder> /Volumes/<share>/<fileorfolder>

    which suggests, at least to me, that this is a Finder problem, not something more fundamental.
  • TestPilot Level 1 Level 1 (0 points)
    I ran Verify Disk and got an OK. In looking over the topics on this forum, I'm inclined to believe there are several related problems with the Finder. Hopefully 10.6.1 is not too far in the future.
  • GFNG Level 1 Level 1 (0 points)
    I found a work around to part of this problem. I am connecting to the NAS/SMB through FTP client Filezilla. now I can transfer files to and from the NAS.

    The only annoyance is that I can not work the files directly from the Network Attached Storage, but I have to transfer it to my mac, work and transfer back. Very inconvenient for Docs and Excel spread sheets. I hope Apple is working to fix the Finder.
  • TestPilot Level 1 Level 1 (0 points)
    Here's an update to my problem. When transferring files through the router's LAN from my iMac to my PC laptop, in addition to the -36 error code, the unix files that are normally created, such as .DSStore and ._<file name>, do not show up on my PC. File transfer from the PC to the iMac, however, seems unaffected (no error codes, files check good).

    Before I started using the LAN connection through my router, I would transfer files back and forth between the 2 computers using a USB flash drive. This process still works as before, and the unix files are displayed on the PC.

    And finally, and this may be unrelated, I have Show icons, Show icon preview, and Show preview column all selected under Finder > View > Show View Options. Icons are displayed and the Preview column functions properly, but only PowerPoint files display the correct icon preview.
  • TestPilot Level 1 Level 1 (0 points)
    I took Thomas Reed's advice and checked the Networking forum. I found several similar posts, so I'm going to continue my search for a solution there.
  • herveyw Level 1 Level 1 (10 points)
    I'm not convinced this is a networking problem as neither cp nor PathFinder have this issue. However I'm not inclined to spend $40 on PathFinder to fix a $30 OS upgrade; instead I'm hoping for 10.6.1 soon.
  • Luke Carbis Level 1 Level 1 (0 points)
    I have the same problem. Here are the details:

    External Hard Drive with LAN (Buffalo Drivestation Flexnet: http://tinyurl.com/kk5mmu)
    Mac OS X 10.6, on 3 different Mac Mini's

    This error occurs on all computers when trying to copy a file to the 'SHARE' sharepoint on the SMB Drive:
    "The Finder can't complete the operation because some data in "filename" can't be read or written. (Error Code -36)"

    I CAN
    Access / Read / Write this Drive in Windows XP
    Access / Read / Write this Drive in OS X 10.5.7
    Make new folder on this Drive in OS X 10.6
    See a .DS_Store file which 10.6 has written to the Drive
    Save a document to the drive from the Text Edit save dialog in 10.6
    Save a document to the drive from the Pages save dialog in 10.6
    Duplicate a document on the drive using Terminal (cp Untitled.pages Untitled2.pages) in 10.6
    Copy anything to any other computer on the Network using 10.6

    I CAN NOT
    Copy a document to the Drive in 10.6
    Duplicate a document on the Drive in 10.6
    Save a PDF or JPG to the drive from the Preview save dialog in 10.6

    This error happens every time. It is easily reproducible.

    I hope that this information helps Apple get on to the problem soon.
  • GeneralLeeOfOV Level 1 Level 1 (0 points)
    I too am seeing this behavior with 10.6 and 10.6.1

    In my environment, we have a mix of Windows Server 2008 and 2003 R2 file servers on a Windows Domain.

    When I try to copy one file up to either of the servers I get the error: "The Finder can’t complete the operation because some data in “<file name>” can’t be read or written. (Error code -36)"; however, the file does copy over. If I try to copy multiple files to the share(s), only one file will copy over and the rest just get discarded.

    If I copy files over via cp from the CLI then everything copies over without issue.

    I too have confirmed that this behavior does not happen with any of the 10.5.8 machines on our domain...definitely looks like some kind of finder bug.

    I did see something in my system log that kinda stood out to me:

    fseventsd[42] getting the group list for userid/id number failed (Unknown error: 0)

    To me it appears that directory services is not properly processing my group id and that may be causing some of the issue. This is just a theory that I have, but I'd figure I'd throw it out there.
  • Jonas Nygren Level 1 Level 1 (0 points)
    I have problems with my Time Capsule, TC, so thought I should make separate copy of Music and Pictures to a Maxtor connected to the TC.

    When I tried to copy Pictures I got -36 error after some minor parts had been copied. Though copying Music seems to go OK so far. Seems the problem must be related to the file on my MPB disk?

    What can be done?
  • SteveOnHisMac Level 1 Level 1 (0 points)
    Hi everyone...
    Just thought I'd add to the discussion. Having exactly the same issue within an AD environment. (Windows corporate network) files copy fine but throws up an error -36. This makes copying multiple files impossible as the first file errors and stops the rest copying.

    I'm absolutely convinced this is a finder issue for two reasons:
    1. like many of you, I had the same shares working in 10.5.8 no problems
    2. I can save and transfer multiple files with no error from all applications (Adobe CS4 for example)

    Strangly I reinstalled 10.6 with a fresh install and it worked for the first day. I may try it again and slowly reinstall all my software in case there's some sort of conflict. I'll let you know how that goes.

    Hopefully we have a solution soon.
Previous 1 2 3 Next