Previous 1 2 3 Next 36 Replies Latest reply: Mar 21, 2013 11:09 AM by HornBlowR
Viztang Level 1 Level 1 (0 points)
Hi all,
I have been suffering from mdworker32 taking up to 97% of the CPU. This lead to a mechanical failure of HD days ago and apple replaced one for me. However, the phenomenon still exits.

Details: MBPro late 2008 unibody 2.4G 4G and 320 HD
After upgrade to SL, the system keeps running at a high fan status. Roughly around 4000, and one process, mdworker32 keeps taking 97% of the CPU (20% of total) power.
I removed all importers from /Library/Spotlight but this didn't help.

An inspection in console suggesting the mdworker32 keeps throw exit code 75? (Anyone know what this means?)


Thanks much,
Sean

Macbook Pro, Mac OS X (10.6), 2.4G/4G/320
  • Viztang Level 1 Level 1 (0 points)
    9/6/09 12:10:47 PM com.apple.launchd[1] (0x10041fda0.mach_init.mdworker32[164]) Exited with exit code: 75
    9/6/09 12:15:52 PM com.apple.launchd[1] (0x10041fda0.mach_init.mdworker32[181]) Exited with exit code: 75
    9/6/09 12:19:57 PM com.apple.launchd[1] (0x10041fda0.mach_init.mdworker32[212]) Exited with exit code: 75
    9/6/09 12:25:02 PM com.apple.launchd[1] (0x10041fda0.mach_init.mdworker32[217]) Exited with exit code: 75
    9/6/09 12:29:07 PM com.apple.launchd[1] (0x10041fda0.mach_init.mdworker32[226]) Exited with exit code: 75
    9/6/09 12:34:13 PM com.apple.launchd[1] (0x10041fda0.mach_init.mdworker32[231]) Exited with exit code: 75
    9/6/09 12:51:36 PM com.apple.launchd[1] (0x10041fda0.mach_init.mdworker32[241]) Exited with exit code: 75
    9/6/09 12:57:38 PM com.apple.launchd[1] (0x10041fda0.mach_init.mdworker32[258]) Exited with exit code: 75
  • Pondini Level 8 Level 8 (38,720 points)
    Viztang wrote:
    Hi all,
    I have been suffering from mdworker32 taking up to 97% of the CPU. This lead to a mechanical failure of HD days ago and apple replaced one for me. However, the phenomenon still exits.

    Details: MBPro late 2008 unibody 2.4G 4G and 320 HD
    After upgrade to SL, the system keeps running at a high fan status. Roughly around 4000, and one process, mdworker32 keeps taking 97% of the CPU (20% of total) power.
    I removed all importers from /Library/Spotlight but this didn't help.


    Not a good idea. It won't ever run right without them.

    Exclude your internal HD (and any externals) from Spotlight indexing via System Preferences > Spotlight > Privacy. That should stop it, but won't fix it.

    Post back with the results, and also what, if any, other disks/partitions are attached, whether you have any disk images/sparse bundles, and whether you're using File Vault.
  • Viztang Level 1 Level 1 (0 points)
    The ultimate solution for me now is to exclude the Microsoft Office 2008. This app will confuse mdworker32 and keep the mac running hot. I re-Imaged mbp with SL and didn't install the office suite but everything else, it runs great.

    Hope there will be a work around or M$ will update the application. I do need it to write a paper though....aggrrrh
  • OverPowerFred Level 1 Level 1 (0 points)
    Hi,

    I have been contacting Apple Support to solve this issue and it seems it is solved so far. The issue is linked to Spotlight and MSOffice 2008. Even after uninstalling MSOffice, the issue wasn't solved until the file +Microsoft Office.mdimporter+ has been manually removed from Macintosh>Library>Spotlight>+Microsoft Office.mdimporter+. Check if you also have something similar in Username>Library>Spotlight>. Once you have done that, you can index you HD with SL without having problems with mdworker32.
    Remember that if you reinstall MSOffice, you will probably need remove those files once more to prevent the problem to reappear.
  • paranous Level 1 Level 1 (0 points)
    Hi,

    I don't think this problem has been resolved. At least, I don't seem to have the MicrosoftOffice.mdimporter file on my computer and the mdworker32 process still hogs CPU and I don't know how to fix it. I have the most recent version of Mac OS (10.6.2).

    Are there any other suggestions?
  • Martin Garmendia Level 1 Level 1 (0 points)
    This seems to be a mdimporters problem. To see which mdimporter is causing the problem go to +Activity Monitor+, double click mdworker32 and select +Open files and ports+ tab. You can see there which mdimporters are used, so you can go to their respective folders and rename or delete them.
  • panos_tsapralis Level 1 Level 1 (10 points)
    I have been having the same problem and the only way I found so far to deal with it was to exclude my entire internal hard disk drive from the SL indexing process by going to System Preferences -> Spotlight -> Privacy and adding that drive to the list. CPU load has gone back to normal ever since - however, I don't know what are the deeper implications of this configuration.
  • FrequentFlyer Level 1 Level 1 (5 points)
    I've had this problem on my Intel quad core PowerMac ever since I installed the update to Office 2008 a few days ago. Sometimes I wonder if Microsoft intentionally cripples their Apple software to make their platform seem more desirable.

    I'm going to remove Office 2008 and reinstall the original programs.
  • panos_tsapralis Level 1 Level 1 (10 points)
    I am not completely sure that Microsoft Office 2008 or any of its update causes this behavior I wouldn't be surprised if it did, though...). A little bit of experiment wouldn't hurt, however - so, let us know what happens when you uninstall MS Office 2008 or its latest update. I am thinking of doing something similar: now, that I have upgraded to Snow Leopard, I am planning to switch to OPENOFFICE.ORG or NEOOFFICE and replace Microsoft Entourage 2008 with MAC OS X Mail.

    Panos.
  • FrequentFlyer Level 1 Level 1 (5 points)
    I removed Office 2008 and the problem persists.
  • txrpls Level 1 Level 1 (0 points)
    Booting in 64 bit mode seems to solve this problem.
  • panos_tsapralis Level 1 Level 1 (10 points)
    What does "booting in 64 bit mode" mean? How do I do it? When I bought my latest MBP (with Snow Leopard) I restored my old contents from an up-to-date Time Machine backup - can I use 64 bit mode now? What are the implications, if any?

    TIA,
  • Marek Stepanek Level 2 Level 2 (290 points)
    Hello all!

    I have had also a problem with this indexing, when I was connecting to an external HD. How can Apple conceive such a thing, indexing foreign Documents? I thought this is Google or Microsoft style!

    I never work with spotlight; and I don't like to be treated as child from my OS. So I only use in my Shell commands like: % locate find grep

    This is largely sufficient. To switch of the indexing of spotlight on SnowLeopard, make the following command in your shell:

    % sudo mdutil -a -i off (without the % off course! If you want to switch it on, you simply put a "on" to the end of this command. Obvious!)

    If you need information about this command:

    % man mdutil

    And to remove the index-files, go to your root-folder:

    % cd /

    and remove the following folder with:

    % sudo rm -rf .Spotlight*

    *Don't remember the exact name of this folder again ... But with the "*" at the end, this command is working too


    marek
  • mishichan Level 1 Level 1 (0 points)
    I've deleted stuffit and problem has gone.
Previous 1 2 3 Next