Previous 1 6 7 8 9 10 Next 272 Replies Latest reply: May 1, 2013 6:55 AM by Chris McCord Go to original post
  • LostAccount Level 1 (110 points)
    I think you are right to suspect the enclosure…I mean in your case that solved it. I am not surprised that it was the enclosure, however, I found it interesting that you were able to erase the drive using Windows.

    Could you let us know if after erasing the drive in Windows you could see the volume as mounted on your desktop.

    This is the second drive I have by a 'reputable' manufacturer die on me and I suspect the enclose and not the drive.

    Thanks for the information.

    For what it's worth I did find this article,

    You can find the article above if you google search, Recover a dead hard drive using dd.

    Take care and thanks for chiming back.
  • Tommaty Level 1 (0 points)
    I have absolutely the same problems as everyone in this threat. The Apple reps in Holland seem to think that the HD MUST be broke and that I am a total lunatic for even doubting the Snow Leopard system.

    It is a Maxtor 360GB disk and it only mounts for 10 minutes, does not transfer any files and creates problems wiith other USB devices if connected to Mac.

    Come on very wise Apple tech guys!!!
  • DJ Droogie Level 1 (0 points)

    This has worked so far.

    Copied >4 GB of data to my Western Digital 120 GB external HDD with no hiccups thus far.

    Great thought on using diskutil.

    Too bad I went through every previous solution suggestion in this threat prior to attempting your fix.


    Update: I spoke too soon, I received Error Code -36 after copying over about 8 GB of data.

    Message was edited by: DJ Droogie
  • jlorre Level 1 (0 points)
    I thought the original thread was about impeccable USB disks that could not be formatted/partioned in snowleopard.

    to DJ Droogie: But if one doubts the integrity of a disk, offcourse that integrity should be prooved or repaired first. Copying upto a certain point and then choking on it is typical for disks that have developed bad sectors (unless you have a cable with a bad contact). I once had a bad sector in a OSX-file containing a parallels 160 GB diskimage. For checking AND repairing such disks that have developed bad sectors i have good experience with the speedtools utilities from intech. In my case it could repair issues that diskUtility or SMART tools could not. I have no affiliation with them whatsoever, and it's not free, but I think it could be useful to repair or at least check your disk.
  • eagleVshark Level 1 (0 points)
    I thought that I was having this same issue too, but mine might have been a bit different. My partitions worked when booted up on startup dvd, and on older Mac, but not in regular boot up in SL.

    I found out that when my previous external drive died, it caused Time Machine to throw an error which somehow created a locked folder in /Volumes called "Disk Image". It was somehow creating a situation where I could not mount anything (story of my life

    Here is what I did:

    $sudo bash
    $chflags nouchg Volumes
    $chflags nouchg Volumes/Disk\ Image
    $rm -r Volumes/Disk\ Image

    Then used Disk Utility to fix perms and Voila. Only some minor hair loss.

    Hopefully this will help somebody else.
  • GouverMXT Level 1 (0 points)
    Same problem here. I just tried everything in this topic (except a firewire enclosure and formatting with old Mac version), and nothing works. And using Windows or Linux disk tools I can't do any change to the disk, but extrangely in this operating systems the disk was mounted and i can view the files, in MacOS I can't browse the disk. What's hapenning? It looks like the disk is ok, but it is completely unuseless, this is the first serious bug I saw in MacOS, unfortunately... What do Apple can do for us?
  • jlorre Level 1 (0 points)
    At least Apple seems to be aware of the issue: I formally reported this problem to apple via, also referring them to this discussion, and got the following reply on 24 feb 2010:
    "This is a follow up to Bug ID# 7606457. After further investigation it has been determined that this is a known issue, which is currently being investigated by engineering. This issue has been filed in our bug database under the original Bug ID# 7564967."
    I suppose that's worth knowing to the contributors to this thread.
  • k258 Level 1 (0 points)
    My iomega Prestige 1T drive became corrupted soon after I upgraded to SL. I suddenly got an error message saying there was no space on the drive (there actually was 500 gigs available) and froze my system completely. I couldn't even shut down my Mac until I cut the power to the drive. Disk Utility now says it can't repair it and I get the same POSIX error when I try to reformat it. File recovery software gets stuck on the first block when I try to scan it. I want to preserve the files that are on the disk, so I don't want to completely erase the drive.

    At this point, I'm thinking I should hold tight and wait for Apple to fix the reformatting problem. If I find a machine on Tiger, reformat the drive and recover data, do you think I can safely use the drive? Or is it likely to go wacky again?
  • Vedat Level 1 (0 points)
    I've had this problem on my Imac ever since moving to SL. I lost 1 of 3 partitions on my 1TB Seagate Freeagent shortly after enabling Time Machine on it. I could recover the files only by extracting the HD from the case and attaching a USB adapter. (I could only save 2 of the partitions for some reason)
    I thought it was the drive that failed. But then I put the drive back together, and used it for a while for extra space. Today, I went ahead and enabled Time Machine on it...What do you know. It is acting up again.
    Time Machine could not backup to it. I can't initialize it. Now I cant even copy the files on it to another disk.

    I am also getting Kernel Panics trying to use Carbon Copy Cloner on my Lacie USB drive.
    I am at a loss not being able to back up sensibly.

    Message was edited by: Vedat
  • jlorre Level 1 (0 points)
    If you're stuck like that, and you suppose the problem is not the disk but what's on it, then my suggestion is to go to the website of the disk-manufactor, and download their low-level formatting-and-checking utility for the disktype you have. All respected diskmanufacturers have a tool like this.
    The tool might be dos-based or windows-based and often the disk has to be mounted directly on IDE or SATA (not in an external USB box) to avoid middleware but i'm sure you can find temporary PC-hardware for this job. Once the disk is low-level wiped and proven-good by the disk manufactors' own tool then you can start from a known clean state and have a better chance to initialise it on SL without entanglements from the past on the disk.
  • Vedat Level 1 (0 points)
    With all due respect to your reply, if I had to go to a PC to make something work on my Mac, it spells doomsday I reckon. :))
  • Urabutln Level 1 (0 points)
    I have the same problem - with a Corsair Survivor 32GB USB memory stick, so I'm going to be hard pressed to connect it via firewire.

    It works fine in Windows 7 and XP, and I've formatted it using every file system there is, using every format utility and partition manager on the planet. Still no dice in OSX SL. I might mention that according to Disk Utility, the Corsair is 33.55 GB large (rather than either 32 or 29.xx), and has no partition map scheme. It will not be formatted under any circumstances, it goes POSIX every time.

    Also, the stick won't work in my PS3, which I find odd...
  • William Kucharski Level 6 (14,965 points)
    Vedat wrote:
    With all due respect to your reply, if I had to go to a PC to make something work on my Mac, it spells doomsday I reckon. :))

    The problem is many drive manufacturers only make their low-level drive tools available in Windows or even DOS versions.
  • Gazzaman Level 1 (0 points)
    Wow, 6 months since the original post and still no solution. Nice one Apple, that's a hallmark of a company trying to do its best for the customer.
    I still have a bricked ext HDD.
  • Allan Eckert Level 8 (49,710 points)
    Hi Gazzaman;

    You are not talking to Apple here only other users like yourself. If you wish to send this problem to Apple you should have used the feedback link instead.

Previous 1 6 7 8 9 10 Next