Skip navigation

External HD Problem in Snow Leopard

221788 Views 272 Replies Latest reply: May 1, 2013 6:55 AM by Chris McCord RSS
  • eagleVshark Calculating status...
    Currently Being Moderated
    Mar 10, 2010 3:11 PM (in response to Allan Eckert)
    Their feedback link has more issues than time machine, and they don't reply with dancing animals in their signature line

    I'm finally at the point where I have to ask myself what makes me angrier:

    • Fiddling around with my $1500 laptop for hours on end trying to do a seemingly simple task

    • Cursing for a few hours once I realize that my data wasn't backed up (couldn't be backed up rather) losing some really important file I'll never get back.

    Option two is faster.

    My current list of technological gripes:

    • Internet Explorer 6

    • Snow Leopard

    That's bad.
    Whizbang!, Mac OS X (10.6.2), MacBook Pro
  • paulausoleil Calculating status...
    Currently Being Moderated
    Mar 10, 2010 9:54 PM (in response to thasro)
    I too had the "POSIX reports: The operation couldn't be completed. Cannot allocate memory" problem when formatting a GPS device (of all things!).
    Note that I could not format either in my XP partition.

    I tried the trick posted at:
    http://www.macosxhints.com/article.php?story=20070306150736965
    and it worked.

    Paul
    MacBook White, Mac OS X (10.6.2), Windows 7 with VMware Fusion
  • Gazzaman Calculating status...
    Currently Being Moderated
    Mar 11, 2010 4:09 AM (in response to paulausoleil)
    Yes, well I've used the feedback link as suggested (I'm sure others have done so since the beginning of this thread also) and will now await the sure to happen fix.
    Should I hold my breath?
    Mac Mini 2.66, 4gb/320/1.5Tb MacPower/1Tb Iomega
  • kenny De La Cruz Calculating status...
    Currently Being Moderated
    Mar 11, 2010 9:53 PM (in response to thasro)
    Hey guys I was having the same issue. after hours of online readings I found something usefull!!
    it worked for me

    what i did was use "diskutil" in Terminal formated to Mac OS extended

    Getting information on the drive itself will allow you to see the Disk Identifier which can be used in the terminal commands below
    1. Use the "diskutil" command.
    To format the drive with the diskutil command, enter the following command in the Terminal, replacing "NAME" with the desired name of the drive, and "IDENTIFIER" with the drive's ID found in Disk Utility.

    type this in Terminal:

    diskutil eraseVolume HFS+ NAME IDENTIFIER

    here is the link to where I found this
    http://reviews.cnet.com/8301-13727_7-10430235-263.html
    27-inch: 2.66GHz i5 iMac, Mac OS X (10.6.2), Awsome Machine
  • huiling Calculating status...
    Currently Being Moderated
    Mar 12, 2010 7:53 AM (in response to thasro)
    i couldn't find the utility disc. Do anyone know how can i find it. I tried to go MacHD -> applications -> Utilities. But there's no untility disc inside, so i couldn't format my external HD to fat32
    macbook pro, Mac OS X (10.6)
  • Clif H Level 1 Level 1 (115 points)
    Currently Being Moderated
    Mar 15, 2010 10:44 AM (in response to thasro)
    Exact same issue with an external Firewire 800 drive. Ran diskutil from Terminal as mentioned in other sites and still got both the memory error and other errors mentioned in above posts.

    My solution?

    1. Plug drive into a different Mac
    2. Run Disk Utility
    3. Repartition drive into 2 partitions
    4. Reconnect to the original Mac
    5. Repartition as a single volume.

    I suspect Disk Utility has some issues in generating erroneous messages after failing a certain number of times. Worth a shot to try reformatting the drive on other Macs as well.

    HTH.
    MacBook Pro 15, Mac OS X (10.6.2)
  • Howard2k Calculating status...
    Currently Being Moderated
    Mar 15, 2010 11:07 AM (in response to Clif H)
    It is astonishing how many threads there are with people having problems with external drives.
    iMac 2.4GHz, Mac OS X (10.6.1)
  • paosborne Calculating status...
    Currently Being Moderated
    Mar 16, 2010 4:15 AM (in response to Howard2k)
    I am also having the same issues with Fibre Channel connected arrays to Xserves.

    Sadly this is for proving that FC arrays are going to be of use to us through R&D before we invest in new arrays specifically for our OSX environment.
    Xserves, Mac OS X (10.6.2)
  • ikramerica Calculating status...
    Currently Being Moderated
    Mar 17, 2010 12:55 PM (in response to thasro)
    Like others, I was having this problem with USB enclosures made by NewerTech. Two different mini-stacks, one USB only and one USB+FW. But when I plugged in the USB+FW via FW, I was able to format the drive no issue. So I swapped out the drives internally between the two cases and formatted both via FW, and now both show up even back in their original cases.

    It's annoying, but I imagine it has to do with a flaw in one of the USB chipsets combined with Disk Utility. Just because a lot of random drive enclosures by lots of companies are failing doesn't mean they all don't use the exact same controller, as there aren't that many controllers out there. It's probably a problem with certain Oxford chipsets, but it's still up to Apple to address this and they've failed to do so...
    Lots, Mac OS X (10.6.2)
  • Cottonline Calculating status...
    Currently Being Moderated
    Apr 1, 2010 2:22 PM (in response to thasro)
    I'm experiencing much the same issues as everyone else. I have a Sony EX1R camcorder that can't be plugged in via USB until my 2TB Western Digitial USB Time Machine drive is unplugged from my machine. Same goes for my little point and shoot and Eye TV. Even then I have to sometimes unplug and re-plug in the USB into a different port. Can't seem to isolate any specific port as a problem.
    For the record I have nothing other than a keyboard plugged into my other 4 USB ports. All though 2 of my 4 FW 800 are used for external memory. I also tried zapping Pram which apparently can reset USB interfaces. Still no luck.
    My external drives that have both USB and FW ports work fine if only using the FW so the problem certainly seems to be isolated to USB.
    Mac Pro 8 core 2.26 12Gb Ram, DMD G4, Mac OS X (10.6.2)
  • Parneix Calculating status...
    Currently Being Moderated
    Apr 1, 2010 2:35 PM (in response to thasro)
    Exactly the same problem here :

    1) Tried to format a 2.5" external hard drive (which I bought "naked" and installed myself in a hard drive enclosure). Got the infamous "POSIX reports: The operation couldn’t be completed. Cannot allocate memory". I was using a Seagate Momentus 7200.4 500GB 2.5IN SATA 7200RPM 16MB Notebook Hard Drive OEM. The enclosure StarTech SAT251OU2F 2.5" FireWire to SATA.

    * DON'T BUY THIS ENCLOSURE IF YOU'RE USING MAC COMPUTERS. At least for the moment.

    I tried to format the same drive in the same enclosure using Leopard (instead of Snow Leopard). Got the "input/output" notification : impossible to format.

    2) I changed the enclosure (same Seagate hard drive) back to a Ultra ULT40243 Hard Drive Enclosure - 2.5" SATA to USB 2.0, Brushed Aluminum.

    IT WORKS FLAWLESSLY.

    Conclusion? As far as I'm concerned it's a compatibility problem with some SATA interface.

    P.
    Macbook Pro Unibody Core 2 Duo 13" 2.53GHz, Mac OS X (10.6.3)
  • cschoolland Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 12, 2010 6:26 PM (in response to thasro)
    Hardware: WD My Book Premium II, 500GB RAID1, fw800

    When I mounted the drive yesterday, it froze some apps that would be accessing it (incl Finder) and would not re-mount. I dismantled the enclosure and tried the drives separately in a usb dock. I was able to recover my not-backed-up files with DiskWarrior, but it couldn't fix the disk (disk malfunction) and seemingly even made it a little worse. Now it seems both drives are unrecognizable by my system. Disk Utility can see one of them, but is unable to format it (same "POSIX reports: The operation couldn’t be completed. Cannot allocate memory" of this thread). Same error trying to format from Terminal using aforementioned method that worked for others. Placing the drives back into the WD enclosure, WD software recognizes enclosure if only 1 or neither drive is inserted, but if both are inserted WD software does not recognize anything at all (invisible to Mac in any case). Will see if PC friend can salvage drives, or I'll have to buy new ones (thank goodness for backups of backups!)
    2008 iMac 24" 2.8Ghz, Mac OS X (10.6.3)
  • payshunz Calculating status...
    Currently Being Moderated
    Apr 13, 2010 7:58 AM (in response to thasro)
    Mac Mini, 2GH Core2Duo, 4GB memory, Snow Leopard 10.6.3

    I see this "POSIX reports: The operation couldn't be completed. Cannot allocate memory" problem is still alive and kicking.

    I have an external LaCie d2 Quadra 1TB Hard Disk. I was using this as my boot drive via FW800. I began having issues with it (improperly dismounting) and finally decided to reformat the thing. Using disk utility I encountered the above POSIX error message.

    As I was unable to reformat using the FireWire 800 connection, I backed down to the USB 2 cable, ran disk utility and was able to reformat the drive successfully.

    I'm not sure what the issue is. Whereas the majority of posts here indicate problems with the USB connection on the external drive (and being able to resolve them using a FireWire connection), MY problem was the opposite. I'm pretty sure my troubles with this disk began prior to (and continued on to) 10.6.3.

    Though it's working fine now (I transferred 60GB to it without error), I'm not sure I can trust the drive. I guess I'll store non-vital stuff on it (music, movies, replaceable things) and keep an eye on it.
    mini, Mac OS X (10.6.3)
  • macwebster2 Calculating status...
    Currently Being Moderated
    Apr 19, 2010 2:17 PM (in response to Parneix)
    I think you are on to something Parneix with the SATA angle. All my ext. drives work fine with SL, except the one with the eSATA interface.

    My OWC Mercury Elite Pro "Classic" 750 GB Quad absolutely flakes out in SL and works fine in L.

    Absolutely not stable for use.
    Mac Book Pro 17, Mac OS X (10.6.3), various external drives
  • Thompson800 Calculating status...
    Currently Being Moderated
    Apr 20, 2010 6:51 PM (in response to macwebster2)
    You may be onto something regarding eSATA connection. I have an Addonics Ruby Cipher 2.5" ExDrive with eSATA and am using Addonics eSATA>USB2.0 converter (my 13" aluminum MacBook only has USB2.0 ports, no firewire, a.k.a. the castrated version)

    I updated OS X with the update that came out this last week (10.6.3). It seemed to work at first b/c disk utility now allowed me to partition it (1 partition, Mac OS X, GUID parition map b/c Intel Processors) and even erase and overwrite with 0's (when selecting the indented disk image should be done.) So I thought all was well.

    But two days later it just ejected itself IMMEDIATELY after mounting and gave me a 'disk improperly ejected warning'. Now the drive won't mount at all. And it's back to square one.
    MacBook, Mac OS X (10.6.3), using Addonics Ruby Cipher 2.5" ExDrive w/ eSATA>USB2.0 converter
1 ... 7 8 9 10 11 ... 19 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (5)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.