Previous 1 8 9 10 11 12 Next 272 Replies Latest reply: May 1, 2013 6:55 AM by Chris McCord Go to original post
  • bsafarik Level 1 (0 points)
    I just wanted to add myself to the list of people with the same problem! I'm running 10.6.3, and get the "POSIX reports: The operation couldn't be completed. Cannot allocate memory", when I try to use my Iomega 160 GB external hard drive.
  • The Test Level 1 (0 points)
    Yet another disgruntled apple user with the same POSIX error.
    10.6.3 obviously didn't do the trick as that is what i'm running.
    Tried the Windows trick (luckily there's a lone PC in the house)...didn't work.
    Tried on 10.5 - no luck.
    Am going to take the hard drive to a friend who has very wisely not updated and is still running 10.4, and see if that does the job.
    Apple have really **ed this OS up this time...oafs.
  • paultmccain Level 1 (0 points)
    Add me to the list of users having the POSIX issue. I've done everything suggested on this thread: no dice.

    I am using an external Seagate drive, 1 TB. Working fine, until 10.6.3

    Apple? Hello? Is anyone out there?
  • jamzer12 Level 1 (0 points)
    Found a work around for this problem, at least for me.

    I used Windows XP to initialize the drive. I was then able to connect it to my Macbook Pro with 10.6.3 and initialized it again for the Mac. So far it's worked no problems.

    Not the best solution I'm sure but one that has worked for me. Good luck.

  • Ebbo Level 1 (0 points)
    Add me to the list, too...

    Sad story for a 2.200 Euro computer...
  • redster Level 1 (10 points)
    Jonnix's suggestion worked for me:

    samsung spinpoint 160gb ide sp1654N in a safecom usb caddy.

    i'd tried on a windows box, wiping the disk with dban, partitioning, formatting as ntfs.

    thanks Jonnix, although I dont understand why running the CLI command works any better/differently than the GUI.
  • Peter Blaze Level 1 (0 points)
    1. Use the "diskutil" command.
    To format the drive with the diskutil command, enter the following command in the Terminal, replacing "NAME" with the desired name of the drive, and "IDENTIFIER" with the drive's ID found in Disk Utility:
    diskutil eraseVolume HFS+ NAME IDENTIFIER

    2. Use the "fdisk" command.
    An alternative to the "diskutil" command is the older "fdisk" command, which can be used to partition and set up the drive. As with the diskutil command, replace the IDENTIFIER portion with the ID found in Disk Utility:
    fdisk -a hfs /dev/IDENTIFIER
    After one (or both) of these commands have been run, try managing the drive again in Disk Utility.
  • stevesse Level 1 (0 points)
    Here was the error message:
    "POSIX reports: The operation couldn’t be completed. Cannot allocate memory"

    I solved in this way using Disk Utility:
    - I partitioned in 2, one extended/journaled and one fat-dos
    - I formatted as usual

    Maybe a lucky shot, maybe not.
  • johart Level 1 (0 points)
    i have the same problem....

    we archive our finished work on some internal western digital 1 TB drives connected via ESATA dockingstation. this was no problem with leopard. now we upgraded to snow leopard and i have the same problem: i can not erase the disk in disk utility, every time the message "disk erase failed with the error: POSIX reports: the operaton couldn't be completed. input/output error"

    i have to archive some jobs urgently, so i need a solution for my problem ASAP. does apple say something to this problem?
  • Drewzers Level 1 (0 points)
    I think I've figured it out. I'm running an OWC external with my wife macbook running 10.6.4 and tried and tried via usb, but there was a tip out there to use firewire. I plugged in the firewire on the external and within 5 seconds it was reformatted. So to everyone who can, try using the firewire. Hope this helps those who have a firewire option.
  • aRKay Level 2 (205 points)
    As I read over this long topic I could relate to many of the comments. I was having
    fits getting some WD and Seagate drives to mount and stay mounted that were
    hosted in external cases. You may not like or agree with my solution but it worked
    for me.

    The internal hard drive in this iMac failed and was replaced by AppleCare and I
    noticed the replacement drive came from Hitachi. I was at Fry's a few weeks later
    and picked up a 500 GB Hitachi drive and it worked perfect in my USB 2.0 case with
    two partitions that were created using Apple's Disk Utility.

    I was then having trouble with another external drive with a new WD (Blue) 500 GB
    drive that would not stay mounted. It was less than 30 days old and Fry's let me
    exchange for a Hitachi 500 GBi drive. I have had NO hard drive issues since changing
    to Hitachi.

    Apple never said anything about changing to Hitachi. All I know is my HD issues
    became history when I changed from WD and Seagate to Hitachi. I do not recall
    anyone on this topic having trouble with Hitachi drives.
  • The Hammer610 Level 2 (285 points)
    I have not gone through all 10 pages of info, but there is also this link:

    I have an external WD that was working fine, but now, I cannot even get it to show up in the disk utility using FW or USB on three different computers, one using 10.6 and two using 10.4.
  • Mark Petereit Level 1 (25 points)
    I solved this problem on my 1.5TB Seagate drive by first setting up two partitions: 1: Mac OS Extended, 2: MS-DOS (Fat)

    I dragged the partition size down so the MS-DOS partition was as small as I could make it, then clicked [Apply].

    Once it was finished, I deleted both partitions, then was able to successfully add a single Mac OS Extended partition.
  • dzmac17 Level 1 (0 points)
    Ha! This may be a SOLUTION! At least it worked for me.

    I had a USB 120GB WD Passport that had been working fine. Somehow, between using it to transfer files and as a Time Machine Backup, it got into the situation most of you are describing.

    I tried to Erase it, Partition it, wipe it...everything through DiskUtility and Terminal. Tried all the solutions. Unfortunately, I didn't have an extra mac or pc to put it in. And, only has a USB Port. I just kept getting the "Cannot unmount the drive" and "OSIX reports: The operation couldn’t be completed. Cannot allocate memory." I'm using Snow Leopard 10.6 btw.


    Put in your Snow Leopard install disc (or restore discs). Restart the machine, and hold down the Option key as it restarts (before you see the Apple icon). It will give you a choice of which to boot from: Hard Drive, CD, etc.

    Boot from the CD. Once it comes up, choose your language, and then when the top menubar appears choose Utilities-->Disk Utility: (not my site, but a nice screenshot)

    Then partition the drive! It works! After that, the drive should work fine.

    I first partitioned mine drive into 2 parts (Mac OS Extended and Fat32). That may not matter. Then I was able to erase it, and format it any way I wanted.

    Hope that helps!
  • GerryML Level 1 (0 points)
    I'm currently having the same problem with my 1TB Seagate FreeAgent/Desk ext. HD connected using Firewire 800 cable. I have an iMac 09' w/ 4MB memory and SL OSX v10.6.4. The Seagate has 3 partitions all formatted Mac OS Ext'd (journaled). The main partition is used for backup with TM.

    Before I had this problem, TM was doing data verification process for over 36 hours (over 10K files verified.) I also did a research on why this is happening and why it's taking so long. Apple site mentions about changes particularly is OS or major movements of files as the cause. Anyway, during this process, the Seagate, as it happens from time to time, was dismounted. From then on, I can no longer remount and access data from the Seagate and have been getting this POSIX reports error "Cannot allocate memory" after attempts to erase and reformat the drive form Disk Utility.

    I have tried all below (as read here and other forums) but was unsuccessful:

    1. I read about people switching from USB to Firewire and solved the problem. Since I have been using Firewire 800 I tried switching cables using USB and Firewire 400 just in case but to no avail.
    2. Use the install discs to boot and from there use Disk Utility to erase/partition/reformat the drive. Same error occurs. Booting from install disks is also not possible when the Seagate is connected. Connection will have to be done after booting. (Now, booting even from the internal HD is not possible with the Seagate connected.)
    3. Connected Seagate to PC running XP. Cannot reformat/initialize/access the ext. HD from Admin tools because the ext. HD is formatted as HFS+. Not sure if MacDrive ($40) will fix it.
    4. Downloaded Seagate Diagnostics software from the Seagate website. The software detects the ext. HD after a few minutes with other partitions not mounted. The test hangs every time and does not give any results. I have to Force Quit the app so I can continue working.
    5. Tried using Disk Utility to repartition many times using different schemes but with same error.

    Also, at one point only 1 partition will be mounted. When I try to eject this partition by dragging it to the Trash I will get an error and an option to "Force Eject" the disk - which I do.

    At this time, when I'm erasing/reformatting the Seagate from Disk Utility, the "mounting disks" status bar endlessly shows without progress. I am currently stuck and out of options but to make some support calls. Anybody out there have any other tricks up their sleeve? Thanks to all your suggestions!
Previous 1 8 9 10 11 12 Next