Previous 1 10 11 12 13 14 Next 272 Replies Latest reply: May 1, 2013 6:55 AM by Chris McCord Go to original post
  • chrisrabbit Level 1 (0 points)
    dzmac17 wrote:
    Ha! This may be a SOLUTION! At least it worked for me.

    I had a USB 120GB WD Passport that had been working fine. Somehow, between using it to transfer files and as a Time Machine Backup, it got into the situation most of you are describing.

    I tried to Erase it, Partition it, wipe it...everything through DiskUtility and Terminal. Tried all the solutions. Unfortunately, I didn't have an extra mac or pc to put it in. And, only has a USB Port. I just kept getting the "Cannot unmount the drive" and "OSIX reports: The operation couldn’t be completed. Cannot allocate memory." I'm using Snow Leopard 10.6 btw.


    Put in your Snow Leopard install disc (or restore discs). Restart the machine, and hold down the Option key as it restarts (before you see the Apple icon). It will give you a choice of which to boot from: Hard Drive, CD, etc.

    Boot from the CD. Once it comes up, choose your language, and then when the top menubar appears choose Utilities-->Disk Utility: (not my site, but a nice screenshot)

    Then partition the drive! It works! After that, the drive should work fine.

    I first partitioned mine drive into 2 parts (Mac OS Extended and Fat32). That may not matter. Then I was able to erase it, and format it any way I wanted.

    Hope that helps!

    Thank you! This fix worked for me as well. Everyone try this!
  • SamuelJohn Level 1 (0 points)
    Thanks kenny De La Cruz, that worked for me, too. Hope this bug will be fixed soon.

    *diskutil eraseVolume HFS+ diskNR*

    Just replace diskNR by the disk you want to format.
    The command *diskutil list* may help you in getting the right disk.
    Be careful not to format a wrong disk!!!
  • traversario Level 1 (10 points)
    This is an old thread, but I'm posting this anyway as I'm sure other people will be looking for this.
    I had the same problem when I my Apple issued internal HD failed and I replaced it with a Western Digital WD10TPVT: Prosix (blablabla): Can't allocate memory. I tried everything I could find online (not a lot) and finally brought my MBP to an Apple dealer. It turned out it hadn't anything to do with the harddisk: the connecting cable between the HD and the motherboard was damaged. This was fixed under warranty and I'm back up to steam (if that's an expression). The only thing I wasn't so happy about is that I wouldn't have had to buy the new harddisk. But then again, now I have 1TB in my notebook so I'm okay with it...
    So if everything else fails, there's always warranty and spare parts.

    Message was edited by: traversario
  • X2THEBOX Level 1 (35 points)
    I was able to wipe, partition, and restore a 640GB external USB hard drive that had the POSIX memory error with Mac OSX 10.6. However, I used a computer running Ubuntu 10.10. I just plugged the external USB drive in, ran GParted from terminal, clicked on my drive, and said format as FAT32. Later, I decided to write all zeros to that disk. I went online and had the commands to run from terminal (using Ubuntu) in less than a minute.

    If you only have a mac, you can still run Ubuntu, but do so using a live CD.
    Get it free from here for desktops:


    Download the ISO, burn it to a CD using Disk Utility, reboot and hit C while you boot up. Choose the "try Ubuntu without any changes to my PC"

    First plug in the bad drive,
    Then click on Accessories-> Terminal
    Type: sudo -s, hit enter
    type: gparted, hit enter
    find your external hard drive (make SURE about this!!!)
    Select the format option, choose what you want.
    You're done.
  • ImaginaryTime Level 1 (0 points)
    Running into a similar problem. My old 500 GB (USB2) Time Machine drive filled up, and I bought a new 1TB Iomega Select Desktop Drive (USB2), which has a Samsung DH103SI hard drive in it.

    It came NTFS formatted, and I repartitioned/formatted it to Mac OS Extended (Journaled) with GUID Partition. All went well until this point, the drive was formatted, recognized, and mounted by OSX.

    I then used Disk Utility and Restore with the Erase option, to copy the old Time Machine drive onto the new. The process took quite a long time, and I left it running over night. This morning, I had the error 'The operation couldn't be completed. Cannot allocate memory'.

    The new 1TB has the name of the old TM drive (so something has been copied), but the drive won't mount. I'm trying it again now, just in case, but I guess with the same result.

    I wonder if I could use CarbonCopy or a similar program, if this doesn't work.

    Very annoying, and I don't know what to do.

    Message was edited by: ImaginaryTime
  • Apl9 Level 1 (0 points)
    @ the person who said to use Hitachi. That was a waste of money. I bought a hitachi HDD on his/her advice and it still doesn't work.

    My combo is still not working:

    Hitachi or Seagate 500GB
    Addonics Ruby Cipher enclosure (with eSata to USB converter)
    MacBook with OSX 10.6.4 (with sadly only USB ports)

    I've tried everything, 3 brand new hard drives (2 x 500GB seagate & 1x 500GB hitachi); with a MacBook,MacBookPro, and an old XP laptop; and tried all the tricks formatting with two partitions, using command line, etc.

    I was able to successfully get it working with a small 250GB HDD and using different cheap enclosures instead. But a 500GB in my expensive encrypted Addonics enclosure (for biz security) still doesn't work. So I think this is still an issue with, either 1.) 500GB+ hard drives, or 2.) units connected via eSATA to USB convertor.
  • GerryML Level 1 (0 points)
    * UPDATE * ... from my previous posts (pages 10 & 11). The 1TB Seagate Ext HD that was replaced through Seagate warranty has been working flawlessly so far. The hard drive brand or the capacity of the HD does not have anything to do with it. My internal HD which was a WD changed to a Seagate through Apple warranty 2 year ago has been fine too. I think the problem has something to do with TM. Has anyone experience the "POSIX" problem with the Ext HD and not using TM?
  • Apl9 Level 1 (0 points)
    I don't use time machine. This is a greater encompassing problem than just time machine, IMO. I think it has to do with OS X's disk utility or a disk utility + external HDD chipset incompatibility combination.
  • Anderson Williams Level 1 (5 points)
    I battled the "POSIX reports: The operation couldn’t be completed. Cannot allocate memory" error for several hours trying to format a brand new Western Digital 500GB PATA drive placed in an old external USB enclosure. I used every combination of format and partition; I tried every Terminal command in this thread and booted from my installation DVD and ran DiskUtility there. I tried it an enclosure with Firewire 800 and 400. Nothing worked.

    Then I checked the drive's jumper settings. When I moved the jumper to the Single (Neutral Position) and hooked the drive back up, it's size was reported correctly and it initialized in seconds. I looked at a chart here:

    Just one more thing for you to try before you smash the HD with a hammer.
  • Paul Willis Level 1 (5 points)
    Just a thank you to Kenny. The terminal fix worked for me.
  • lights22 Level 1 (0 points)
    Hi all. I hope you can help me.

    My hard drive is playing up and I really don't want to have to reformat and lose all data.
    Here's what I got:
    iMac 24 2007. Running latest snow leopard. 3gb ram
    Hdd is 1tb seagate expansion. USB.
    The drive is partitioned into 2 Hfs partitions. 700gb movies etc and the other 300gb for time machine.
    Was working fine. Then for no reason opened the movies volume in finder and all folder contents gone. Seemed to sort itself out but a few days later would not unmount when trying to eject. Couple of days ago it stopped displaying any files or folders whatsoever but still reported in 'get info' that there was data on the drive.
    I've done everything I can think of and searched all over google.
    Here's what I've already tried:
    - Disk utility can't unmount the drive in osx and therefore cannot repair.
    - Disk utility from startup disk has a go at repairing the disk. Ive tried a few times and it either repairs it and reports that it's ok or else says error and fails.
    - tech tools can't unmount the disk
    - disk warrior can't unmount the disk
    - data recovery programs report errors and so I am unable to retrieve my data that way.

    The constant issue that all these programs have is that neither volume on the disk can be unmounted when in osx. There are no programs using them and they fail to unmount even on a fresh reboot.
    Occasionally when powered up the disk reports the correct first level of the directory. No data can be read or written though.
    Finder hates it and crashes sometimes when trying to access either volume.

    The seagate drive is less than a month old and, like I said, I really want to avoid a format.
    Does anyone have any suggestions?
    Or could someone tell me how to use activity monitor to figure out how to locate the process that is causing the drives to fail to unmount.

    Many thanks.
  • GerryML Level 1 (0 points)
    If you read my previous posts (p10-11), I had problems with a 1TB Seagate Ext HD. I had a POSIX problem with some mounting problems just like one your having. I am not sure what caused the problem, if it's the OSX, TM, or the Seagate. But, ever since I got a replacement from Seagate things are good. I did not partition the drive and mainly kept it for TM - just to be safe. I also noticed that my bad Seagate drive was heating up 3X faster than what I have now. I'm afraid you have to get that replaced through warranty. Seagate may even recover the data you have in that bad drive through warranty also. Check with them. The next time I'm buying a new HD, it won't be a Seagate.
  • lights22 Level 1 (0 points)
    Thanks for the advice Gerry. Good to know I'm not alone. I feel that the two partitions might have been what made it go wrong.
    Do you think another option may be to reformat disk as single partition. Recover data and then format again. Put data back on drive and give it one more go.
    If it fails again then I'll send back to seagate.
    Can anyone tell me if I stand a good chance of recovering data if I format and delete partitions. I'll try with drive genius.
    Thanks all
    And thanks again Gerry.
  • GerryML Level 1 (0 points)
    My partitioning before was 500GB for TM and 500GB for media (movies, etc.). My internal drive is 500GB also. I think that alone is a problem with TM but shouldn't have caused the POSIX error. I already had problems accessing data in the Seagate Ext HD after the POSIX/mount/unmount problems first occurred.
    Reformatting or Initializing your HD will wipe away your data no matter what. I was just lucky enough that I could afford to lose my data in the ext. HD but will not risk it again. Try to read more about what others did here before sending it out. I have read a few successful recoveries here in the past. Good luck.
  • kakaluto Level 1 (0 points)
    Having the same problem with SL, cannot erase and format drive. Disk Erase failed with the error: (POSIX reports: The operation couldn’t be completed. Cannot allocate memory)

    Bug in SL or any solution? External drive is useless until I can format it on Windows.
Previous 1 10 11 12 13 14 Next