Previous 1 2 Next 24 Replies Latest reply: Mar 1, 2010 6:41 AM by kenjohn55
rexwool Level 1 Level 1 (0 points)
I have always had superb results with the Epson Stylus Photo R1900 (A3), until I installed Snow Leopard - now I cannot get a decent photograph no matter how much I tinker with the settings. I am using the recommended driver.

Snow Leopard? S'no use!!

iMac 2.16 GHz Intel Core Duo, Mac OS X (10.6)
  • Robert Yanal Level 1 Level 1 (30 points)
    According to Apple's web site:

    http://support.apple.com/kb/HT3669#HP

    you should be using Gutenprint 5.2.3. (Your probably are, but just checking.)

    BTW, my HP Deskjet 5650, an oldie but a goodie, is not supported at all under Snow Leopard!
  • CalxOddity Level 3 Level 3 (680 points)
    And that's why I'm not upgrading to SL yet - my r1900 is working very nicely thank you in Leopard and there's no compelling reason to upgrade.

    Don't use the Gutenprint drivers unless you only want basic printing - they don't cut it for photo printing. Some are reporting good results with updated Epson drivers, but it's mixed at the moment.

    Regards,
    Calx
  • rexwool Level 1 Level 1 (0 points)
    Thanks, Robert. I am using Gutenprint 5.2.3, but the results are awful. I guess I'll just have to keep looking.
  • rexwool Level 1 Level 1 (0 points)
    Hi Calx, I think you were the wise one! If I can't find the right drivers I'll just have to revert to Leopard. The Gutenprint driver recommended by Apple is, as you say, hopeless.
  • beside Level 1 Level 1 (0 points)
    I had this issue. I updated my drivers, spent about an hour on the phone with Apple, removed bundled software from Epson, added drivers, removed Guttenprint drivers, fixed stuff in the Library and eventually came to a proper solution after being on the phone with Epson for 30mins.

    They have different drivers in their bundles. Choose the one for Tiger/Leopard which includes the 10.6.x driver (driver version 6.20). Don't forget to uninstall the software, restart (without your printer on/plugged in), follow that by removing the printer from the print list, then plugging the printer back in and it auto-adds it with the proper driver which you just installed from the download.

    Once that's done, you should have all your options in the print settings, where you can specify all the colors etc. options.

    Hooray, I spent about 2-3 hours fixing this issue, I hope this helps someone else.
  • gloom909 Level 1 Level 1 (10 points)
    I can confirm that the following method solves the issue of crap/bad/washed out/slow printouts from the Epson R1900 under Snow Leopard:

    1) Remove the printer driver *using the driver installer* (dropdown, select "Uninstall"). This makes sure that all leftovers of the old printer driver is removed. Wait for the 2000+ elements to be moved to the trash.

    2) Make sure the R1900 is unplugged, then reboot your Mac.

    3) Go to *"System Preferences"* -> *"Printer and fax"* and remove the Epson R1900 by selecting it and clicking the "-" sign.

    4) Empty the trash. Make sure everything is gone.

    5) Download the *6.20 driver* (important! Don't choose the newest one, unless there is one specifically marked Snow Leopard, which at the time of writing, there is not) and install it - direct link: ftp://download.epson-europe.com/pub/download/3202/epson320283eu.dmg

    6) Plug the printer back in, then go to "System Preferences" -> "Printers and fax", and select the "+" sign to add the R1900 again. Welcome back to a world of fantastic quality prints.

    Again: this works perfectly. *Do not use the Gutenprint driver* as suggested by Apple and Epson, as it is complete rubbish.

    Message was edited by: gloom909. Forgot to add the point about emptying the trash, which might or might not be important, but it is how I did it so I felt it should be included.
  • Original_NightStalker Level 1 Level 1 (15 points)
    I'm having all sorts of problems with my Epson R1900 since upgrading to Snow Leopard, too. I'll try the suggestion above, BUT there is one difference in my setup - I have the R1900 running off a wireless D-Link Print Server on the LAN, and not plugged directly into the computer.

    The D-Link Print Server has a fixed IP address on the LAN, and I can get to it via a browser using that IP addy, and control all the settings etc. I had no problem with this setup before upgrading to SL.

    Now, the Mac simply doesn't "see" the printer, and all attempts at installing using the latest 10.6.x drivers from Epson have failed. I've tried it as a TCP/IP printer, a LPR printer, and an HP port printer (which funnily enough works with the big colour laser we have). I've tried it with the Epson drivers and the Gutenberg drivers and the Generic drivers.

    Epson suggest using the Bonjour driver, but I have no idea how to install that - it doesn't show up in any list of drivers on my Macbook Pro.

    This is driving me nuts - I had no problem with Leopard, and have been getting superb prints from Aperture via the R1900. Now - zilch, zippo, nada...!

    Anyone else successfully installed the R1900 on a LAN as a networked printer for a Mac, since the Snow Leopard upgrade?
  • bia23 Level 1 Level 1 (0 points)
    hi there,
    i was having the same problem. the reason is because snow leopard uses the gutenprint drivers.
    you need to install your epson printer driver. if the new epson "snow leopard compatible" driver doesn't work, you need to install a previous driver from epson - for OS 10.4.
    once you have done that, you can go to the printer center ( in system preferences) and choose the epson driver that you installed. the new epson drivers are not always visible to snow leopard but for some reason the 10.4 drivers are... go figure.
    hope it helps,
    bia
  • Alan of VianAlky Level 1 Level 1 (25 points)
    Using the latest drivers for R1900 after installing Snow Leopard!! when will Epson & Apple get together and sort them out to satisfy their customers? I am constantly asked what size paper i have when i want to print a CD! Thankfully i am able to use the printer to its full extent as i still have my iBook G4 running Tiger!
  • CalxOddity Level 3 Level 3 (680 points)
    All,
    I've been checking the Epson site almost daily for R1900 driver updates, and some were quitely launched a few days ago - dated 28 October. No longer need Rosetta?? This might sort some of the problems.

    Good luck! (I'm still on 10.5.8 and will stay there until all the "excitement" dies down...).

    Regards,
    Calx
  • NBW Level 1 Level 1 (5 points)
    After initially installing Snow Leopard and running into the Gutenburg driver problems I followed the steps in this thread and got things running fine. I recently installed the latest update to Snow Leopard that came out a couple of days ago. Since then printing to my R1900 has gone to crap. I am getting washed out orange prints with vertical banding. I followed the steps again but I tried the latest driver that came out on 10/28. No joy, I'm still getting garbage prints. I even tried the new Gutenberg 5.2.4 drivers and got the same results.

    One thing I have noticed is that even though at this point I have the Gutenberg drivers uninstalled and I have the the latest Epson drivers installed I still have two different R1900 drivers available. One says "Epson SP R1900" and the other says "Epson SP R1900 (1)". The "(1)" driver offers the usual large selection of options in the "Printer Features" section. The other one has a paired down set of options and simple offers "Color Model", "Media Type" and "Resolution".

    This Epson / Snow Leopard / Gutenberg debacle makes be feel like I am in Windows ****. I'm going to try finding the old drivers and reinstalling once more.

    -Noah
  • Siomn Level 1 Level 1 (10 points)
    I had exactly this problem with Snow Leopard and my 2400, the first thing to know is that you must not use the gluten print driver it's crap. The following worked for me and my printer is now working fine :-
    1. Close any applications that are open.

    2. Click on the Apple icon and choose System Preferences. Choose "Print & Fax".

    3. Highlight the Epson printer in the list and click the delete button [-].

    4. If no other printers are installed, in Print and Fax please hold down the Control key and then in the list if printers, click and hold. That should present the "Reset printing system..." menu. Choose this option and confirm.

    5. Disconnect the printer from the computer.

    6. We will now remove the EPSON Printer driver from the system and delete the drivers that you downloaded.

    Go to the Mac Hard Drive/Library/Printer and move the complete EPSON folder to the trash. Warning this removes all EPSON Printers.

    7. Also remove any drivers that were previously downloaded to the trash if the file name does not match that from our web site.

    8. Restart the Mac.

    9. Empty the trash.

    10. Now we will run a repair utility that may take up to 30 minutes to complete so please plan for this. Go to Mac Hard Drive/Applications/Utilities and open the Disk Utility. Note: If you cannot find it this way, use Spotlight to locate it.

    11. Select Disk First Aid at the top of the dialog box.

    12. Select the Mac Hard Drive Icon in the left hand pane.

    13. Select Repair Permissions at the bottom of the dialog box.

    14. When this has completed restart the Mac.

    Power the printer on and connect it to the Mac. Ensure that it is directly connected to a port (such as a USB port) on the Mac and not via a third party device such as a USB hub.

    You will now need to download the driver/s from the Epson website. Connect to the Epson website via the link below:

    http://esupport.epson-europe.com/FileDetails.aspx?lng=en-GB&data=zbff+oTjl0EHnix fShyxIHWVn0U002FZyJp6TQAu9H3pjHIU003D&id=324505

    Download the printer driver for your printer and ensure this starts in the Download Manager you will need the driver 6.62. Try the following to install and add the driver:

    1. Locate the downloaded file and double-click it. This should mount a drive on the Desktop. Double-click this and a window should appear with a blue VISE icon. This is the printer driver installer, double-click this icon.

    2. Follow the on screen prompts to install the driver, restarting the Mac once the installation has been completed.

    3. Once restarted the driver needs adding to the printer list. To do this click on the Apple icon then System Preferences. Choose "Print & Fax" and ensure it is set on "Printing". If the gutenprint driver is listed here, highlight it then choose the delete option (this can normally be done by clicking the [-] minus sign.

    4. Normally, USB printers will add themselves automatically. Check the list for your printer. If listed, highlight the printer and the driver information will appear on the right. Under "Kind" the printer name should be listed, i.e. Epson SP R2400 Series with a version in brackets. If a gutenprint driver is listed or the 'Kind' indicates a different printer model delete this driver.

    5. If the Epson driver is not listed, click the add icon button [+] towards the bottom-left of the window. The window that will appear first will be the Printer Browser. Connected printers with a valid driver installed should appear, highlight it and click the "Add" button. Do not choose a different model from the list of printers that may be present. If 'Add' is greyed out, leave the browser open for 10 minutes and ensure that the printer is powered on and connected directly to the Mac. Do not connect it via a third party device such as a USB hub or hub in a keyboard.

    6. The printer should now be added to the printer list. Test the printer with a Nozzle Check so ensure paper is loaded. In Print & Fax, double-click the printer name and choose "Utility" from the top of the window that appears. In the Epson Printer Utility, select to print a 'Nozzle Check'.

    This is taken direct from Epson support and worked for me

    Good luck

    Simon
  • NBW Level 1 Level 1 (5 points)
    Thanks for the very detailed instructions! Before I saw these I ended up uninstalling Gutenberg using the 5.2.4 installer/uninstaller in the DMG I downloaded from the main Gutenberg site. Then I uinstalled the EPSON drivers per the instructions in the beginning of this thread and then installed my older ones (epson13187.dmg) and my printing seems to be back to working order. I still have two R1900 drivers a "R1900" and "R1900 (1)", the later being the one that I am using. I'm going to leave well enough alone but thanks again!
  • Randy Glover Level 1 Level 1 (0 points)
    I finally "upgraded" to the r1900 this weekend from an r280 (which works fine on my MacBook Pro running Mac OS X (10.6.2). I have followed the detailed instructions, which are appreciated, but for some reason my prints continue to look washed out/faded. I have version 6.62 of the Epson driver installed, which was released October 28, 2009. I really hate to return this printer, but unless I can find a solution quickly I plan to return it and get something else, especially if I find a deal today on Cyber Monday. Or maybe I will just stay with the r280, which actually produces pretty nice prints as long as you don't go larger than 5x7.
Previous 1 2 Next