4 Replies Latest reply: Mar 10, 2010 1:09 AM by Simon Pendlebury
Cheezer66 Level 1 Level 1 (0 points)
Every time I start ITunes, I get the following dialog box: "A folder was specified instead of a file". I click OK on the dialog box and it moves along to ITunes. How can I stop this dialog box from appearing every time I start ITunes?
  • polydorus Level 6 Level 6 (11,950 points)
    Look in your Music\iTunes folder.

    Do you be any chance have a folder called iTunes Library?
    Normally you should just have 2 files called iTunes Library.itl and iTunes Library.xml not a folder with that name.

    This seems to have been the problem for someone else.
  • AlanBd Level 1 Level 1 (0 points)
    Hi All,

    I have just upgraded to 9.0.2 and am now getting this error, as with the previous post it says "The disk [My Hard Disk] cannot be read - A folder was specified instead of a file"

    I have deleted and re-installed iTunes, deleted the iTunes Library and re-created it (from scratch!) and I still get this error.
    Does anyone know how to solve it?
  • I don't need an alias... Level 1 Level 1 (0 points)
    I've had this problem as well, and I've noticed that it only pops up when I'm logged into the network at work. Corporate IT has been moving things around and changing the auto-mapped network drives that show up on my machine, and as they do this the pop-up comes and goes and changes depending on the drive letter assigned. My conclusion: You aren't going to find anything to fix this within iTunes, since there is some external network factor causing it to happen. I think we're stuck with the extra click.
  • Simon Pendlebury Level 1 Level 1 (0 points)
    Not sure if this helps but I had the same problem, again only happens at work,I received the same error message each time I opened iTunes, it did state a particular drive letter within the error S: checked and this drive was mapped on my computer but no longer used by the company, it had nothing to do with iTunes and had nothing related stored on there but I disconnected the drive and now no longer get the error message, might be worth seeing what you have mapped?