8 Replies Latest reply: Dec 8, 2009 10:14 PM by Jeff Ludes
redpola Level 1 Level 1 (25 points)
Just that - since 14:29 yesterday Mail has been stuck downloading the same message over and over again from my google-apps-hosted domain. Logging into google and searching for the message elicits no results. On google my drafts and trash folders are empty.

This "Copying message" operation also blocks all other network operations, so I'm no longer receiving new mail and cannot examine online folders.

The character of the message in question is that it was generated by Sync Diagnostics and contains an attachment which is 27MB in size, hence the bandwidth hogging all night!

I've tried changing setting in Mail.app for the account in question - the various options to store messages on the server or not - and this had no effect.

I'm at a bit of a loss to be honest. Any tips would be greatly appreciated.

One last thing - I can read mail fine online in Safari and fine on both my iPhones.

Aluminium MacBook, Mac OS X (10.6)
  • timrod0 Level 1 Level 1 (0 points)
    Intriguingly, I have experienced exact same behavior since 9/4 when I mistakenly tried to send too large a file using my Google Apps IMAP account. Now Google has stopped all my client-based access (calendar, mail) for exceeding some bandwidth limitation and Apple Mail continually generates a "recovered messages" folder with the offending message repeated many times (maybe as many as 50 times). No wonder I have a bandwidth problem with Google. But as redpola observed, I don't see any of these messages through my web access to Google apps.

    Incidentally, fwiw, just upgraded to snow leopard.
  • redpola Level 1 Level 1 (25 points)
    I'd like to confirm that I too have just upgraded to SL.

    I've also effected a fix, which was to delete "~/Library/Mail/IMAP-my@email.address@imap.googlemail.com/.OfflineCache/1", which was a file containing the offending message's data. Also in that directory was a file "2" and a file "operations", both of which disappeared after I restarted Mail. I then rebuilt the appropriate mailbox and everything's been fine since.
  • Libby2006 Level 1 Level 1 (0 points)
    I am having a similar problem. I have an imap account (not google, my own domain). I closed a note yesterday and it then created a recovered messages folder where a blank note keeps replicating itself. then I notice that 2 out of 4 email accts are not pulling in email. I don't have the files mentioned in the previous post so am wondering if there is another file I should delete???? and how do you "rebuild" your mailbox? I just upgraded to snow leopard too.
    thanks!
  • Tom Craft Level 1 Level 1 (70 points)
    I too am having this issue. I created an email full of photos that was 81MB in size. I then used the built in "resize image" feature of Mail, and made it 2.8MB. That email sent fine, but ever since then it keeps putting the 81MB file in recovered messages. This morning it had 34 copies of it. I can't find it anywhere on gmail.com, and both the website and my iPhone function fine.
  • boggy45 Level 1 Level 1 (5 points)
    I just wanted to reply to say this fixed the issue for me.

    Thanks!
  • redpola Level 1 Level 1 (25 points)
    I'm replying to my own message because I think there is a slightly safer fix. I've had a similar problem since and needed to dump my local differences to the server and it occured to me that doing as I suggested did work but probably relied on some code detecting an error when searching for the file I removed.

    I suggest a better solution (which is effectively the same as the first) is to pretend there are no local differences to the server's knowledge of the state of the world:

    open Terminal.app and type:
    cd ~/Library/Mail/IMAP-my@email.address@imap.googlemail.com/.OfflineCache/
    rm ./*

    (obviously replace the my@email.address bit with the relevant thing for you).

    I believe that this will remove all offline changes that Mail knows about. It may mean that you have some locally-unsynced changed but Mail will no longer be blocked.
  • ejoishi Level 1 Level 1 (0 points)
    I recently installed Snow Leopard, and have experience the several problems. One is a higher occurance of multiple mail downloads, some applications slow to launch, and some applications that wouldn't even run.

    I just got off the phone with Apple support and they indicated the multiple mail download issue could be caused by corrupt Permission files. The best way to clean up this is to:

    1. Close all applications
    2. Open Finder and on the upper bar click on Go
    3. Open the Utilities folder and in the Utilities folder launch the Disk Utility app
    4. Select the Macintosh HD and then launch Repain Disk Permissions.

    Unless there are a lot of things wrong, about 3 to 5 items should show up in the report, which is normal. This should straighten out ALL applications that have corrupt permission files. The recommend doing this after any major upgrade or install.

    Another thing I discovered is that for Snow Leopard, Quick Time needs a newer version of Flip4Mac to run .wmv files. There is a new beta version available from Telestream v 2.3.0.11 Beta.

    http://dynamic.telestream.net/downloads/download-flip4macwmv-beta.asp



    Good luck !
  • Jeff Ludes Level 1 Level 1 (5 points)
    Thanks redpola, deleting this file worked for me. I tried the terminal command you had, but could not get it to work. But clearing that cache did the trick.

    -Jeff