6 Replies Latest reply: Oct 9, 2009 7:39 AM by Mikefas
Mikefas Level 1 Level 1 (0 points)
I continually press the eject key on keyboard, see the eject icon on screen, but drive never opens. What gives. I'm on a brand new Mac Pro, running 10.5.8, with following drive.

HL-DT-ST DVD-RW GH41N

Mac Pro 2.93 Quad Intel Xeon, Iphone 3G, Mac OS X (10.5.8)
  • mathtop Level 1 Level 1 (0 points)
    I confirm the issue.
    I booted SL in 64bit mode and I insert a CD/DVD but it does not mount the CD/DVD. Even I could not eject the CD from the superdrive.
    I rebooted the Mac pro in 32bit mode, then it worked. Any of you know how to resolve the problem?
    My guess is that it is a 64bit driver problem.
  • Richard Platt Level 6 Level 6 (9,230 points)
    I booted into the 64 bit mode and all my drives loaded, mounted and ejected. I have the stock DVD drive; a Matshita Blu Ray drive; and, a Lacie DVD Lightscribe drive. Not sure what your problem might be but it doesn't appear to be a generic one.

    Good luck
  • mathtop Level 1 Level 1 (0 points)
    Thanks for your comment.
    In my case, the problem is solved after upgrading to snow leopard 10.6.1.
  • Mikefas Level 1 Level 1 (0 points)
    I figured out what was going on... Paralles was controling the cd/dvd drive for windows. the mac eject button was disabled. my work around is to disconnect dvd drive through parallels device menu. problem solved.
  • cameragirlnyc Level 1 Level 1 (0 points)
    I have the same problem- my dvd tray won't eject (actually, there are two, and neither of them ejects when I hit the eject button.) What does "parallels was controling the drive" mean, and how exactly did you fix the problem? thanks
  • Mikefas Level 1 Level 1 (0 points)
    i meant that parallels seems to override mac os x's eject button. i noticed that i couldn't get my drives to open when parallels was running. try quitting it and then pressing the eject button. if that works then you know it's parallels. you can then change the settings in your parallels menu bar... Parallels/Devices/CD/DVD Rom ---> select disconnect. Then you should be able to run parallels and use your mac to eject discs. hope that helps.