6 Replies Latest reply: Sep 8, 2009 11:43 AM by K T
ATC Produtions Level 1 Level 1 (0 points)
Hello,
I would like to become an app developer and I have got an app inmind in a area which is quite new on the app store. I don't want to buy a new Apple PC for cost reasons but I need Xcode to develope my app. But what I need to know is what version of Xcode do I need to download to work with a 10.4 Tiger Os system and in that older version of Xcode do you still get the drag and drop button and text feature onto the fake Ipod on your screen?. And are you still able to get the app up onto a fake ipod and test your app on your PC?, I need to know the answers soon!, If you need any more information please ask!

Thanks
Sam

Apple Mac G4 Laptop, Mac OS X (10.4)
  • K T Level 7 Level 7 (23,700 points)
    The current requirements surrounding the creation and deployment of an iPhone app to the store mean that it is pointless to do what you propose.

    what version of Xcode do I need to download to work with a 10.4 Tiger


    There are no legal downloads presently available in that category.

    If you want support as well, you'll have to either rely on your google skills and/or use current software if you expect others to participate, test and feedback on your code, etc.

    Get current or give it up.
  • ATC Produtions Level 1 Level 1 (0 points)
    So you are saying the old Xcodes are no good in developing new apps and I should have that latest macs to do it?
  • K T Level 7 Level 7 (23,700 points)
    ATC Produtions wrote:
    So you are saying the old Xcodes are no good in developing new apps and I should have that latest macs to do it?



    Not me....Apple.

    Apple owns the platform, hardware, software, tools, distribution, testing, marketing and support you'll be using. Being current is part of being involved.
  • ATC Produtions Level 1 Level 1 (0 points)
    So I need the latest Mac OS and the latest Xcode for what I need to do?
  • Q Lazarus Level 1 Level 1 (80 points)
    You need an Intel machine running 10.5.8 and programming experience.
  • K T Level 7 Level 7 (23,700 points)
    3rd time here...sorry I wasn't clear.

    Y E S - you need current hardware and software to develop iPhone apps, among other things. Check the iPhone Development Center for what those requirements are at your time of need.

    http://developer.apple.com/iphone/index.action

    When you buy your shiny new Intel development machine, you'll get everything you need but the appropriate iPhone SDK. Do a custom install from the DVD for Xcode. Check the iPhone Development Center for latest versions, etc.