Previous 1 2 3 4 Next 142 Replies Latest reply: Sep 14, 2013 5:50 PM by Greg Reyna Go to original post
  • danashley Level 1 Level 1 (0 points)
    THis also happens to me. It happened in Leopard and it happens in Snow Leopard. I had Apple replace the mouse and nothing. IT was less in Snow Leopard at first but now the mouse pointer appears all the way across the screen. It also makes the hot corners activate AND sometimes this happens right at boot causing the screen to light up then go dark until the mouse is clicked. IT happens on the WIndows side of the dual boot also (XPSP3). COuld this be related to the dual boot?
  • deh2k Level 4 Level 4 (1,765 points)
    It sure sounds to me like you need a new mouse.
  • Tracey-pet'l Level 1 Level 1 (0 points)
    Mine too. And definitely since I upgraded to SL. Please keep me posted on any progress as I'm having no joy this end. Though I have been finding that SL resets some of my preferences such as sound, so I may take another look in the sound panel.

    This is not my only major issue with SL by the way!
  • Tracey-pet'l Level 1 Level 1 (0 points)
    My mouse doesn't wander when I don't use it, but it struggles to recognise double and triple-click since I installed SL. Also, doing selected-area screen grabs is very patchy because it decides when to grab - I don't!
  • musicwind95 Level 4 Level 4 (1,280 points)
    The issue isn't extreme enough that I'd need a new mouse, and seeing that I'm using Apple's mouse, that should mean something. I firmly believe this is software issue. Let's keep this thread going and maybe Apple will start to pay attention.
  • musicwind95 Level 4 Level 4 (1,280 points)
    Update: It appears, at least after resetting the PRAM, that the issue is only really present every other restart or so. That is, I'd shut it down, and the next time it'd be fine. The time after, the mouse would start acting up again.
  • Mulderscully Level 1 Level 1 (60 points)
    A haunted mouse?
  • musicwind95 Level 4 Level 4 (1,280 points)
    What happened at Apple? :P
  • ~Bee Level 7 Level 7 (31,120 points)
    music --
    Have you tried your mouse on a plain piece of white paper?
    If it works there, that would indicate that all you need is a new mouse pad.
  • musicwind95 Level 4 Level 4 (1,280 points)
    I have; every time I change a mouse pad (I've cycled through plain white, gray lined, blue lined, a Dell mousepad, and the cheap wood finishing on my desk) the issue would go away for the first few weeks, but then come back (shall I say with a vengeance?)

    Right now, I'm just using the finishing on my desk, which seems to be better than any other mouse pad.

    One thing to note is that with the white paper I had a plastic sheet protector, and then a matte plastic film over it because I hate the feeling of the mouse grating over the paper. I also used the mouse on a smoother type of paper, but both gave the same result.
  • ~Bee Level 7 Level 7 (31,120 points)
    music --

    Have you cleaned the mouse?
    If you have, maybe it's time for a new one.

    (For clarity to others --
    When plain white paper is advised, it means just that.
    No plastic sheets over it. It will mess up an optical mouse.)
  • dylw Level 1 Level 1 (0 points)
    I don't think it is a hardware issue at all, I work in a studio of over 40 macs that are less than 12 months old and quite a few of us are having the issue. I thought that it may have been interference with my graphics tablet, but I have unplugged that to no avail. I also thought it may have been the I.T. department accidentally controlling macs from time to time via ARD, but it couldn't be as it is happening too frequently for the odd mistake.

    I am desperately keeping an eye out for a solution, someone please help.
  • musicwind95 Level 4 Level 4 (1,280 points)
    I've cleaned the mouse several times. Plus, it's only a bit over a year old. I have a four-year-old Dell mouse that works fine.
  • Crobex Level 1 Level 1 (0 points)
    I had the same problem on Leopard and I still have it on SL. My iMac is 6 months old and I have this problem since day 1. The mouse just moves randomly, usually to the lower left corner and this happens 3-4 times a day (every day). I tried cleaning the mouse, using another one and it's always the same thing. Like some people said before it must be a software problem.
  • kisuke3 Level 3 Level 3 (910 points)
    do it in safe boot. Does the mouse jump there?
Previous 1 2 3 4 Next