7 Replies Latest reply: Sep 16, 2009 5:44 PM by adnixon
mrbofus Level 1 (5 points)
I have a 16GB iPhone 3G, with the latest 3.0.1 software on it. The phone is not jailbroken.

All Internet access seems to be working fine; Safari works, all my news apps work, any other app that needs to access the Internet works, Mail works, etc...I can even open the App Store and browse the Featured, Categories, Top 25, and Search sections just fine. However, when I click on Updates, it just sits there, saying "Loading..." until an error message pops up, saying, "Cannot connect to iTunes Store". If I turn off WiFi, the Updates section of the App Store will load just fine over 3G or Edge.

Here's the interesting part: if I change the MTU on my router from 1500 to 1492, I can load the "Updates" section just fine. But then some sites have trouble loading on my Mac Pro that is connected directly to the router. My Mac Pro, MacBook Air, Mac mini, Dell XPS 410, Dell Mini 9, and Palm Pre all have no troubles with the router MTU set to 1500. And my iPhone, as I said above, has no issues, EXCEPT for just the Updates section of the App Store. The Mac Pro, and MacBook Air have just had a clean install [not an upgrade] done of Snow Leopard, and the two Dells have had clean installs of Windows 7. My Mac mini is running Leopard 10.5.8.

Does anyone have any idea as to why ONLY the "Updates" section of the App Store would not work on my iPhone when everything else on the iPhone and on my network function just fine?

Oh, and in case you're wondering, yes, I have tried forgetting my WiFi network, turned off the phone, turned it back on, and rejoined the network. I have also tried doing a restore of my iPhone. The issue still persists.

Thanks in advance!

iPhone OS 3.0.1
  • THansen Level 1 (0 points)
    I noted the exact same problem over the past 24 hours. Any help appreciated.
  • DDAY82 Level 1 (0 points)
    Yep, same exact problem here. Just installed the 3.10 update and I'm still having the problem. I'm curious as to what kind of router you have. I'm currently using my brother's (the only known router I've had a problem with) and it's a Belkin N1. Maybe that's the culprit, maybe not, but it sure as **** is frustrating.
  • adnixon Level 1 (140 points)
    I had a similar issue with a DLink 802.11/n /g Router until the Firmware was updated by the Supplier. Good idea to check that what ever router you are running you have the latest software installed.
  • mrbofus Level 1 (5 points)
    I have a Linksys WRT54G; this issue hasn't been a problem before, and I'm not sure if the 3.0 software update is what borked it. For now, I'm living with the 1492 MTU setting.
  • adnixon Level 1 (140 points)
    Do you have the same issue when connected to a Free Network?
  • mrbofus Level 1 (5 points)
    Nope. Works fine at Starbucks, my WiFi at work, at airports, friends' houses, etc...

    It's bizarre. Logically, the fault should lie with either my iPhone or my router. I haven't changed my router at all. I've updated my iPhone, but everything works fine, including the rest of the App Store; it's ONLY the updates section in the App Store on my iPhone, using my router at home.
  • adnixon Level 1 (140 points)
    Well if it works OK elsewhere then I would be inclined to think that the Router is the point of failure. This is what I would do.... Check the supplier for any firmware upgrade. Then I would be inclined to run a backup on the configuration then reset the router and then power it off and on and then logon as the administrator setup the same configuration as it used to be [backup and restore]. Get the iPhone to forget the network or you can reset the Network Settings/General/Reset/Network Reset which is probably a better option. Power everything OFF [cold start] Power up the Modem first then the router and then the iPhone connect to the network. On the router set the IP lease for the iphone to never expire. If that does not work see if you can borrow another router and set it up at your location and see if that works. Good Luck..