1 2 3 Previous Next 79 Replies Latest reply: Nov 10, 2009 12:17 PM by XP
Sam Brentnall Level 1 Level 1 (0 points)
Any one having problems with WIFI after upgrading to 3.1... I've never had any issue with mine but after the upgrade it cant see any WIFI networks, I've tried restoring and tried it before and after it did restore my data back on and it still doesn't work.

Any one got any ideas?

Macbook, Mac OS X (10.6)
  • 1. Re: 3.1 WIFI Issues
    iphoneowner Level 1 Level 1 (0 points)
    Yes, same here! No wifi, first time it happened!
  • 2. Re: 3.1 WIFI Issues
    Jason L Community Specialists Community Specialists (9,475 points)
    Hi,

    Try Resetting Network Settings on the iPhone by tapping Settings> General> Reset> Reset Network Settings.

    If the issue persists, check for a Wi-Fi address by tapping Settings> General> About.
    If there isn't a Wi-Fi address, try the tips in this article: http://support.apple.com/kb/TS1559
    If there is a Wi-Fi address, try the general tips in this article: http://support.apple.com/kb/TS1398

    -Jason
  • 3. Re: 3.1 WIFI Issues
    Gary Emery Level 1 Level 1 (0 points)
    I can see and connect to wifi networks, but after a minute or two it drops the connection and also it has been randomly asking me for the router passkey to reconnect. This is pretty annoying for me as I don't live or work in a 3G area so I pretty much rely on wifi for a fast net connection.

    I have tried resetting the network settings, but no luck there. I have a valid Wifi address. And the general tips don't seem to apply to me. Other than a fundemental issue with the firmware, I'm stuck as to what the issue could be. Anyone else experiences this and resolved the issue?
  • 4. Re: 3.1 WIFI Issues
    yarin hochman Level 1 Level 1 (100 points)
    I'm having exactly the same issues here. iphone 3G cannot see any wifi networks after putting 3.1

    Tried a clean restore yet no solution.

    Apple lately reminds me of issues typical with MSFT
  • 5. Re: 3.1 WIFI Issues
    krissareann Level 1 Level 1 (0 points)
    Im not currently connected to or in a wifi area so I rely on the 3G network and its not even showing up. I use it at work all day and today its just not showing anything. I have tried resetting the phone by holding the wake and home button but it is still not working...Any ideas or anyone else having the same issue????
    Thanks!
  • 6. Re: 3.1 WIFI Issues
    Sam Brentnall Level 1 Level 1 (0 points)
    Tried all the above, little better, It sees them for a bit but disconnects soon after... only a reboot fixes it but then half an hour later it all happens again!

    Looks like a trip to the Apple Store for me
  • 7. Re: 3.1 WIFI Issues
    Gary Emery Level 1 Level 1 (0 points)
    Please keep us updated if the apple store trip solves your problem.
  • 8. Re: 3.1 WIFI Issues
    Sam Brentnall Level 1 Level 1 (0 points)
    Is there a way to downgrade to the last version? I think its 3.0.1?
  • 9. Re: 3.1 WIFI Issues
    Mike Atwood Level 1 Level 1 (20 points)
    Same here on a 2G. WiFi worked great... until the 3.1 upgrade. Now it will connect for a moment, and then disconnect/reconnect for a few seconds before not detecting the network at all. Manually entering the network name and encryption doesn't work either. Meanwhile my macbook sitting right beside it is connected to the same wifi with full signal and no problems.
  • 10. Re: 3.1 WIFI Issues
    FroggyParis Level 1 Level 1 (15 points)
    For me the signal i use to catch at the gym can't be see anymore on OS 3.1
  • 11. Re: 3.1 WIFI Issues
    theskyking Level 1 Level 1 (0 points)
    my wifi stopped working too after 3.1. What happens now? Apple releases a new version for iphone or we are all just hung out to dry?
  • 12. Re: 3.1 WIFI Issues
    Sam Brentnall Level 1 Level 1 (0 points)
    So, after a visit to the Apple Store, they have swapped it out for a Refurbished

    Came on 3.01, WIFI worked fine. Got home and upgraded to 3.1 and WIFI still works

    Morral of the story, go the Apple Store to get it swapped!
  • 13. Re: 3.1 WIFI Issues
    Kalir Level 1 Level 1 (0 points)
    I don't understand why a problem which occurs immediately after a software update is treated as a hardware problem. Shouldn't there just be some sort of restore procedure that actually does a restore in a way that guarantees the phone will run properly if the hardware is alright? And if the hardware is the problem, why hasn't it manifested prior to now?
  • 14. Re: 3.1 WIFI Issues
    tersono Level 1 Level 1 (0 points)
    Having the same problem here. iPhone can't see wireless networks since I upgraded to 3.1. I've re-booted the airport base (but it's not going to be that - three computers can see it fine). Reset network settings on the phone. I've even done a complete restore (twice - once with a backup, once setting up as a new phone - neither worked).

    The phone is showing that it has a MAC address in Settings/Genera/About.

    Completely flummoxed - was working fine until the upgrade.

    I'd take it into the Apple Store, but the nearest one is an hour's drive and I'm not going to be able to get there for at least 3 weeks.
1 2 3 Previous Next