Skip navigation
This discussion is archived

iPhone 3.1 Won't Sync w/ Exchange

52804 Views 123 Replies Latest reply: Jan 7, 2010 7:54 AM by JRB2 RSS
  • rehab980 Calculating status...
    Currently Being Moderated
    Sep 9, 2009 8:07 PM (in response to cml110)
    Unless there's a fix for this, the only solution would seem to downgrade from 3.1. So far this is the only forum I've found discussing the topic. If a large enough population is affected, Apple should fix it.
  • Jay Selle Calculating status...
    Currently Being Moderated
    Sep 9, 2009 8:16 PM (in response to rehab980)
    I'm getting the same error with the iPhone 3G. It's worked fine with 2.0 and 3.0. Immediately received this error after upgrading to 3.1.

    I've tried deleting the account and re-adding with no luck.
  • Aubrey Laverty Calculating status...
    Currently Being Moderated
    Sep 9, 2009 8:19 PM (in response to daw2010)
    I was having problems getting my contacts & calendar. I fixed the calendar by turning it off and then it slowing synced my stuff when I opened up the calendar app, but my conctacts didn't synce. I tried turning it off again in settings. It still didn't work. Then I turned the phone off by holding the top button and turned it back on. It WORKED! Just a thought to try this. Hopefully it will work for all of you.
    iPhone 3G 3.1
  • Jay Selle Level 1 Level 1 (35 points)
    Currently Being Moderated
    Sep 9, 2009 8:26 PM (in response to Aubrey Laverty)
    We're getting a very specific error message popping up that states:

    "Policy Requirement"
    "The account 'account' requires encryption which is not supported on this iPhone."

    I'm guess that our exchange server ActiveSync policy has encryption enabled and the iPhone ignored this up until 3.1. Since only the 3GS supports hardware encryption all 3G iPhones will no longer sync with Exchange that have this policy option enabled.

    Seems like a mighty big 'oops' we forgot to tell you this would render your company's thousands of iPhone 3G's ActiveSync capability useless instantly.
  • itunes-user Calculating status...
    Currently Being Moderated
    Sep 9, 2009 8:36 PM (in response to Jay Selle)
    I am having the same issue with Sync.

    I had this issue earlier when I tried the 3.1 beta on my phone, and rolled back to 3.0 (which was a partial rollback).

    When 3.1 was officially release today, i thought Apple would have fixed this problem by now, and silly me, i didnt check before updating.

    Now i am stuck again.
    Macbook
  • bcell Calculating status...
    Currently Being Moderated
    Sep 9, 2009 9:11 PM (in response to itunes-user)
    Yep. Same problem here. It's driving me nuts.
    Unfortunately, I'm not sure Apple can solve this. It's up to your Exchange provider to change their settings. My guess is that most security-sensitive IT departments aren't going to be willing to do this. *****.
  • davidg_croydon Calculating status...
    Currently Being Moderated
    Sep 10, 2009 2:28 AM (in response to bcell)
    Same here with me and trying to sync with Exchange Server 2007 at work. I found this..

    http://www.dslreports.com/forum/r22999133-iPhone-31-breaks-Exchange-Sync-for-pre 3GS-phones

    which proves that unchecking the 'require encryption' box fixes the issue. I can't see my work doing that though. How do you rollback to OS 3.0?
    Self-Built, Windows Vista
  • GreggTeHennepe Calculating status...
    Currently Being Moderated
    Sep 10, 2009 2:34 AM (in response to cml110)
    We're seeing this on Exchange 2007.
  • GreggTeHennepe Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 10, 2009 3:59 AM (in response to daw2010)
    I've tried downgrading to 3.0 without success, consistently get a 1015 error and the phone left in recovery mode.
  • bcsef Calculating status...
    Currently Being Moderated
    Sep 10, 2009 6:01 AM (in response to bcsef)
    I tried doing a hard reset (holding down the power button until I got the apple symbol), upon reboot my work email was back. It might work for some people.
    15.4 Mac Book Pro, Mac OS X (10.6)
  • rjain Calculating status...
    Currently Being Moderated
    Sep 10, 2009 6:22 AM (in response to cml110)
    Tried the hardboot but still having the same problem. The error message that I get says "The account <email address>" requires encryption which is not supported on this iPhone"
    iphone
  • davidg_croydon Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 10, 2009 6:32 AM (in response to rjain)
    Reboot didn't work for me either. My company are having a debate as to the security of switching off that setting.

    The annoying thing is that I've now now no contacts in my Phone book as I was using my Corporate Contacts as my Contact list.
    Self-Built, Windows Vista
  • GreggTeHennepe Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 10, 2009 9:27 AM (in response to daw2010)
    A couple of points of clarification based on further reading:

    Non-3GS phones which have been upgraded cannot be downgraded without jailbreaking because both the OS firmware and baseband firmware are upgraded, and there is no way short of jailbreaking to downgrade baseband fireware (this is the firmware that manages the cell radio/modem). The normal downgrade process only affects the OS firmware. I have seen claims that the 3.0 OS will run on the newer baseband, but it didn't work for me.

    One possible albeit very limited workaround is to setup another mail account for IMAP access to the Exchange system (assuming that service is running). This doesn't help with calender and contacts, though.

    We have an emergency call into the SE for our account, but haven't heard anything.

    It seems to me Apple has several options:

    1) Provide a method for downgrading baseband so that folks can revert to 3.0.1 (seems unlikely).
    2) Release a patch reverting to the pre-3.1 behavior, which would be bad for security.
    3) Release a patch which offers non-3GS phone owners the option of explicitly ignoring the ActiveSync Policy, which would also be bad for security, but would make the choice an explicit one by the users. This is bad for orgs who want to be able to centrally enforce security policies.
    4) Tell orgs they need to upgrade to 3GS phones if they want Exchange support. This seems near suicidal for them in the enterprise market.
    5) Tell orgs they have the option of disabling the encryption requirement on the Exchange side. This is bad because it affects all handhelds, not just iPhones.

    I'm very interested to see how they handle this.
  • tschangrx7 Calculating status...
    Currently Being Moderated
    Sep 10, 2009 9:43 AM (in response to daw2010)
    I have a 3GS with Exchange Sync problem as well since upgrading to 3.1
    Inbox keeps saying Connecting, Checking for Mail....Updated, but it does not download new messages. I've tried deleting/re-adding the Exchange acct but same problem in the end. Strange thing is that other folders (i.e. Sent folder) are updating fine. How do I put 3.0.1 back?
    DELL, Windows XP Pro, MAC
  • jensbirk Calculating status...
    Currently Being Moderated
    Sep 10, 2009 9:44 AM (in response to daw2010)
    I'm having the same problem - but I also are facing the message, that the phone can't activate the celular data network... I have to set ANP in settings/network/cellular datanetwork before I can reseive mails from the exchange...

    Jens
    iMac/MacBook Air, Mac OS X (10.5.7), iMac 24" intel
1 2 3 4 ... 9 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.