14 Replies Latest reply: Nov 14, 2014 11:03 AM by Finder alum
jenniferp417 Level 1 (0 points)
I have three computers in my home, three different itunes accounts. All authorized with each other. I can view and play songs from other libraries, but there's no import button on any of them, as I understand there should be.

All computers have Itunes 9. Two are XP machines, one is Leopard.

What am I doing wrong?

Imac, Mac OS X (10.5.8)
  • BillF Level 3 (645 points)
    I just used drag and drop and it seemed to work just fine.
  • jenniferp417 Level 1 (0 points)
    That does nothing either.

    I know this has to be something simple, but I'm stumped.
  • Lauren L. Level 3 (910 points)
    Did you set up the home share using the same ID on all of them? I learned that earlier today, even though they are all authorized, you have to use the same account on each one to setup the Home Share. It won't change your buying methods, just sets up the share.
  • jenniferp417 Level 1 (0 points)
    That is exactly it.

    For anyone else reading this - I just went in to the advanced menu and turned off home sharing. Then I went back in and turned it back on - I chose the user/pass of another one of my computers, then clicked into that library - and the buttons I needed were immediately there.

    I knew it'd be easy, if I knew what to do. Thanks so much!
  • richard grant Level 3 (695 points)
    I'm having the same problem. But both of my computers are logged into the same iTunes account, both are Macs, both have been updated to iTunes 9. One is running OSX 10.5 and the other 10.4. Current versions of Quicktime, etc.

    Drag-and-drop doesn't work either.

    Any ideas? Thanks!
  • northerndancer64 Level 1 (0 points)
    Same issue.

    Advanced/Disable home sharing

    on each computer

    Advanced/Enable home sharing

    on each computer

    and it will eventually set up properly.
  • jpmoriarty Level 1 (0 points)
    My home sharing network drive (the hopeless western digital my book world edition "piece of junk") is sharing the music fine, but I can't copy music from that drive to any other computers through iTunes (and consequently can't add them to ipods etc even though it's not apple songs).

    I don't think I can set an itunes account on the my book itunes server (which I think is Twonky - yet another piece of junk) - so can I do the import / copy thing or do I have to do it through copying the files through windows explorer?

    basically the import button doesn't show up, and attempts to drag and drop files fail miserably.
  • mdpatsfan Level 1 (0 points)
    Lauren, your the woman. A year and your post helped me out. Many thank you!
  • Nicque Level 1 (0 points)

    Turning homesharing off and then on (in Advanced) eventually worked for me (I couldn't get it to work for a couple of hours).  It finally did the trick, though!

  • texn Level 1 (0 points)

    Thanks so much for that EASY answer. I have looked all over for the answer to why I couldn't import songs from a shared library (including no import button) and here is the answer. I see I'm not the only one thanking you for this!!! THANKS!!!!

  • yeseniafromastoria Level 1 (0 points)

    Thank YOU!!!! I had the same problem and the button is now there.  Thanks so much.  For all of you out there on Windows 7 PC's this will work for you.

  • 4345 Level 1 (0 points)

    very nice, thanks

  • DustinV2013 Level 1 (0 points)

    Toggling home sharing off and on resolved the issue with Home Sharing between Windows 7 and Windows 8 machines. The "Import" button did not appear initially but after turning home sharing on and off a few times it finally appeared in the bottom right.

  • Finder alum Level 1 (0 points)

    I had this, also, but your trick didn't work for me, so I'm posting for anyone else reading this thread. To solve the problem, I had to go to iTunes Preferences->Sharing->Share my library on my local network (on all computers), and switch that off. Then I turned Home Sharing back on everywhere and it started working.

     

    (Make sure you give the same iTunes account on all computers when turning on Home Sharing.)