Previous 1 9 10 11 12 13 Next 949 Replies Latest reply: Aug 20, 2015 1:04 AM by Peter D Cox Go to original post
  • Michael Boylan Level 1 Level 1 (60 points)
    Yep, add me to the list with the problem too

    I've a Samsung 1TB drive in an Icy external drive enclosure, USB. I have it in two partitions. When my iMac 27" wakes up I get the famous "The disk was not ejected properly......" message.

    Following advice on these boards I've disabled "Put drives to sleep when possible" and it worked for a few days but now I'm getting the not ejected properly messages again.

    Even worse I'm getting messages from TimeMachine telling me the last backup failed because of folder problems.

    Some times the partitions remount after waking, some times they don't. Some times only one mounts. Increasingly I have to Restart to sort it out.

    All in all not a very satisfactory state of affairs and certainly scary to be happening to backups. I need a backup strategy I can trust and I don't know where to turn to next.
  • diminicot Level 1 Level 1 (0 points)
    Just something to check, do you have it powered in a strip with power saver feature sockets. These are designed to power off to save electricity like phantom power when detected not in use. May be shutting off power to the TimeMachine drive unexpectedly.
  • Jonathan Clark Level 1 Level 1 (5 points)
    After the last OS update I re-tried the 'unplug, replug' steps described earlier. This time I've been up with no problem for over 24 hours. Fingers are crossed.
  • Michael Boylan Level 1 Level 1 (60 points)
    Since posting above I reformatted the disk and took it off my hub giving it its own direct connection to the iMac using a high quality LaCie cable. I ran two complete backups but started to get the same error message again.

    Resigned to having to 'put away' the drive every time I did just that but the next time I switched the drive on to run a backup it only stayed mounted for about fifteen seconds. TimeMachine had just started backing up and the drive unmounted itself.

    Now I can't get it to mount - it looks like it's toast.

    Arrgh.
  • GFX-Printing Level 1 Level 1 (0 points)
    I just finished battling the same issue. It occurred after the most recent OS update this week. Actually, I had been avoiding updating the iWeb stuff since none of it is relevant to us here ... and as soon as it was updated, I kept getting the darn external eject error message.

    After trying a number of things as everyone else has suggested (ports, power supply, other computers, cables, etc) all to no avail ... or would work for short bursts ... I decided to try connecting the external to the keyboard's USB port (which I know is a big no-no), it worked!

    My conclusion is that by-passing the OS works.

    I'm now in the process of moving all the files and will reformat it to see if that solves the problem.

    Stay tuned to see if that's the ticket ...

    If it does work, then it has to be an OS issue.
  • GFX-Printing Level 1 Level 1 (0 points)
    Update
    =====

    After formatting the external through the keyboard's USB port, I plugged it back into the hard drive and all is well in external hard drive land <keeping fingers crossed>.

    If it's not an OS issue (although I suspect it is), it could have been a corrupt file (or files) prohibiting the OS from displaying all the files and folders on the external.

    As an endnote, I don't use Time Machine or any other program for backing up ... just drag and drop. I also skipped the journaling of the external as well.

    ... now I need to try this on all the externals collecting dust to see if this works as well.

    I hope this helps someone else!

    Barb
  • William Boyd, Jr. Level 6 Level 6 (10,515 points)
    GFX-Printing wrote:
    I don't use Time Machine or any other program for backing up ... just drag and drop.


    What are you backing up that way? Drag and drop can work well for a user's own documents, but doesn't preserve permissions and ownership of system files, so it's difficult to restore those to their original state.
  • GFX-Printing Level 1 Level 1 (0 points)
    2nd Update
    ========

    Well it was a short-lived victory ... as soon as I try to transfer files to the newly reformatted external, it ejects again after a few minutes.

    At least I can use it through the USB keyboard port when I need to access the files ... it's not optimal, but for the short term I haven't lost any data or lost a lot of time thankfully.

    Barb
  • Titans_Fan Level 1 Level 1 (0 points)
    Count me in this group too...my Seagate 500gb external drive is ejecting itself. I just bought this iMac a few months ago and connected my 2yr old external drive to it. It has ejected itself several times since then. I can't attribute what it's doing to anything I've been doing. It's a mystery. I hope Apple or someone can think of a remedy.
  • jamesj109 Level 1 Level 1 (0 points)
    I've tested most of the external drives I have at home across two different Macbooks (2.4 C2D & 1.83 CD) both running 10.6.5. Here are my results on both computers:

    *SIIG Cool Dual SATA to USB 2.0 Dock* (self powered)
    · Toshiba  Branded 60GB SATA 2.5" Drive (ejects automatically) Never used with TM
    · Seagate Momentus 500GB SATA 2.5" Drive (ejects automatically) Never used with TM
    · Seagate Barracuda LP 1.5TB SATA 3.5" Drive (ejects automatically) Used with TM

    *Hitachi USB 2.0 Drive Enclosure* (self powered)
    · Seagate Barracuda LP 1.5TB SATA 3.5" Drive (ejects automatically) Used with TM

    *Vantec NexStar TX USB 2.0* (usb powered)
    · Seagate Momentus 500GB SATA 2.5" Drive (maintains connection/data transfer) Never used with TM
    · Toshiba  Branded 60GB SATA 2.5" Drive (maintains connection/data transfer) Never used with TM

    *Lacie Porsche USB 2.0* (self powered)
    · Stock 500GB drive (maintains connection/completed TM Backup) Used with TM

    In all situations I've tried connecting the enclosures directly to the computer and through a 20" Apple Cinema Display.

    I thought the issue had to do with Time Machine or my partition scheme on the Seagate 1.5TB. These problems started when I repartitioned the drive to allow for TM to take over one of the partitions. During the first TM backup the disk ejected. So I used Disk Utility to remove the added partition (creating 1 partition) and the disk ejected during this process. Since then, I haven't been able to use 2 out of 3 of my self powered enclosures/docks without the disk ejecting. It certainly feels like an OS issue.

    I hope this data helps someone find a fix... I would like to use the 2TB of space I have available.
  • MAbifarin Level 1 Level 1 (0 points)
    Just the facts.
    On the Friday after Thanksgiving, I went out to buy a new Time Machine back up drive. I settled on the 2TB Seagate Free Agent GoFlex Desk (USB 3.0/2.0 base). When I went to check out, the price was so awesome, I bought two. I came home, plugged them both in, (USB direct into the computer) reformatted them both (Mac OS extended, Journald, with one GUID partition). I set one up as a Time Machine backup drive, and moved my iTunes library to the other drive to free up space on my internal drive.
    Since then, the Time Machine drive has been periodically, and seemingly, randomly, ejecting it's self and then plugging it's self back in. I've been getting the "The disk was not ejected properly..." notice on screen but without doing anything, the icon shows back up on the desk top, at first with the orange USB drive icon, then after a few seconds, it switches to to the Time Machine icon. Everything seems to be working fine, Time Machine is reporting no errors, but, this constant and unpredictable in and out is concerning me. I have read every post in the thread and have tried many of the solutions but nothing seems to work.
    Has anyone with this problem actually come up with a permanent solution?
  • Michael Boylan Level 1 Level 1 (60 points)
    MAbifarin wrote:

    Has anyone with this problem actually come up with a permanent solution?




    Yes. I've disconnected my USB drive and packed it away in a drawer and replaced it with a LaCie FireWire drive with external power brick. So far (touching wood) it is working as intended - not one self-eject. I'm still so spooked from experiencing this problem on several drives (USB external and USB dock) that I don't yet trust the LaCie despite it seeming to work perfectly. What I do now is mount it, run my backups and then dismount it.

    BTW doing a complete backup on the FW drive was exactly half the time as any of the USB 2 drives I've had recently. Just shows you despite similar claims for throughput speeds FW still whips USB 2.
  • jamesj109 Level 1 Level 1 (0 points)
    UPDATE:

    So far the following combo hasn't ejected on its own.

    *Hitachi USB 2.0 Drive Enclosure* (self powered) - Attached through Apple Pro Keyboard.
    · Seagate Barracuda LP 1.5TB SATA 3.5" Drive

    I'll keep my fingers crossed, but for now it seems to be a work-around that's worked for a couple other people in this discussion.
  • MAbifarin Level 1 Level 1 (0 points)
    Thanks guys, I've seen tons of workarounds, but no answers to the question. The stubborn side of me wants to know why Time Machine on some external USB drives isn't working as advertised. The practical side of me thinks that if I buy the FireWire 800 base for my GoFlex TimeMachine drive, I will not have anymore problems. I think, in this situation, I'm going to forgo answers and understanding, and let my practical side win. I will buy a FireWire base and cable, and keep my fingers crossed.
  • MAbifarin Level 1 Level 1 (0 points)
    Got the FireWire 800 base. Hooked the TimeMachine drive through FireWire. Still have the problem
Previous 1 9 10 11 12 13 Next