Skip navigation

Disk Drive ejecting itself

292116 Views 907 Replies Latest reply: Mar 27, 2014 7:57 AM by Pauleduc RSS
  • Luke Murphy1 Level 1 Level 1 (35 points)
    Currently Being Moderated
    Oct 20, 2009 10:00 AM (in response to judithnewman)
    Same issue here too with my external USB Time Machine drive since installing 10.6. It doesn't seem to happen consistently on sleep and does not seem to be related to the screen saver.
    Mac Pro, Macbook Pro, Mac OS X (10.6.1)
  • Gimbo Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 20, 2009 1:08 PM (in response to kjw97)
    Having recently upgraded to 10.6, I thought the spontaneous ejecting of my Time Machine drive was due to a software problem. I've now switched back to the original USB cable (having tried using the much longer one that came with my camera), and the drive is staying mounted. Presumably it wasn't able to draw enough power over the camera's USB cable.

    Thanks, kjw970!
    MacBook 2 GHz Intel Core Duo, Mac OS X (10.6.1)
  • kjw97 Level 1 Level 1 (15 points)
    Currently Being Moderated
    Oct 22, 2009 5:14 AM (in response to Gimbo)
    No worries, glad I could help.
    MacBook Pro 17", Mac OS X (10.6.1)
  • s1owmo Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 22, 2009 7:00 AM (in response to kjw97)
    I have also been having this problem, this Lacie 1Tb has been driving me nuts. I'll admit kjw970's solution sounded crazy but I switched up the long USB cable with the short cable that came packaged with the drive and now I can sleep my computer every time without the drive dismounting.

    THANKS kjw970!
    MBP, Mac OS X (10.6.1)
  • Tipton Grange Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 28, 2009 6:36 AM (in response to judithnewman)
    I have the same problem. But, I think it's happening because there's a bad sector somewhere on the disk, and it's crashing when it tries to access that sector. When I use Disk Utility to erase the disk and zero out the data, which is supposed to mark off the bad sectors, it fails to complete the task and disconnects the disk.

    I'm using OS 10.6.1. Have any of you with 10.5 tried erasing the disk with the zero out security option to see if that works?
    MacBook Pro, Mac OS X (10.6.1)
  • Allan Eckert Level 8 Level 8 (39,360 points)
    Currently Being Moderated
    Oct 28, 2009 7:38 AM (in response to Tipton Grange)
    Hi Tipton Grange;

    What error is it returning to you?

    Allan
    tiger
    MacBook Pro, PowerMac G5 Quad. iPhone, Mac OS X (10.5.8), 7800 GT, 6.5 GB RAM, 440 GB, Nikon N80, D70 and D300 Nikon Coolscan 5000ED
  • Tipton Grange Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 28, 2009 8:18 AM (in response to Allan Eckert)
    It starts with "Preparing to zero disk", then "Writing zeros to disk. Estimated time: 3 hours", then after 3 minutes I get the error; Volume Erase failed with error: Disk object invalid or unable to serialize.

    Furthermore, I get a second error message from the system "The disk was not ejected properly. If possible, always eject a disk before unplugging it or turning it off." and the entire drive is disconnected from the computer. (I have 3 partitions on the drive. Two of the partitions work fine, but the problems occur with the third.)
    MacBook Pro, Mac OS X (10.6.1)
  • Ross Meador Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 28, 2009 8:52 AM (in response to judithnewman)
    I have read the many interesting attempts to solve this problem, but none seem to work for me. I am using the short cable that originally came with my Simpletech drive and I am not using a hub. There is no evidence that a bad sector is causing the problem. Sleepmode apparently acts to disconnect the drive from my Macbook, and it then reconnects upon waking, albeit with a warning that the drive was not properly disconnected.
    MacBook5,1 2.4 GHz; 4, Mac OS X (10.6.1), 1TB SimpleDrive II USB Ext HD
  • opiekelly Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 29, 2009 7:44 PM (in response to judithnewman)
    Any news from Apple? I too have an external USB drive that has a problem after system comes out of sleep mode. It is connected with a very short USB cable and no USB hub. I have not had data loss or corruption issues to date.
    iMac, Mac OS X (10.6.1), Western Digital My Book 320GB
  • s1owmo Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 30, 2009 8:32 AM (in response to opiekelly)
    No news yet, my problem still exists only now it doesn't instantly wake my computer after I sleep it, which is better. Oft when I wake it I get the Disconnection notice.

    Message was edited by: s1owmo
    MBP, Mac OS X (10.6)
  • kokp Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 16, 2009 9:07 AM (in response to judithnewman)
    I have this problem, and no solution. The drive ejects itself as soon as it mounts. I have a lot of work stored with no access to it.

    It happens on both my Macbook Pro 15.4" Early 2006 model, as well as the iMac 7,1. External enclosure is an Akasa Integral SATA connected through USB. I had no problems with Leopard.
    iMac 7,1 and Macbook Pro 15.4" Early 2006, Mac OS X (10.6.1)
  • cejones Calculating status...
    Currently Being Moderated
    Nov 25, 2009 7:45 AM (in response to Glen Carpenter)
    I have an external HD in an external Acomdata enclosure (with its own power supply) and when I am cpoying files to this drive, it eventually disconnects as described by everyone here... At first I thought it was my drive, but now I am starting to think it is this 10.6.2 since this never happened before.

    Chris
    iMac, Mac OS X (10.6.2)
  • Quinnetic Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 1, 2009 12:23 PM (in response to judithnewman)
    I am having the same problem, with the original cable, w/ and w/o a hub, only on 10.4.11, on a PPC, which makes me think that maybe it is related to the latest updates to OSX in general, not to snow leopard in particular. Also, mine ejects randomly, sometimes while I am using it, not only on sleep mode. Sometimes it will eject and immediately re-attach, and other times I have to restart my computer.

    The problem is, I can't afford to lose the data on the drive as I am a web designer, and have ongoing projects on it - and my Mac Mini HD is no where near big enough to store all the data on my drive (over 1/2 TB). So I can't try to wipe it and start over.

    After it ejects, if I plug it into another computer, it loads up the drive (all 3 partitions) just fine. If I try plugging it back into the Mac Mini (w/o restarting the comp) it won't work. If I try turning it off and back on via the switch on the back, no luck. It must be an OSX issue, but I have no idea what.

    Any word yet from Apple?
    Mac Mini G4, Mac OS X (10.4.11)
1 2 3 4 5 ... 61 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (23)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.