Previous 1 29 30 31 32 33 Next 949 Replies Latest reply: Aug 20, 2015 1:04 AM by Peter D Cox Go to original post
  • deelievense Level 1 Level 1 (0 points)

    I Have had this disk ejection problem with USB pen sticks, USB cableDrives and i honestly conclude that it all began with Snow Leopard...In fact i have found more bugs in Snow Leopard than a holiday in GranCanaria in a cheap apartment. Nothing on it seems stable, I am alsogetting Console messages that go on for weeks with endless jargon aftercrashes, and i spend most of my time waiting to reboot my musicprojects... The Fact Mac are now using PC chips says it all..... shouldhave bought a PC instaed of a £2500 mac... not to mention i could havebought a pc for £600 and ran Crash Leopard on it anyway....

  • deelievense Level 1 Level 1 (0 points)

    Im Sure rushing OS Loincloth out the door instead of addressing the existing bugs will be the order of the day since Mac are now turnig into macrosoft, the clues started when the I bought an iphone 4 with an ariel that you cant touch with out the phone cutting out.. GENIUS!

  • iMac39 Level 1 Level 1 (0 points)

    Well.. here is my update.


    I am still using the same WD MyBook 500 GB HD as my Time Machine backup.  However, I have replaced the USB cable with the shortest one I could find:  a StarTech 1 foot cable, measured from one connector end to the other (The actual cable length is about 8 inches) ref:


    I have the unit plugged into a UPS, the same as my iMac.  The system was recently upgraded to OS X Lion.


    I completely erased the external HD, and formatted it (Mac OS Journaled), then fired up Time Machine.  After backing up about 25GB, the drive self-ejected.  It automatically reconnected a few moments later, only to eject once again. It repeated this again. Finally, I turned off Time Machine, and decided to erase and reformat the drive.. however, now it is constantly ejecting and I can not even erase and reformat it.


    And all this is with a 1 foot cable and the new Lion OS.  So, two of the suggestions mentioned here obviously do not work for me.  Oh, and btw.. should I also mention that I previously opened the WD MyBook and replaced the original WD HS with a Seagate HD, because the WD drive was so trashed it was totally unrecoverable.


    Looking for any further advice to fix this problem.. thanks!

  • Richard E. Cooke Level 2 Level 2 (220 points)



    If your drive is re-connecting by itself, then you have a different problem than what we are discussing in this thread.


    The problem we have the drive "ejects" and stays that way unitl it is power-cycled or un-plugged and re-connected.


    For starters, puting a non-WD dirve in a WD enclosure its not reliable - unless WD tells you to do it.


    Startech makes good cables, your OK to use any length they make that they certify is USB 2 compliant - no need to suffer along with a 1" cable!


    I need more information, but the first step is to find out if your Seagate drive is expected to work in the WD enclosure you have it in.  For that you have to search the web for the two part numbers to see if anybody else has tried what you did and it works.  If you post the model numbers here, I'll do the reasearch for you when I have time.


    If you leave the computer and hard drive OFF for a few hours - especially in a cool room - does it work for 10-15 minutes or more before it auto-ejects?


    I posted a generic debug procedure as part of an ealier message here:

  • Andy2006 Level 1 Level 1 (0 points)

    If your drive is re-connecting by itself, then you have a different problem than what we are discussing in this thread.

    The problem we have the drive "ejects" and stays that way unitl it is power-cycled or un-plugged and re-connected.



    Disagreed. When I was having this problem, my drive would constantly eject and then re-connect randomly. That may not be what you're talking about, but it's what I've been talking about since I joined this discussion.


    That's a moot point, though. I have not had a single random eject since downgrading the two USB kexts to the older versions. I've been holding off on applying the latest SL software updates because I don't want to have to go through the kext downgrade again, as the problem clearly hasn't been resolved.


    Wondering if anyone has tried Lion + the kext downgrades? Does that work?

  • Richard E. Cooke Level 2 Level 2 (220 points)



    I can't find your posting of your symptoms and results.  When was it?


    Can you post a link for me?  Or just what "page" its on.



  • Andy2006 Level 1 Level 1 (0 points)

    Nah, I'm not going back through this post to look for it. Plus, as I said, my problem has been solved by downgrading the kexts. The problem is not with my drives or cables or the temperature in my office or the position of the sun in the sky relative to Apple's corporate offices. The problem is within OS X, as evidenced by the fact that going backwards from the current-version USB kexts to the older-version kexts solves the problem and doesn't create any new problems.

  • Richard E. Cooke Level 2 Level 2 (220 points)

    Um, not exactly.  Back around page 25 of this thread we found a pattern.  One, maybe two, specific USB interface chips (that go inside the drive's enclosure) that handle the data transfer over USB and convert it to IDE or SATA (depending on the drive) that will auto-eject under heavy WRITE load.


    For the one chip I had, 10.6.8 seems to have fixed it.  I say "seems" because in testing I discovered the problem does not occur using my drive with USB 3 or SATA, so I switched it to a machine with those interfaces.  I did bring it back to my MAC for one test and it passed. 



    All of the other postings in this thread lead to hardware or user problems.  Mind you there are a bunch of people that have failed to post enough details for me to analyze what happened.  So maybe they have the known bad chips, maybe not.


    Did you post under "Andy2006"?  Its odd that I can't find it.  Usually the system will give me a list of all your posts so I can easily round all the info up.

  • Andy2006 Level 1 Level 1 (0 points)

    Honestly, I'm not sure what it's under. I've had several different AppleIDs and it's either not possible or so difficult that it might as well be impossible to combine them into a single account. So it could be under any of a number of user IDs.


    How I got here, for what it's worth, is that my Drobo (connected via USB directly to my Mini) started randomly ejecting and re-connecting a year or two back. I found a solution online somewhere (reverting to old kexts) which solved the problem.Then, some time later, I apparently let the Software Update feature update OS X, and the random disconnects started happening again. I searched for the solution (again), and found both this post and the original kext-reverting solution.


    I downgraded the kexts and found that it worked (again), so I posted that solution here. FWIW, before downgrading the kexts, I had the exact same issue on three separate drives: the Drobo, a WD 320GB passport plugged into a powered USB hub, and an 8GB thumb drive plugged into the same powered USB hub. All of these drives performed without issue on the PC right next to my Mac.

  • Andy2006 Level 1 Level 1 (0 points)
    Did you post under "Andy2006"?  Its odd that I can't find it.  Usually the system will give me a list of all your posts so I can easily round all the info up.

    Turns out I did. Check P24 of this thread for my original posts, including the USB chip information that you asked for.

  • tingotanca Level 1 Level 1 (0 points)

    Not quite related to this thread, but I've had the same problem with Apple IDs. After being driven crazy trying to resolve things myself, I got in touch with Apple's support and found them to be very helpful in this particular case (for other issues, I'm still waiting for a reply – any reply – to repetaed requests). They are actually in a position to manually configure IDs, mail adresses etc., once they've determined that you are bona fide.




    Message was edited by: tingotanca

  • Ian Downie Level 1 Level 1 (25 points)

    I've had this dismounting problem since I had the main logic board of my 24" iMac replaced in the local Applestore a few months ago. It happens with all my USB and Firewire external drives, which dismount spontaneously about 15 minutes after being mounted. Occasionally, I get the 'drive disconnected improperly' error message but mostly I don't. My original Time Machine backup drive (3 years old) is now scrap and will not mount at all; the replacement drive (in the same Wiebetech enclosure) is working but suffers the same dismounting problem. I have a total of three USB 2.0 drives and two Firewire drives, plus a USB 2.0 SATA drive adapter for bare drives. All have the same problem.


    The dismounting problem does not happen with the same drives connected to my MacBook Pro using the same cables. I have tried reinstalling Snow Leopard (now at 10.6.8) and logging in from a new account, without any success. I installed Snow Leopard on a brand new external drive in a bare SATA drive adapter and booted from that - same result. It makes no difference whether or not I connect the USB drives through a hub.


    I have tried every solution mentioned in this thread without success but have found a workaround, which depends on having another Mac so will not work for everyone: share the screen with the other Mac using Screen Sharing. As soon as I log in with Screen Sharing, the attached drives remount and stay mounted as long as the Screen Sharing session is active. By the way, that is the only way I have found to remount the drives other than by switching them off and on again or rebooting. Ten to fifteen minutes after closing Screen Sharing on my MacBook Pro, the drives connected to my iMac dismount again. Just connecting to the drives over the network (they are shared) is not enough to keep them mounted - I need to connect using Screen Sharing. I also have LogmeinIgnition - that doesn't work.

  • macdim Level 1 Level 1 (0 points)

    I've since had this fixed.


    It was purely hardware for me. Try swapped my logic board which fixed the drive ejecting issue but the new board had a sound problem so they just swapped my mid 2010 corei3 iMac (midrange) with a top end current model corei5 of the same screen size.


    New system has NO problems whatsoever.


    Hope you all sort out your problem but I fear it is likely a logic board issue for most people.

  • Kari Lassila Level 1 Level 1 (5 points)

    That's an AWFUL lot of different machines that would fall under the logic board theory. A good number out of warranty as well.

  • Ferenc.Szakacs Level 1 Level 1 (0 points)

    I bought a brand new 1 TByte WD external hard drive and I met two problems:


    1) My Mac was not able to write on the disk

    2) The extenal HDD was ejecting unexpectedy at different moments but at least once in 5 minutes. Even more the WD utility was sending messages telling that the HDD is in use and and cannot be ejected.


    I found the following solutions:


    1) I erased the external HDD with the utility supplied by WD. From that time on I could write on the disk.


    2) I uninstalled all WD utility programs from my Mac using the Uninstall utility given by WD. I left the external HDD running for 12 hours and it did not disconnect any more.

Previous 1 29 30 31 32 33 Next