Previous 1 30 31 32 33 34 Next 940 Replies Latest reply: Apr 21, 2015 3:54 PM by Sasha_yu Go to original post
  • GaryCoyne Level 1 Level 1 (0 points)

    The one issue I'm not seeing here is that in addition to drives self-ejecting themselves, i also have the issue/problem that after a period of time from a restart, I can access the data from a drive but cannot write to the drive. To be able to write to the drive I have to Force Eject the drive, pull the power to shut it down, and then re-insert the power to restart it up so it can once again mount and then I can write to the drive.

     

    Anyone?

     

    Other than that, I have two towers, one older tower at work and a newer tower at home. The newer one seldom self-ejects, but does. The older one self-ejects often, but certianly not as bad as some of you I'm reading. None the less, this happens to me with flash drives, USB external portable drives, FW external desktop backup drives, you name it, it's self-ejected.

     

    Sigh...

  • Kelly Davis Level 1 Level 1 (15 points)

    This (https://discussions.apple.com/message/13275300#13275300) worked for me, with the exception that kext helper b7 backed up the kexts, removed them from /System/Library/Extensions but did not actually copy the 10.6.4 kexts. When I rebooted, the mouse and keyboard were not working. I sshed into the machine and manually installed the 10.6.4 kexts and then rebooted. After that, the time machine backup completed without an ejects. So, I guess my recommendation is don't use kext helper, just backup and copy the kexts manually from the command line.

     

     

    2010 Macbook Pro - 10.6.8

  • Martin Harries Level 1 Level 1 (0 points)

    We have a LaCie FireWire disk on an iMac purchased in May 2011. We had the problem of the disk seeming to eject itself. From a comment I found on mac-forums.com:

    http://www.mac-forums.com/forums/os-x-operating-system/199458-disk-not-ejected-p roperly-warning.html

     

    we seem to have resolved the issue on our machine currently running 10.6.8.

     

    We ejected the Lacie drive using Disk Utility using a button on the Disk Utility top menu bar. Then we turned off the drive and turned it back on. We then ran Time Machine which ran extremely fast and did the job, just like there was no problem. So, for now, it seems that ejecting the disk via Disk Utility does a more thorough job somehow than simply powering off the Mac. <shrugs>

  • spkane00 Level 1 Level 1 (0 points)

    I finally fixed my USB drive ejecting problem, by breaking down, and doing a clean install of Lion on my iMac. The problem complete vanished. I made the mistake of installing the Seagate Drivers on the new system and things immediately started to go bad again. I manually removed them and rebooted and all was good again.

     

    Anyone who is really experiecing pain with this issue and hasn't tried a fresh install, this might be the best option. It certainly will verifying if the issue is actually a combination of the hardware and the Apple supplied OS or some other 3rd party software.

     

    Sean

  • userremoved Level 1 Level 1 (0 points)

    Just out of curiosity, has anyone had this "ejecting" issue occur with hard drives smaller than 1 TB in size? I have had no absolutely no issues with my 500 GB hard drive ejecting, yet my 2 TB hard drives will constantly eject.

  • tingotanca Level 1 Level 1 (0 points)

    @gavnone: I had the problem with a 1Gb USB key plugged in my keyboard, as well as with a LaCie 1Tb Firewire drive like Martin Harries's above. More details in my previous posts (search for both "tingotanca" and username "tingo@tanca.com" – not a valid address).

     

    Message was edited by: tingotanca

  • GaryCoyne Level 1 Level 1 (0 points)

    I've had this happen to flash drives smaller than 250 MB to 8 GB, I've had this happen to card readers getting images off of my camera's card, I've had this happen to external hard drives from 500 MB to 2 TB.

     

    I've had it happen continuously for weeks to months on end and then the problem goes away for weeks to months.

     

    I think that covers it.

     

    Gary

  • brian273 Level 1 Level 1 (5 points)

    I had this problem with an ejecting external disk for nearly five months and it inexplicably resolved itself after godknows how many attempts at mounting the external disk. I'd actually given up on it and thought the ext disk ruined when I tried again for a laugh last month and to my surprise it did not eject but took nearly 15 mins trying to read the disk before throwing up a message saying the disk was not in Mac OS Extended (Journaled) format. But for the first time in months, I managed to access my precious data on the disk, transfered it to the harddisk, formated the external disk and have not had a problem with it since, and Time Machine works perfectly. This will not be helpful, I know, but thought I should share the info, for those blessed with sharp technical brains.

     

    Something that may be woth noting: my success came a day after I connected my new ipod (had not had one for 2yrs). When I connected the new ipod for the first time, it was spontaneously ejected twice but was accepted and synced on the 3rd attempt. I'm sure Apple will propose that you all buy new ipods to make this problem go away!

  • userremoved Level 1 Level 1 (0 points)

    After re-installing my OS (Lion) the "ejecting" issue seems to have resolved itself.

  • jay4190 Level 1 Level 1 (0 points)

    I was having the same problem with my WD Passport 500GB USB drive and my 2008 Macbook.  It would automatically eject after anywhere from 5-15 minutes, not allowing me to complete a large file transfer or a Time Maching backup. 

     

    After going through lots of threads and racking my brain, I ended up uninstalling the WD software that came with the drive, then restarted.  Seems to have fixed the problem for me.  I've been doing a TM backup and large file transfer for about 30 minutes with no ejecting. 

     

    Also, FYI, I did have the WD Software set to "Never" for the sleep function.  Not sure if it's a bug or what, but hopefully this helps you other folks with WD issues. 

  • GaryCoyne Level 1 Level 1 (0 points)

    Sorry, but not have an issue for 30 minutes does not mean your problem is solved. I've gone for months with no issues and then I'd have problems continuously for weeks or months.

     

    Because of all this variability, I can understand why Apple is having problems with this, but it does seem to be a problem that does exist in various OSs, (at least X.6 and X.7), and does exist on most models, but does not show up all the time and anything from re-installing the OS to installing new drivers, to swinging cats over your head all seem to "solve" the problem-------until it shows up again.

     

    Gary

  • jay4190 Level 1 Level 1 (0 points)

    Point taken.  However, it's now been several hours and I've been able to move all my large files and do a full TM backup without the drive shutting down.  So for me, it's fixed considering I wasn't able to keep the HD active for more than 15 minutes before (rendering the HD useless).  Whether or not the problem returns remains to be seen.

     

    Just passing along the info for others in case it helps them. 

  • oscarfromguilford Level 1 Level 1 (0 points)

    Just to add my experience to the pile of disparate observations - this problem had been driving me crazy on my Intel MacBook Pro 17" since somewhere mid-Snow Leopard and continuing now in Lion. It occurred with my big USB drives for Time Machine, rendering backups essentially impossible, and it occured with my efforts to upgrade my internal drive(s) using an Apricorn USB enclosure, and even using Winclone just to back up a 60 GB partition to any external USB drive.

     

    I reached the breaking point yesterday, and decided, in spite of what I had read, to try to replace IOUSBFamily.kext and IOUSBMassStorageClass.kext with their 10.6.4 versions - it just HAS to be a software problem. So, I just dragged the current kexts to the Desktop and dropped the old ones in.

     

    As you might guess, I rebooted and was treated to the login screen with no functional trackpad or keyboard. Stuck. Duh. That's what people SAID would happen. Since I was in my office with no access to another computer, I booted into my Win7 Bootcamp partition and used a free demo of MacDrive (which I think I will purchase now, btw) to copy the Lion kexts back where they belong.

     

    I blithely rebooted and, of course, no joy. Still no trackpad or keyboard. Same with single user mode - no keyboard input. So, I booted with Command-Option-R for Lion recovery, and ran Disk Utility to repair permissions. I was delighted to see it repairing permissions on the offending kext's. I blithely rebooted again, and still nothing. Then, with the addition of various choice expletives, I zapped the PRAM and reset the SMC. No luck. I then rebooted in Safe Mode, hoping that would rebuild the caches, and indeed, on reboot the machine was working properly once again.

     

    THEN, this morning, it occurred to me, maybe this giant headache from yesterday had magically fixed the problem. So, I ran Winclone, and successfully backed up the 60 gig partition to a spare 250MB drive in the enclosure. Then I used CCC to successfully back up my internal 250 gig drive to a 1TB drive in the same enclosure. I couldn't get ten minutes into these operations yesterday without the eject problem. So, it seems to me that my problem is solved, and it is definitely solved compared to yesterday.

     

    I have repaired permissions in the past without any luck, and I assumed that caches would have been rebuilt upon upgrade from SL to Lion. But, still, what I don't really know is which, if any, of yesterdays operations (permissions, safe mode boot, zap PRAM, reset SMC) would have solved the problem even if I had left the kext's alone. In any case, things are working fine at the moment, for the first time in well over a year.

     

    It feels a little like an old pocket watch that stops ticking and you slam it down on the table and it starts up again, but all I know is the problem is either fixed or has crawled off into the shadows for now, but I type this having booted from my new cloned 1TB drive.

  • Andy2006 Level 1 Level 1 (0 points)

    Sorry for all your trouble, but I'm glad you finally got the problem fixed (or at least made it go away for a while).

     

    I believe I am the original suggester of the "replacing the kexts will solve this problem for you" solution in this thread (although I certainly make no claim to have been the one who figured this solution out). For what it's worth, I have not had a single instance of premature ejectuation since replacing the offending kexts. I did have the non-working KB/mouse issue (think I used LogMeIn to fix), but I was able to remove just that kext from the repair recipe and now all has been well for months and months.

     

    Seems pretty obvious to me that THIS IS NOT A HARDWARE ISSUE, APPLE. This is a SOFTWARE ISSUE. I haven't let Software Update do anything to my machine since I last replaced the kexts because I don't want to go through the hassle again. I'd love for someone to verify whether the new kext solution works in Lion, because I'd like to upgrade someday.

  • Kelly Davis Level 1 Level 1 (15 points)

    Glad you got it working.

     

    If you look back at my post https://discussions.apple.com/message/16166836#16166836 you'll see that the same thing happened to me with the mouse not working. There was a problem with the kext helper b7 not installing the kexts after removing them.

     

    One way to recover from this, if you know (or can discover) the ip address of your machine on your network, is to ssh in and manually move the kexts. Even better, though, would be to not use the kext helper and just manually move the kexts (making backups of the existing ones).

Previous 1 30 31 32 33 34 Next