Previous 1 32 33 34 35 36 Next 938 Replies Latest reply: Feb 26, 2015 2:39 AM by Cali Xenon Go to original post
  • ticzon Level 1 Level 1 (5 points)

    Yes, this is a OS 10.6.8 or Lion feature only. Even if you are running iTunes 5, the WiFi feature doesn't show up in iTunes 5 unless you are in OS 10.6.8 or Lion (when you have your iOS 5 device connected to your computer, so you can set up WiFi sync). There is another discussion forum regarding this feature, and after doing some digging I found out that Apple fail to mention the OS 10.6.8 or Lion requirement for WiFi sync with IOS 5 devices. Meanwhile, older version of Windows have this WiFi feature.

     

    Sounds like Apple is trying to force us to upgrade to 10.6.8. However, with my experiences of dropping of USB external HDs in 10.6.5 thru 10.6.8, I will not make this upgrade because my data is more important than the WiFi sync.

  • OregonRob Level 1 Level 1 (0 points)

    I recently purchased a Western Digital (WD) My Passport Essential SE 1TB USB 2.0/3.0 drive and experienced similar problems: The drive worked fine for a few minutes, and then would invariably eject itself, even in the middle of Finder copy or Time Machine backup operation. (I have a MacBook Pro running Snow Leopard.) Thinking the drive was defective, I returned it for a replacement … and had exactly the same problem. An external drive that can't copy or backup is worthless.

     

    Fortunately, I had access to several different WD external USB drives and several different Macs. Tring different combinations, I concluded that the problem occurs only when both of the following are true:

     

    1. The WD external USB drive has a -01 model number.
    2. The current (recent?) version of WD SmartWare is installed.

    In particular, I have experienced the problem with the just the following model (two different drives);


    • WDBACX0010BBL-01 (WD My Passport Essential SE 1TB USB 2.0/3.0 Blue)

     

    But all of the following models work fine:


    • WDBACY5000ABL-00 (WD My Passport Essential 500GB USB 2.0/3.0 Blue)
    • WDBACY5000ARD-00 (WD My Passport Essential 500GB USB 2.0/3.0 Red)
    • WDBAAA6400ASL (WD My Passport Essential 640GB USB 2.0 Silver)
    • WDBABM7500ASL-00 (WD My Passport Essential SE  750GB USB 2.0 Silver)
    • WDBACX0010BBK-00 (WD My Passport Essential SE 1TB USB 2.0/3.0 Black)

     

    Note that -00 and -01 drives appear to have totally different series of firmware updates. The -00 drives have firmware versions such as 1.012 through 1.016 (the most recent as of a few weeks ago). In contrast, the -01 drives have firmware versions such as 1.003 (again, the most recent as of a few weeks ago). And the problem occurs when the current version of WD SmartWare is installed:


    • WD SmartWare Version 1.3.3.8

     

    But the problem does NOT occur when earlier versions are installed:


    • WD SmartWare Version 1.3.2.5 — but note that this earlier version of WD SmartWare does not appear to recognize the newer (?) -01 drives, so it is probably as if WD SmartWare isn't installed for these drives.

     

    For all my tests, I have been using various iMacs, MacBooks and MacBook Pros, all running the current version of Mac OS X Snow Leopard (10.6.8). Of course, the work around is to uninstall WD SmartWare, and the problem does appear to go away. This workaround would be acceptabe except that:


    1. You can't run S.M.A.R.T. diagnostics without WD SmartWare.
    2. You lose the convenient "Unmount Volume" menu bar command.

    Given the larger number of different combinations I tried, I conclude that the problem is NOT with a cable or with a particular drive but rather is a systematic problem involving a line of (newer?) drives WD SmartWare (for Mac, as I have not done any tests on PCs). Whether responsibility lies with the drive hardware, the firmware, WD SmartWare or some incopatibility with Mac OS X I do not know.

  • GaryCoyne Level 1 Level 1 (0 points)

    Excellent job and all very good but this doesn't explain why sometimes my card reader is kicked out, my USB flash drives are kicked out, or other problems that are not covered in your study.

     

    I'm not trying to rein in on your work here, it sounds like you've done an exhaustive study and a great job all around. It may in fact cover the issues around WD drives, but that's only part of the problem.

     

    Hopefully this will give someone somewhere the clue to break open this problem which either doesn't effect people at all, occasionally effects people, or causes major problems for people.

     

    Best,

     

    Gary

  • cosmoli Level 1 Level 1 (0 points)

    Hi Everybody. I understand that for most of you the solution is simple because you have no important data on the drive and can simply replace it by something better, but I do have all my photos and videos of my family from the last two years on my WD 1 TB and it only recently started doing this. It makes me wonder if it was an Apple software update that caused all our issues?

     

    In any event, there is no concrete sign of the drive itself being broken, this smells like a software or power issue to me as well. I can access all files on the drive but it keep ejecting after typically less than a minute of usage. I already bought a replacement drive but can't get stuff off the WD because I have hundreds of GB on it and it always ejects after moving a few hundred MB at the very most.


    What should I do? These data are absolutely precious to me and I'd pay whatever I can to recover them. I took the external plastic shell of the drive to see if there are any loose contacts. It looks like there is an unused connector on the drive. Perhaps I could try to use that?

     

    For the record, I tried accessing the drive with both my mid 2011 MBA as well as my wife's 2009 17" MBP. The issue is the same on both. Actually this makes me wonder if it is NOT a software issue as my wife never updates her software. I did drop the drive recently so maybe it is due to that. However I have exactly the same symptomatic as everybody else here and am able to access all files on the drive, if only briefly. How could I be able to do that if the actual HDD was broken? Doesn't make sense. Seems to make more sense that a connector got loose during the drop which is why I'm having the same issue as you guys.

     

    Anyway, I guess my question is if there is any other way of accessing the data except for the standard USB cable?

     

    Thanks so much for any suggestions you might have. I definitely learned my lesson to not only backup my Air's SSD but also my external media drives at all times.

  • GaryCoyne Level 1 Level 1 (0 points)

    At times where I had this happen to the degree that you are describing, I set myself up in front of the TV and copied items over in small quantum bits. Think 20 files at a time, that kind of thing. Yes this will take a long long time, but it should work. Plus, if you have an ejection, you will have better control on where the problem occurred and you'll know what files got copied and what files didn't.

     

    Good luck,

     

    Gary

  • cosmoli Level 1 Level 1 (0 points)

    I apreciate your suggestion but at the current ejection rate I would have to unplug and replug the WD drive around 1,000 times. I don't think this is feasible.

  • GaryCoyne Level 1 Level 1 (0 points)

    But my guess is that that will not happen. It's been my experience that if you transfer small quantum bits of data, e.g., 10 x 100 MB as opposed to 1 GB, there is less chance of the drive self-ejecting.

     

    I'm not saying that it wont self-eject, just as not as often as you think. If you know that 2 minutes is the maximum amount of time before it self-ejects, than figure out how much you can transfer in 1.5 mintues. Just many many times.

     

    It's worth a try, no?

  • userremoved Level 1 Level 1 (0 points)

    I use to have the ejecting problem with both my 2 TB Porsche drive and my 2 TB Verbatim drive, however one I replaced both drives with two 1 TB Verbatim drives my ejecting issue disappeared. I know this is not a scientific conclusion yet it might be worth it to note that my original 2 drives (Porsche and 2TB Verbatim) were USB 2.0 drives and my two replacement 1TB drives were USB 3.0 - I don't know if this information wil be helpful or not.

  • alanfromrohnert park Level 1 Level 1 (0 points)

    I was having a similar problem with my Seagate Goflex.   The software discussed in this article fixed it for me.

     

    http://www.seagate.com/ww/v/index.jsp?locale=en-US&name=goflex-mac-install-softw are&vgnextoid=77002aaf8cc5d210VgnVCM1000001a48090aRCRD

     

    Alan

  • Ian Downie Level 1 Level 1 (25 points)

    I'm kicking myself because I caused the problem myself, in a way. Eight months ago my iMac 24" had to have a new logic board fitted and the external drives started spontaneously ejecting not long after I set it up again.

     

    I now realise that the problem was caused by having the iMac plugged in as the master device on an energy saving power strip, to which the hard drive power supplies were also plugged in as slaves. I believe that the new logic board must consume less power than the original so that, when the display goes off, the power strip believes that the iMac has shut down and cuts the power to the other sockets on the strip. This usually makes the iMac display come back on and the power is restored to the other sockets, so it looks as if the drives have ejected for no reason. I'm pretty certain that the iMac was always plugged in to the master socket before the logic board replacement because otherwise the power strip would not have been live. I can't swear that the hard drives were plugged into the energy saving strip, but I'm pretty sure at least one was.

     

    It took a bit of effort and lots of wasted work to find the cause. I finally established that keeping the display from sleeping kept the drives mounted, then the final penny dropped when I found that shift-command-eject switches off the display. As soon as I hit those keys, the lights went out on the hard drives. The fix was to move the hard drive power supplies on to a power strip connected directly to the mains, so the display going off now affects only things like printers and a scanner, and other drives I use only occasionally. I will replace the energy saving strip with a conventional one as I bought it originally because I had a PC which was a significant contributor to global warming. I leave the iMac on all the time.

     

    I'm sure this is not the answer to everyone's problem but it doesn't half make me happy to have solved mine!

  • GaryCoyne Level 1 Level 1 (0 points)

    Interesting concept and I cannot fault your logic.

     

    Unfortunately that doesn't quite explain what's taking place when a drive self-ejects WHILE we are using the computer and/or transfering large quantities of data--again while we are using the computer.

     

    On the other hand, many people here have been trying to find software causes and perhaps there are minor electrical variations that are being interpreted as ejections which the computer then accepts and ejects the drive. Perhaps all that's necessary is a more robust electrical sensing interpretation of what connected drives are doing.

     

    Anyone have the electrical engineering expertise to comment on that theory?

     

    Gary

  • tingotanca Level 1 Level 1 (0 points)

    GaryCoyne wrote:

    [...] and perhaps there are minor electrical variations that are being interpreted as ejections which the computer then accepts and ejects the drive. Perhaps all that's necessary is a more robust electrical sensing interpretation of what connected drives are doing. [...]

     

    Exactly, that's what I've been trying to say the whole time. So, at the risk of repeating myself, I would ask people to at least try what I've done: since I started using shorter cables as explained on p. 26 (May 7, 12 and 14), I have not experienced one single disconnect.

     

    Message was edited by: tingotanca

  • Ian Downie Level 1 Level 1 (25 points)

    It's not just a concept, and it did affect file transfers because the display was set to sleep after 15 minutes (and various other times more recentlyas I experimented). The fact that the Time Machine drive often came back up again quickly enough to allow the backup to continue masked the problem. Other operations like installing Snow Leopard (and more recently Lion) on an external drive failed regularly but because the sleep time was so long I was never there when it happened as I have better things to do than watch a progress bar. Same thing happened with big backups to other drives.

     

    If you read way back in the thread, you will see that I found a work round which involved screen sharing from my MacBook Pro, allowing me to perform large file transfer operations. I now realise that sharing the screen stops the host display from sleeping. In the last couple of days, I had set the display to sleep 'Never' and made a black screensaver (which of course looks grey because the backlight is still on), and the drives stayed mounted all the time.

     

    Those without an obvious external cause are still stuck with their ejection problem but GaryCoyne and Tingotanca could be right in thinking that electrical noise could be responsible. Maybe the problems are related as there is obviously quite a big change in current to the Mac when the display switches off and that's often the source of nasty spikes which can affect electronic circuits either in the computer or in the disk drive.

  • Ellen74 Level 1 Level 1 (0 points)

    I've been able to at least temporarily resolve things by running Diskwarrior and Onyx.  Here's my story:  2010 MacBook Air.  Snow Leopard 10.6.8.  G-Drive Slim, 320 GB which I started using in September.  USB bus powered

     

    From the moment I started using the external drive, I've been getting the "not properly ejected" messages from time to time, BUT the drive remained mounted (or else immediately re-mounted) and worked fine.  Time machine has been running since Sept. without difficulty.

     

    Suddenly today, the drive started mounting for only a few seconds and then ejecting (with the "not properly ejected" error message).  Or it would freeze the computer (sometimes with spinning ball, sometimes totally frozen, sometimes peripherals worked, other times all USB peripherals froze -- e.g., external mouse and keyboard).  I had to do several hard restarts from the power button.

     

    The problem occurred regardless of whether I was using my USB hub or plugging directly into the port.  Plugging directly into the port maybe let the drive mount more often, but ejection and freezes were just as frequent.

     

    Here's what might help people get their drives back up and running, even if it isn't a permanent fix (I can post back in a week or so and let you know if things are still OK):

     

    - I ran Diskwarrior on the MacBook (booted off of CD) and let it replace the directory and also repair files and permissions.  This ALONE did not help.  (The DiskWarrior graph showed only 1 or 2% out of order, so maybe that's why it didn't make much difference.)  I couldn't run DiskWarrior on the G-Drive, as it wouldn't stay mounted.

     

    - I then ran Onyx on the MacBook (I checked every single item under "Automator" including repair permissions, even though Diskwarrior had just done that).

     

    - After running Onyx, the G-Drive mounted just fine!!  No ejections or error messages. So either Onyx alone or Diskwarrior plus Onyx fixed something.

     

    - HOWEVER in case there was damage to the G-Drive, I shut off Time Machine and ran Diskwarrior on the G-Drive (from the MacBook Air).  The directory was 46% out of order, which is a lot.  The directory replacement was almost complete when the laptop display started to sleep and everything froze.

     

    - I restarted and ran Diskwarrior on the G-Drive again;  this time I web surfed to make sure the laptop stayed awake.  The directory was replaced.  The graph shows less than 1% out of order. 

     

    For the moment, everything is working perfectly. The drive stays mounted, there have been no error messages, Time Machine is making backups, Finder seems much speedier, and "display sleep" isn't messing things up.

     

    Has anyone else tried running everything in the Onyx Automator?  Or the following sequence: DiskWarrior on the computer hard drive, then Onyx, then Diskwarrior on the external drive?   (FYI -- Onyx is donationware from Titanium.  Alsoft's DiskWarrior costs money, but is worth it IMO).

     

    I don't really understand what these utilities do, but for the moment I'm back in business.  I'd be happy to type out the list of what Onyx "Automator" does if that will help anyone figure this out.

     

    Is it possible there were 2 problem areas --

     

    - one in the Mac OS? or in Finder?, which was causing both the fake eject error messages and actual ejects (fixed by Onyx).

     

    - and another in the directory on the external drive, which was causing the freezes (fixed by Diskwarrior, but only if the laptop display stayed awake during the directory rebuild??). 

     

    It doesn't make any sense to me.  But for the moment everything is fine.

  • Sam Homerson Level 1 Level 1 (5 points)

    Hi cosmoli, please try to install a fresh copy of Snow Leopard 10.6.3; this version was the last one that did not have any issues with external drives in my experience. 10.6.4 up to 10.6.8 all have issues to varying degrees.

     

    Also, to sort of automate the task of copying over your files, you can use rsync, which is a command line tool. You invoke it as follows:

     

    rsync -avP /Volumes/"External Disk" ~/Downloads/External

     

    This would copy the contents of the external disk "External Disk" to a new folder "External" in your Downloads folder. You can invoke this command as many times as you want and it will only copy files that it has not yet managed to copy.

     

    One caveat: If the disk is ejected improperly, a stale directory may be left behind at /Volumes/"External Disk" and the next time the disk is connected, the system will create a new directory with a different name and mount the disk at /Volumes/"External Disk 1". As a result, the above rsync command will obviously fail. You cannot see this issue in Finder, as it hides the change of name.

     

    You need to run the following in Terminal to verify:

     

    ls /Volumes

     

    Then a spurious directory would show up with an added " 1" suffix. If that is the case, eject the disk and then

    erase the proper directory with

     

    rmdir /Volumes/"External Disk"

     

    This allows the system to create this directory again when you connect the disk again.

     

    Good luck!

Previous 1 32 33 34 35 36 Next