Previous 1 34 35 36 37 38 Next 938 Replies Latest reply: Feb 26, 2015 2:39 AM by Cali Xenon Go to original post
  • db247365 Level 1 Level 1 (0 points)

    I've had this problem with my My Book Essential 3TB WD drive now for months. I would be able to go 1-6 hours and then an eject. At first the drive worked perfect, but over the course of the first two months this problem started occurring regularly. It's been plugged in to a power supply, connected directly to the two different ports on my computer, and through a non-powered hub. Three days ago I connected it through a powered usb hub and since then the problem has not occurred at all. Further more I generally hear less noise from the drive which makes me think that it was being put into some kind of low power sleep and being woken intermittently before.

     

    I'm guessing that this is indicating that the problem was occurring from some kind of low power mode that the drive was being put into from the usb handling in osx. So, it's not to say that this operating system level problem is fixed, but that there may be a work around, being plugged into a powered usb hub.

  • db247365 Level 1 Level 1 (0 points)

    I SERIOUSLY can't believe this. Today, after 3.5 days, it happened, while plugged into a powered USB hub. I swear, when I typed the above post earlier today, I felt a tinge of "maybe I'm speaking too soon", but it had been three days! Then, this afternoon, boom, It happens for no apparent reason.

     

    I'm really frustrated now. I know that wiping the disc sometimes helps, but it seems to only help for a while before problems come back in. How come the port would fix the problem for three days and then it reoccurs? I'll keep this thread afloat of what I find out.

  • riker82 Level 1 Level 1 (0 points)

    I'm having the same issue with my Mac Mini Mid 2010 (Macmini4,1) and the same drive (WD My Book Essential 3 TB)...

     

    After startup, I receive the message "disk not ejected properly". On my Macbook, this does not happen.

     

    Lion updated to 10.7.2 and My book update to the 1.016 firmware

     

    Any help is appreciated

  • userremoved Level 1 Level 1 (0 points)

    In case anyone is interested, I had this exact same issue a few months ago. Fortunately for me, the issue has not happened since. As an aside, I am a self-employed I.T. Consultant who has been in the Technology field for the last 15 years.

     

    This was my setup when the issue kept occurring:

     

    13" Mid-2011 MacBook Pro

    1 Porsche 2TB USB 2.0 external drive (connected via a 6' USB A-B cable)

    1 Verbatim 2TB USB 2.0 external drive (connected via a 6' USB A-B cable)

     

    Here is my setup now:

     

    15" Mid-2011 MacBook Pro

    2 Verbatim 1TB USB 3.0 external drives (connected via two 3' USB A-B cables)

    1 WD My Passport 500GB USB 3.0 external drive (connected via a 3' USB Micro cable)

    1 Seagate GoFlex Free Agent 1TB USB 3.0 external drive (connected via a 3' USB Micro cable)

     

    My observations:

     

    Since the USB 3.0 standard is irrelevant for Mac's, I knew that this was not the underlying issue.

    My 2TB Porsche drive ended up dying on me about 2 weeks after the "disconnects" began happening, so I

    ended up recycling it to Goodwill.

    My Verbatim 2TB drive also died on me a few days after the Porsche drive died, so I returned it to Office Depot where I had purchased it.

    Since swapping out my 6' USB cables (which were only about 6 monts old) for brand new 3' USB cables, I haven't experienced a single "disconnect issue".

     

    My conclusion:

     

    Based on my experience with the "disconect" issue, and the research I had done at that time regarding possible solutions I now think that, at least in my case, the issue was happening because I was using interface cords which were too long (6' USB cables) and that, once I switched to shorter cords (3' USB cables), I experienced no more issues with random disconnetcs.

     

    Matthew B. Howell, Owner

    Gavn Group Consultations

    CompTIA A+ Certified Professional

     

    Message was edited by: gavnone

  • tingotanca Level 1 Level 1 (0 points)

    Thank you for confirming what I tried to tell this thread eons ago.

  • Ellen74 Level 1 Level 1 (0 points)

    Just curious -- would any of you be willing to try downloading the free maintenance app "Onyx" and then run only the "Automation Panel" ?  [Check off everything.  It'll take 20 minutes. From Titanium Software.  http://www.titanium.free.fr/index.php.]

     

    3 times it has solved the problem for me (until I disconnect the drive for a while; then it recurs).   After running Onyx (and not disconnecting the drive), I've now gone 14 days  without a problem.

     

    If this works for a few other people, maybe that will help narrow down the cause.

  • saneman Level 1 Level 1 (0 points)

    Have the same Drive and a Mac Mini, same issue and the same sleep disable download from Seagate, did apple fix this yet?

  • bug00 Level 1 Level 1 (45 points)

    I've been following this thread with great interest, and wanted to quickly share my experience. 

     

    Mine seems to occur completely randomly.  But when it does occur, I get the "ejected improperly" dialog.  I look on the desktop, and the icons for the external disk's partitions are gone.  The *moment* I click "okay" on the ejected-improperly-dialog-box, the icons for the external partitions magically reappear.  So apparently, they weren't actually ejected or disconnected.  It's just that the finder had lost track of them momentarily.

     

    Very disconcerting though, to say the least.

     

    I'm going to try the Onyx fix recommended, and will report back.

  • Ellen74 Level 1 Level 1 (0 points)

    Regarding the USB cord -- mine is very short, slightly less than 2 ft. long.   Maybe more than one thing can cause this. 

  • brian273 Level 1 Level 1 (5 points)

    Certainly more causes than the cord. Mine is 3 inches long and I still have the problem.

  • xefned Level 1 Level 1 (0 points)

    I've determined the short cord theory is just coincidental happenstance. I went back to the long cord and still had no more troubles. Whatever solved the problem for me is a complete mystery.

  • saneman Level 1 Level 1 (0 points)

    I Talked with Seagate who is repalcing my 3.0 USB dock, for my GoFlex Desk External Drive, with a 2.0 dock, because Apple and Intel have a compatibility problem switching down to 2.0 when the drive is 3.0. Intel's Mother boards don't support USB 3.0 yet and Mac is still sticking it out with Thunderbolt. Lacie Drives seem to be the only external drives that have a driver built in to confront this compatibility issue. I'm not saying this is your issue, but my computer ejects the drive and it will not come out of sleep the same as a few others have mentioned here.

  • ankhank Level 1 Level 1 (0 points)

    Thank you.

  • riker82 Level 1 Level 1 (0 points)

    finally found the root causa (at least for me)

     

    the problem was the journaled filesystem!!!!!

     

    Infact I saw a lot of errors of reading of the .fseventsd folder into the console log. Emptying this folder make the external disk works again. So I did for finally solving my issue was:

     

    1) emptying the .fseventsd folder into the external disk

    2) delete the time machine backup <-- this is mandatory in order to remove any hard links

    3) disabled the journaling on this disk (My Book Essential 3TB) from the disk utility app (pressing the OPT key and then File -> disabling journaling)

     

    in my opinion, the journaling option for this kind of disk, may is too heavy to handle for Lion....

     

    Unluckly, the next time machine backup, will re-enable the journaling.... but I've installed the "Time Machine Scheduler" that allow me to do backup less frequently.

     

    You can also do some kind of script that empty the fseventsd folder at shutdown (or startup)

     

    Hope this can help somebody else

  • GaryCoyne Level 1 Level 1 (0 points)

    Sorry, but it's not just Lion, it's also Leopard and Show Leopard.

     

    I'm not saying you are wrong, just correcting that one issue. Also, there have been a number of "eureka," moments by any number of people who later come back and say "well, apparently not..."

     

    Good luck though,

     

    Gary

Previous 1 34 35 36 37 38 Next