Previous 1 35 36 37 38 39 Next 949 Replies Latest reply: Aug 20, 2015 1:04 AM by Peter D Cox Go to original post
  • riker82 Level 1 (0 points)

    Infact I wrote "at least for me"


    In my opinion there is something wrong in the Kernel that cannot handle big disks with a big number of filesso that's why propably this issue occurr also on SL and Leopard

  • GaryCoyne Level 1 (0 points)

    Again, you are leaving out the issue that this also occures with flash drives. Not all that many files (comparied to a hard drive) on one of those suckers. (Also flash drives eliminate the issue of USB cord length.)





  • tingotanca Level 1 (0 points)

    Well, yes and no. While I've insisted a number of times that by using shorter cables – or rather what back then I called "strong" connections – the issue had gone away as far as my Firewire connections were concerned, I'd kind of forgotten about USB flash drives. A few days ago, I connected one of these, an ancient 125Mb model to my (wired) keyboard, and sure enough, I got the first "drive eject" in almost a year. The moment I connected it directly to the MacBook's USB port, the issue went away, and I was able to copy the files.

  • Ellen74 Level 1 (0 points)

    I just ran an experiment and am even more convinced that many of you should at least try running the entire "Automation Panel" in OnyX (free maintenance program at to see if it makes a difference.


    I know this is long, but bear with me…                              


    I just plugged my drive into my old 2008 MacBook (upgraded to Snow Leopard), and the constant ejects/error messages started immediately.  Ran OnyX, and all is miraculously fine.  (By the way, Time Machine is NOT running on this MacBook, so that eliminates Time Machine as a source of the problem.)


    A little background:  My drive is relatively small (391 GB capacity G-Drive Slim), and when my problems start up, they occur regardless of whether the drive is plugged into a powered USB hub or directly into my Snow Leopard MacBooks (2008 MacBook and 2010 MacBook Air). USB cord is under 2 ft.


    If the external drive is disconnected for several days, something between the computers and drive gets out of sync.  When re-connected, the constant ejects (and error messages) suddenly recur.  Running the OnyX "Automation Panel" fixes whatever it is, and the drive is then fine for weeks or months until I again disconnect for a while. 


    (Just FYI in case it helps anyone figure this out -- in the few seconds between automatic ejects, if I manually eject the drive and don't physically unplug it immediately, it'll re-mount itself and jump back into the continuous eject/error message loop.  Sometimes the icon disappears, reappears or changes.  After running the OnyX "Automation Panel,"  I can eject the drive, leave it plugged in and it behaves as it should, i.e., doesn't mysteriously re-mount itself.)


    I have very little clue what any of this means, but here's what the "Automation Panel" in OnyX fixes:


    - Repairs Permissions

    - Executes Maintenance Scripts

    - Rebuilds LaunchServices

    - Rebuilds Display of Folders Content

    - Rebuilds dyld's shared cache

    - Rebuilds Spotlight Index

    - Rebuilds Mail's Envelope Index

    - Cleans System Cache

    - Cleans User Cache (retains Audio Units Cache)

    - Cleans Fonts Cache

    - Cleans web browser cache and history

    - Cleans logs, including CrashReporter (retains OnyX, bash, and System Software Update logs)

    - Cleans Temporary and Recent Items


    As my older posts show, when I tried running just a few of the above, the fix was not consistent.  Some combination solves the problem, but having no clue which ones are essential, I just run them all.


    [And if you have freezes/crashes in addition to the ejects, be sure to run something like DiskWarrior on BOTH the computer and drive, as OnyX doesn't fix whatever DW (and similar software) does.]


    There may be several different reasons for the automatic eject phenomenon.  For some it may be hardware related.  On my computers, it looks like there's a software glitch or communication issue between the drive and computer that gradually worsens (especially when the drive has been disconnected from the computer for a while).  Luckily it can be set right by running the above maintenance/repair routines.

  • bobw409 Level 1 (0 points)

    WOW!  I appreciate the enthusiasm of some of the responses over the last 2 weeks...  As for some of the suggestions:


    It's not a cable issue for me.  I'm using a cable that's about a foot long plugged directly into the MAC's USB port.  I've tried both ports and different cables.  Neither solved the problem. I also tried a powered USB hub to no avail.


    The Western Digital My Passport drive I am using is USB 3.0, and I thought the fact that the MAC is only compatible with USB 2.0 might be a problem.  I did try a USB 2.0 cable with the 3.0 drive, but it didn't make a difference.  I had been using this particular drive for the better part of a year with absolutely no issues until recently.  So, even though this may be an issue for some, I don't believe this was causing my problem at this time.


    I have noticed that a lot of posts had been about issues with Time Machine.  This ejection problem wasn't occuring with the drive I use for Time Machine and it happened whether TM was on or off.  I don't believe this contributed to the ejection issues.


    I thought it may have been a formatting issue.  I formatted the drive as exFAT to be compatible with both my MAC and PC without the limitations on file size as with FAT32.  Again, this drive worked for almost a full year with no problems.  When the ejection issue started, I tried transferring the files from this drive to another to save my music from that great trash bin in the sky.  During transfers, the drive kept ejecting on the MAC.  I used a PC to transfer the files to a drive formatted in FAT32 and after a couple of days I was able to save all my music.  I plugged the problem drive back into the MAC to reformat it as a MAC extended (journaled).  During the erase process, the drive could not be unmounted and I received an error message.  Now, the drive is not recognizable in either the MAC or PC which makes it useless.


    The good news for me is that my drive is still under warranty.  I believe that the issue has to do with a failing drive and nothing else.  Although this drive was not plugged in constantly, it still had it's fair share of use when it was because it's used to hold my iTunes library which is pretty large.  Perhaps the constant accessing and writing of new music/files to the drive caused it to wear out before its time?  Who knows?  I'm currently using another My Passport drive formatted in MAC OS extended (journaled) and I am having no issues for now.  If that changes I'm sure I'll post again. I'm in the process of putting together a NAS drive so hopefully I won't have to worry about something like this in the future.


    Thank you all for the suggestions. Good luck to those who still have this problem.

  • db247365 Level 1 (0 points)

    Just to update people, since several days ago of plugging my drive into a powered USB hub I have experienced two ejects. I have been able to leave things running for hours on end with no eject. Occassionally I get the eject (twice in about 5-6 days) but nowhere near like it was. Things seem to have stabilized but are still not immune to the problem.


    If in fact the logic boards on mac have a problem resolving the usb 3 connection (my WD essential 3TB has USB 3 only) then this could explain some quirkiness.


    All in all things have been much more stable since plugging into a powered USB port, although not 100% trouble free.

  • Richard E. Cooke Level 2 (220 points)

    You made a good start, but now you have to be more methodical.


    I posted this a few months ago, its the general-purpose diagnostic procedure for electronic devices.  If you follow it, you will either figure out the true root cause on your own, or you will be able to post enough information for people like me to figure it out for you.


    If you want answers or help (especially from me) then you have to do this, in order:


    - Google your drive make and model, see if anybody else is having the same problem. If you are the only person on the planet with drive "XYZ" with a problem then chances are you have a hardware problem in the drive, computer, hub, or cables (not necessarily in that order).


    - if there is a support site for the drive post a question there about your symptoms (and read/search previous posts). Again, if your the only person in the world with a problem...


    - Search this thread for you drive make (not model) to see if there have been other problems with their products (actually this is a good idea for a google search too). I tell clients to do this BEFORE they buy something for the first time. This comes under "buyer beware".


    - Do some experiments. Try the drive on other computers, different cables, no hub, different USB jacks. Try READiNG only small files, then large. Try WRITING small files, then large. Try it after it's been OFF overnight. Try it after the computer and hub have been OFF overnight. Try it with nothing else running on the computer. Change the drive format, does it matter if it's exFAT, NTFS, or OSX Journaled?


    - Post your symptoms and test results here. If you want help and not just platitudes and "me too"s you must include the drive make, model and any other potentially useful info like date of manufacturer, the disk drive make/model iniside. Go into System Profiler and grab all the USB info.


    - Check to see if the drive has the same USB chip ID as the two we have already found in problem drives. Googling the chip ID sometimes can tell you quite quickly if there is a problem and a fix.


    I know this is potentially a lot of work, I go through this process nearly weekly for clients. The problems change, but the process remains is the same.


    The only "quick fix" is to find a solution or workaround with Google. I will spend a few hours reading every post even remotely related to a problem, looking for clues to the problem or a fix. In most cases a workaround is acceptable - it depends on how annoying the workaround is.

  • oscarfromguilford Level 1 (0 points)

    Richard E. Cooke is right about this! With due respect for people's efforts and also for the frustration this problem has caused, these recent posts have been driving me crazy, the same as some of my "experiments" were driving Richard E. Cooke crazy a few months back.


    Diagnostic parsimony suggests that instead of a symptom having 20 causes, it probably has only one. I'm pretty sure that if people post their USB chip ID's, we will see the same offenders. I know once I started using drives with different chips, my problems disappeared for good, instead of requiring constant voodoo.


    I'm still following this thread, though, because I'm only "pretty sure" but I would be delighted to see the root cause of this problem pinned down.

  • Richard E. Cooke Level 2 (220 points)

    Diagnosing Sophisticated Electronic Systems is like peeling an onion.


    You have to work your way through many layers of "skin" to get at the "root cause". 


    And it will likely make you cry.


    Consider yourself lucky if you only have ONE problem.  The most challenging problems to solve are those with multiple issues at the same time.


    Looking back over this thread, there are at least 6 different problems in here.  Some of them have similar symptoms, which has caused confusion - people arguing about what was wrong!


    I volunteer my time to help others because I feel a responsibility to do so.  I was a "beginner" to this once, I remember all too well how frustrating it was to figure out problems.

  • saneman Level 1 (0 points)

    I figured my issue out, it was a compatibility issue with the USB 3.0 dock on my Seagate GoFlex Desk and Mac and Intel not being fully compatible. They switched out the Dock to a 2.0 super USB and problem solved. "Steve Jobs made a point of saying that No Intel support was a big problem for Apple when it came to USB 3.0. With Intel planning USB 3.0 CPUs for early 2012, there’s just no way they’ll jump ship to a third-party manufacturer instead of just waiting it out." This was a excerpt from an article from "Cult of Mac" a few months before his stepping down.

  • db247365 Level 1 (0 points)

    After a couple of weeks of only getting ejects every three days or so, it's started to happen regularly through my powered USB hub. I just don't get what I did that would temporarily stabilize things, and then have it go off the rails again on it's own. I would think if it's a problem based on quantifiable variables, that it would happen with a predictable regularity. I don't get why plugging it into a hub would help for two weeks only to have it start up this behavior again with nothing changed.

  • Ellen74 Level 1 (0 points)

    Anyone else willing to try the freeware OnyX (to see if it makes a difference)?  For me, it stops the eject nonsense for at least 2 weeks (often longer if I don't  disconnect the drive for any reason).  I might get one eject message on the initial bootup after running OnyX, but then things are fine for a long time.  I've been replicating this again and again on two different laptops.


    For the folks interested in the chipset info. --  is that the product ID for the external drive?  Mine  is 0x8005; is that one of the problem ones?


    If you want to try OnyX, download from and run the entire "Automation Panel"  (check off all options.  Can take about 20 minutes; if it looks frozen during the permissions repair, it isn't.)


    Also, for those in the know, is it possible that this is a hardware issue that's ultra-sensitive to something going on with the software?  On my computers, it seems that something builds up over time, and running a maintenance/repair program clears everything out and fixes it for a while.  [For me, the problem crops up regardless of where the drive is plugged in, regardless of cord length, regardless of whether Time Machine is turned on, and regardless of computer (2008 and 2010 laptops, both running Snow Leopard)].


    For those who know what this means (I don't really);  here's what the "Automation Panel" in OnyX fixes:


    - Repairs Permissions

    - Executes Maintenance Scripts

    - Rebuilds LaunchServices

    - Rebuilds Display of Folders Content

    - Rebuilds dyld's shared cache

    - Rebuilds Spotlight Index

    - Rebuilds Mail's Envelope Index

    - Cleans System Cache

    - Cleans User Cache (retains Audio Units Cache)

    - Cleans Fonts Cache

    - Cleans web browser cache and history

    - Cleans logs, including CrashReporter (retains OnyX, bash, and System Software Update logs)

    - Cleans Temporary and Recent Items



  • Kelly Davis Level 1 (15 points)

    I've used OnyX and it did clear it up for me, at least temporarily. I wasn't able to narrow it down to a particular task in the automation panel, though. One thing that I think may be significant is my usage pattern. The external drive is used for periodic time machine backups. I don't leave the drive connected most of the time. The computer is not used very much, so it can be several weeks between backups.

  • Richard E. Cooke Level 2 (220 points)



    Your close.  What we are tracking is the "Vendor Id".  Although I would rather you copy and paste ALL the device info here so we have a record of what you have.


    For example, I have a Seagate drive, when I go into System Profiler and click on the USB hardware tab, I can see a device named "Seagate" and it has this info:


      Capacity:          1 TB (1,000,204,884,992 bytes)

      Removable Media:          Yes

      Detachable Drive:          Yes

      BSD Name:          disk1

      Product ID:          0x3008

      Vendor ID:          0x0bc2  (Seagate LLC)

      Version:          1.38


    The USB interface chip in my drive is a "0x0bc2" - and Apple even provides the manufacturer name "Seagate LLC".  This is NOT one of the chip mfrs that we have observed to have a problem.  Please post yours.


    As an over-view this is what the System Profiler screen looks like:



    Notice there is a lot of information under "Seagate" that we don't need, but no harm if you post it.


    I'd be happier about accepting Onyx "fixes" your problem if you could narrow down WHICH of those tools actually fixes it.  A bit more testing, but if you can figure out exactly which item(s) fixes it, then I might be able to figure out the puzzle and give you a permanent cure.

  • Richard E. Cooke Level 2 (220 points)


    If you were not doing any work on the drive at the time of the disconnect, then you are likley looking at a thermal problem - something overheated.


    What happens AFTER it ejects?  Does it re-attach by itself?

Previous 1 35 36 37 38 39 Next