Previous 1 38 39 40 41 42 Next 949 Replies Latest reply: Aug 20, 2015 1:04 AM by Peter D Cox Go to original post
  • bfreebody Level 1 (0 points)

    Late 2009 iMac (27") 3.06 core2duo LION, 4GB 1067 mhz RAM.


    I have issues with both USB pen drives and the memory card slot.


    This issue with the disk unmounting ungracefully happens with any memory card and is happening with a pen drive I own, it DOES NOT happen with my 2TB powered external HDD (iomega).


    I have run disk diagnostics and found that I had some hard file link issues which I repaired using the book disk util of Lion.


    The issue reoccurs in much the same manner post repair.


    I am adding my issues to this thread to assit this issue in its bid to gain some traction.


    Good luck to all of you with the same problems. What a pain.



  • Richard E. Cooke Level 2 (220 points)



    I'm not surprised, based on your initial post I would have guessed the drive is over-heating then crashing.


    If you read back through the 40-pages of this topic you will find users that have had various problems, all causing their drives to eject unexpectedly.  See if any of them match your symptoms.


    You will also find a posting I did with a master troubleshooting list of things to do.  I highly reccomend the first item: Google search your drive make and model to see if there is a product recall, or a workaround.

  • bfreebody Level 1 (0 points)

    I have found that MOVESLINK s'ware causes the issue when it is running.


    Disabling the MOVESLINK s'ware stops my issue dead.


    Enabling MOVESLINK s'ware causes the following errors to be generated.


    12-02-08 11:34:30.000 AM kernel: 0    0 AppleUSBCDC: start - initDevice failed


    I'm not sure how the two are related but thought to post my experience.



  • zaphoda Level 1 (0 points)

    I agree that some of these ejections may be caused by a USB problem. After switching my external disk connection from USB to FireWire a month ago, I have had no problems.

  • Kelly Davis Level 1 (15 points)

    Just another data point (which I hope isn't dismissed by those who are really thinking about this):


    I have 3 Macbook pro laptops. One 13" that was purchased August 2009, another 13" that was purchased August 2010, and a 15" purchased October 2010. All are running 10.6.8. Disk eject occurs in 13" 2010 and 15" 2010. Disk eject issue never occurs in 13" 2009. (This is all using the same external USB hard drive)


    I know there was at least one hardware rev between summer 2009 & summer 2010 on the 13". While there certainly may be some interaction with the external usb , unless all 3 were experiencing the same issue, it can't just be a problem with the usb drive.

  • db247365 Level 1 (0 points)

    My MBP is the last 2006 model, basically the first core 2 duo, and it's presenting with this problem.


    Also, as for people saying switching the disk connection from USB to Firewire, are you saying that you have some kind of usb-firewire hub and are plugging the drive to the hub and then to computer via firewire, or are you all talking about removing the drive from it's enclosure and putting it in a new firewire enclosure?

  • zaphoda Level 1 (0 points)

    In my case, I have both firewire and USB ports on my DROBO (a set of 3 hard disks I use for backup), and of course, both USB and firewire ports on the back of my iMac. Using the USB ports, I had the disk ejection problem regularly. I removed the USB cable and started using the firewire cable, and the problem has stopped.


    No hubs involved.

  • Kelly Davis Level 1 (15 points)

    It's funny how things work, but after an hour or so of attempting to run disk repair on my 2009 mbp the disk ejection issue occurred. So it doesn't seem to be due to a difference between the models.


    In frustration I went to my local CompUSA and purchased this USB/SATA adapter for $12 + tax. I connected it to the drive and attempted to repair it as it was no longer mounting correctly. Disk repair couldn't fix the disk so I decided to erase it and start from scratch. After doing this, I did a full time machine backup without any issues. The eject issue could either have been fixed by starting with a clean disk or the new adapter. I suggest that maybe for $12 people get one of these and experiment with it to see if it fixes it. I'll post again if I run into ejects with this adapter down the road.

  • Allen Huffman Level 1 (65 points)

    Ironically, Apple has only recently closed the bug report I filed about this, saying it was a Drobo issue.


    Ironic, because it was Drobo that told me it was an Apple issue, and provided ME with the patch that THEY got from APPLE to fix said issue ;-) At any rate, my issues were resolved by upgrading to 10.6.8.


    I have not noticed the issue with 10.7.

  • GaryCoyne Level 1 (0 points)

    Allan, that is pure bunk. For Apple to point to Drobo, or any other manufacturer and say it's their fault is not only wrong, it's libelous. Apparently, according to Apple, every instance of this is "the other guys fault." Whomever from Apple wrote that should be fired.

  • Allan Eckert Level 8 (49,665 points)

    I don't think things work that way in business. You might wish they did but that carries absolutely no weight with anyone but you. Sorry.



  • db247365 Level 1 (0 points)

    This is what drives me nuts, in my case with Western Digital and Apple. Western Digital points the finger to Apple or the user on their forums, despite having hundreds of posts about the problem.


    Apple points the finger at Western Digital.


    And the user is screwed!


    Bottom line though, it's Western Digital who should absolutely NOT be putting the apple symbol/mac osx compatible on their drive boxes if there is a known problem. They sell a specific drive for mac that has only usb 2 connections. Then DONT put mac compatible on all of your freakin drives! This drives me nuts. I guess this is maybe Apple's fault as well, since they license and approve the use of their name/symbol?


    I would have never bought this drive if I could forsee these problems. It is beyond annoying. But I'm not made of money and I don't feel like bricking my nice 3TB drive, especially knowing hte next drive could have problems as well. In this realm I think Apple really has to do a better job of supporting external drives in a variety of configurations in the OS. In 2012 this is just unacceptable.

  • Allan Eckert Level 8 (49,665 points)

    One of the primary reasons I get my disks from


    They stand behind their products.



  • riker82 Level 1 (0 points)

    Same situation here.

    My Book essential 3 TB USB 3.0 and Macmini mid 2010.


    Wd says, It's Apple fault.... Try to guess on Apple side. My issue occurs on boot... I just solved temporarily starting fusion and a vm with win xp and MacDrive Standard installed on It. Then I unmount the disk and everything start to work again.


    In the past, when this problem occurs, the HFS journal start to be corrupted so I've disabled It.... (no_log file under .fseventsd folder)...


    Strange things is that when my MacMini start to see the disk, everything works fine even if reboot or shutdown the Mac and restart It in less of two hours. If the shutdown time lasts more than two hours, at the next boot, the issue is still there....


    Already tried different cable (even micro USB)... Reinstalled the Lion from scratch...


    Connecting a different disk, no improperly ejections....

  • ankhank Level 1 (0 points)

    This looks like a clue:



    Same dropout problem experienced with a Mac  Mini.


    It's a guy testing Thunderbolt gear, he's describing seeing voltage spikes on various power buses as drives are ejected/connected -- sufficient to make some drives drop their Thunderbolt connection.


    He says it's a familiar problem and the Mini has a cheap power supply and needs a better one.


    Sad if true.   That could explain why there's not been a software fix.

Previous 1 38 39 40 41 42 Next