Previous 1 39 40 41 42 43 Next 940 Replies Latest reply: Apr 21, 2015 3:54 PM by Sasha_yu Go to original post
  • tingotanca Level 1 Level 1 (0 points)

    Possible, except that it can happen on other machines too – my (one of two) MacBook Pro in particular.

  • macjansson Level 1 Level 1 (0 points)

    My WD drives starded ejecting themselves a few days ago, both the drive used for Time Machine and another WD drive used for random storge. Took me a while before i checked for firmware updates for the drives, found that WD offered updates and after installing the new firmware from WD my drives seem fine.

  • riker82 Level 1 Level 1 (0 points)

    In my case, Mac Mini mid 2010 + Lion + Wd MyBook essential USB 3.0 the root cause was Remote Buddy that used tO start @ boot. Disabling It and launching few minutes after the startup, my issue finally seems to be solved (I've opened a support case to Remote Buddy in order to solve the problem )

  • Is there a vet in the house? Level 1 Level 1 (145 points)

    I've been having problems with a powered LaCie USB drive (used for Time Machine backup) ejecting without warning when another properly-ejected USB device (often a thumb flash drive) is disconnected from my Mac Pro (early 2009). AppleCare have had the Mac Pro out for repair three times in the past couple of months but their so-called "fully-trained" technicians haven't got a clue and can't even replicate the problem.

     

    I'm beginning to wonder whether the good people at Apple have a clue about how their own products work.

  • db247365 Level 1 Level 1 (0 points)

    After contacting Western Digital several times armed with some information I did get a response from a tech there that indeed there is a known problem with Mac's having trouble 'stepping down' the usb 3 to usb 2 protocol, something which is supposed to happen by default when a usb 3 device is plugged into a host that only supports usb 2. They sent me a usb 2 cable for my drive instead, which funny enough just has a usb to micro connection that plugs into half the usb s.s. port. It's kind of an awkward conneciton, but I'll let you know how it goes.

  • fei por Level 1 Level 1 (20 points)

    I backup up in FEB 2012 before I left Hong Kong for Singapore - NO problems then. I returned to HKG last night and since then it has been ejecting the very same Maxtor external drive I have used before, Time Machine or no Time Machine.

     

    Any ideas?

  • Ellen74 Level 1 Level 1 (0 points)

    This happens to me every time I travel.   For me, it is easily fixed by running everything listed under the "Automation Panel" in the freeware maintenance/repair utility "OnyX."  From Titanium Software.  http://www.titanium.free.fr/index.php.   (see my prior posts)

     

    On my system, the problem can be triggered 3 ways:  sometimes it happens spontaneously after 3 or 4 months of use (Time Machine backups);  sometimes it occurs after I've had to disconnect my external drive several times for some reason;  and it nearly always occurs when the external drive is disconnected for a while during travel.

     

    No clue what causes it.  All I know is that for me, OnyX fixes it, and I'm good for several months.

    Please respond back if it fixes it for you.

  • fei por Level 1 Level 1 (20 points)

    Tried out your suggestion but my Maxtor ext hard drive still "self ejects" or gets ejected.

  • Ellen74 Level 1 Level 1 (0 points)

    That's too bad.  There are very detailed hardware discussions in this forum;  maybe one of those posts will help.

  • VanessaVG Level 1 Level 1 (0 points)

    I couldn't go through this entire forum but the quick answer is this:

     

    Macs don't give enough power via the USB, therefore your external drive will eventually go to sleep or turn itself off or whatever. You need to have either an external drive with its own powersource or connect the drive via Firewire cable/connection.

  • db247365 Level 1 Level 1 (0 points)

    If you would have read the forum you would have known that many of us are using drives with their own power supply, and/or drives plugged into powered hubs. I've used all of the above scenarios. WD admitted to me that their is a known problem with macs stepping down USB 3 to USB 2 and sometimes having power and connectivity issues with these drives.

     

    An upadate on my situation: Western Digital sent me a USB 2.0 cable, which was half of their super speed 3.0 cable (USB micro B to USB). This cable seemed to fix my self eject problems with the drive, BUT... then the drive failed on me. Figuring my data was more important than the cost of the drive, I jacked open the enclosure and removed the drive. What I found in my case was that the USB controller board that's screwed into the drive as part of the WD enclosure had partially burnt up. Further more, there was heat dispersing sticky tape applied to the controller board. When I took it to a computer electronics shop they said that's what they do when the board isn't passing testing properly but is still considered 'saleable'. So  WD had a cheap controller board in the enclosure that was basically a faulty yet salvageable board. I purchased a new enclosure and slid the WD caviar drive into it. Unfortunately what I did not know was that these My Book Essential drives are encrypted by a special WD encryption algorhythm, and that the data is basically unrecoverable. Luckily I had the data backed up in many other places although it took me a long time to pull it all back together. The drive has since been reformatted and is working like a charm.

     

    Long story short, I think I'll be putting together my own enclosure/drive combo's in the future. As I understand it WD takes this $100 drive and puts it in a $9 case, and many of these enclosures create the problems rather than the drives themselves. I've had too many drives go bad that probably started with or were entirely related to cheap enclosure problems.

     

    Good luck to everybody out there. My best guess is that many of you are having these USB 3 to USB 2 step down issues. No one has really addressed these issues directly yet and it's probably not likely to happen as Apple looks towards USB 3 integration in their next series of hardware releases. If you're at all electronics comfortable and can back up your drives I'd go get a new specifically USB 2 enclosure at a micro center or some such and liberate your drive. I'll continue to watch this thread for updates as I still want to understand these problems better.

  • Nemrod Level 1 Level 1 (0 points)

    Hi,

     

    I have the same issue, I own two Mac, a MBP (1) and a Mini (2).

     

    On both i have externals WD Drives, a My Book Essentials 3 To (USB 3.0) for the (1), using a Hub Belkin, and two Elements Desktop 3 To (USB 2.0) for the (2).

     

    Both are brand news and on both i have the same problem, or it looks like, they anmount themself.

     

    For the (1) I don't think it's the Hub, i have the same problem with the drive directly plugged to the (1). I don't think it's the USB cable, not on both computers.

     

    For the (2), it happens on one drive while transfering files from the (1) to (2) using home WiFi.

     

    Cheers

  • db247365 Level 1 Level 1 (0 points)

    I explained my problem about the my book essential 3tb to WD and they sent me a replacement USB 2 cable. Honestly your best bet is to go to a computer store and buy a USB to micro b cable (that's all WD sent me). It's just have the super speed cable that the 3 is. You just plug it into half of the port that it fits into. This solved my self ejecting issues. The problem is apples handling of the USB 3 input and stepping it down to USB 2 is causing power management problems with these drives. Most WD people will give you the run around, but if you're prepared and talk to someone knowledgable they'll admit it's a known problem and send you the tiny cable. It's about 1 foot so I still went and bought my own.

  • EJCmac Level 1 Level 1 (0 points)

    This could explain my problem.

    All USB ports working fine until Mac Book Pro power cable failed (battery doesn't even last till log-in screen).

    Didn't want to pay over-priced Apple replacement power cable costs so bought a knock off on ebay.

    It powers the Mac Book, but consequently causes the neighbouring USB port to eject anything in it after about 5 minutes (including a mouse and an externally powered hard drive).

    The USB port works fine with a borrowed bona-fide power cable.

     

    I find the cost of a replacement battery and power cable to be too high considering the short life-span of the hardware.

  • fei por Level 1 Level 1 (20 points)

    But mine are the genuine Apple power cable, etc. Unless, of course, that their QC isn't much good and they are not superior to non-Apple versions.

Previous 1 39 40 41 42 43 Next